summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-12-07 16:25:18 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-12-07 16:25:18 +0000
commit40dd72ee7f3b4791401930a95eba3f5f47f5da6b (patch)
tree8a2ac6ddab9d8cc99ecff319590f08b6a259029b /app-pda/libsyncml
parentStable for HPPA. (diff)
downloadgentoo-2-40dd72ee7f3b4791401930a95eba3f5f47f5da6b.tar.gz
gentoo-2-40dd72ee7f3b4791401930a95eba3f5f47f5da6b.tar.bz2
gentoo-2-40dd72ee7f3b4791401930a95eba3f5f47f5da6b.zip
Update the scm ebuild wrt to the upstream switch to cmake. Make obex and debug default.
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog6
-rw-r--r--app-pda/libsyncml/libsyncml-9999.ebuild35
2 files changed, 16 insertions, 25 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 617f43bb15fd..507d3ef12d01 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/libsyncml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.6 2007/11/26 20:10:00 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.7 2007/12/07 16:25:18 peper Exp $
+
+ 07 Dec 2007; Piotr Jaroszyński <peper@gentoo.org> libsyncml-9999.ebuild:
+ Update the scm ebuild wrt to the upstream switch to cmake. Make obex and
+ debug default.
*libsyncml-9999 (26 Nov 2007)
diff --git a/app-pda/libsyncml/libsyncml-9999.ebuild b/app-pda/libsyncml/libsyncml-9999.ebuild
index fba7b6521219..b844df2d9e09 100644
--- a/app-pda/libsyncml/libsyncml-9999.ebuild
+++ b/app-pda/libsyncml/libsyncml-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.1 2007/11/26 20:10:00 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.2 2007/12/07 16:25:18 peper Exp $
-inherit eutils subversion autotools
+EAPI="1"
+
+inherit eutils subversion cmake-utils
DESCRIPTION="Implementation of the SyncML protocol"
HOMEPAGE="http://libsyncml.opensync.org/"
@@ -13,7 +15,7 @@ ESVN_REPO_URI="http://svn.opensync.org/libsyncml/trunk"
KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="bluetooth debug doc http obex"
+IUSE="bluetooth +debug http +obex"
RDEPEND=">=dev-libs/glib-2.0
>=dev-libs/libwbxml-0.9.2
@@ -53,26 +55,11 @@ pkg_setup() {
}
src_compile() {
- eautoreconf
-
- econf \
- $(use_enable bluetooth) \
- $(use_enable obex) \
- $(use_enable http) \
- $(use_enable debug) \
- $(use_enable debug tracing) \
- --disable-unit-tests \
- || die "econf failed"
- #$(use_enable test unit-tests) \
-
- emake || die "emake failed"
-
- use doc && doxygen Doxyfile
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable debug TRACE)"
- use doc && dohtml docs/html/*
+ cmake-utils_src_compile
}