summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-14 20:14:24 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-14 20:14:24 +0000
commit9b07b68df3ade9bde48d32d8c5e7bc9996dcc336 (patch)
tree70b0d9dffbd3d5fb3a34f86544ada92f4d161129 /app-pda/libopensync
parentRevbump. Fix a typo breaking plugin installation. Possibly improve mime-type ... (diff)
downloadgentoo-2-9b07b68df3ade9bde48d32d8c5e7bc9996dcc336.tar.gz
gentoo-2-9b07b68df3ade9bde48d32d8c5e7bc9996dcc336.tar.bz2
gentoo-2-9b07b68df3ade9bde48d32d8c5e7bc9996dcc336.zip
Revision bumps, remove old.
- backport all ebuild fixes from 0.39 - patch 0.22 to find python correctly and add swig version detection for versions greater than 1.3.x (bug #328691) - fix TypeError in python wrapper (bug #340605) - add debug support back to 0.39 - drop .la files (Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libopensync')
-rw-r--r--app-pda/libopensync/ChangeLog17
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-pythonpath.patch63
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch13
-rw-r--r--app-pda/libopensync/files/libopensync-py2.6.patch65
-rw-r--r--app-pda/libopensync/libopensync-0.22-r1.ebuild90
-rw-r--r--app-pda/libopensync/libopensync-0.36-r1.ebuild78
-rw-r--r--app-pda/libopensync/libopensync-0.36-r2.ebuild127
-rw-r--r--app-pda/libopensync/libopensync-0.39-r1.ebuild21
-rw-r--r--app-pda/libopensync/metadata.xml6
9 files changed, 322 insertions, 158 deletions
diff --git a/app-pda/libopensync/ChangeLog b/app-pda/libopensync/ChangeLog
index 50e6c2cfccc8..609e8d679ece 100644
--- a/app-pda/libopensync/ChangeLog
+++ b/app-pda/libopensync/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for app-pda/libopensync
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.38 2011/02/12 03:51:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.39 2011/02/14 20:14:23 dirtyepic Exp $
+
+*libopensync-0.36-r2 (14 Feb 2011)
+*libopensync-0.22-r1 (14 Feb 2011)
+
+ 14 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> +libopensync-0.22-r1.ebuild,
+ -files/libopensync-py2.6.patch, +files/libopensync-0.22-pythonpath.patch,
+ +files/libopensync-0.22-swig-typeerror.patch, -libopensync-0.36-r1.ebuild,
+ +libopensync-0.36-r2.ebuild, libopensync-0.39-r1.ebuild, metadata.xml:
+ Revision bumps, remove old.
+ - backport all ebuild fixes from 0.39
+ - patch 0.22 to find python correctly and add swig version detection for
+ versions greater than 1.3.x (bug #328691)
+ - fix TypeError in python wrapper (bug #340605)
+ - add debug support back to 0.39
+ - drop .la files
*libopensync-0.39-r1 (12 Feb 2011)
diff --git a/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch b/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch
new file mode 100644
index 000000000000..abfb68cbdb33
--- /dev/null
+++ b/app-pda/libopensync/files/libopensync-0.22-pythonpath.patch
@@ -0,0 +1,63 @@
+diff --git a/acinclude.m4 b/acinclude.m4
+index 2bf9951..a3b617c 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -1008,9 +1008,9 @@ AC_DEFUN([AC_PROG_SWIG],[
+ if test -z "$available_patch" ; then
+ [available_patch=0]
+ fi
+- if test $available_major -ne $required_major \
+- -o $available_minor -ne $required_minor \
+- -o $available_patch -lt $required_patch ; then
++ if test $available_major -lt $required_major \
++ -a $available_minor -lt $required_minor \
++ -a $available_patch -lt $required_patch ; then
+ AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
+ SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
+ else
+@@ -1114,7 +1114,7 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+ AC_MSG_CHECKING([for Python include path])
+ python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
+ for i in "$python_path/include/python$PYTHON_VERSION/" "$python_path/include/python/" "$python_path/" ; do
+- python_path=`find $i -type f -name Python.h -print | sed "1q"`
++ python_path=`find $i -type f -name Python.h -print 2>/dev/null | sed "1q"`
+ if test -n "$python_path" ; then
+ break
+ fi
+@@ -1129,8 +1129,8 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+ # Check for Python library path
+ AC_MSG_CHECKING([for Python library path])
+ python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
++ for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/lib/" ; do
++ python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print 2>/dev/null | sed "1q"`
+ if test -n "$python_path" ; then
+ break
+ fi
+@@ -1142,16 +1142,21 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+ fi
+ AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -lpython$PYTHON_VERSION"])
+ #
+- python_site=`echo $python_path | sed "s/config/site-packages/"`
+- AC_SUBST([PYTHON_SITE_PKG],[$python_site])
++ # site-packages directory
++ #
++ AC_MSG_CHECKING(python site-packages)
++ PYTHON_SITE_PKG=`$PYTHON -c "from distutils.sysconfig import get_python_lib; \
++ print get_python_lib()"`
++ AC_MSG_RESULT($PYTHON_SITE_PKG)
++ AC_SUBST(PYTHON_SITE_PKG)
+ #
+ # libraries which must be linked in when embedding
+ #
+ AC_MSG_CHECKING(python extra libraries)
+ PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
+ conf = distutils.sysconfig.get_config_var; \
+- print conf('LOCALMODLIBS')+' '+conf('LIBS')"
+- AC_MSG_RESULT($PYTHON_EXTRA_LIBS)`
++ print conf('LOCALMODLIBS')+' '+conf('LIBS')"`
++ AC_MSG_RESULT($PYTHON_EXTRA_LIBS)
+ AC_SUBST(PYTHON_EXTRA_LIBS)
+ ])
+ dnl as-ac-expand.m4 0.2.0
diff --git a/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch b/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch
new file mode 100644
index 000000000000..b1e42f394493
--- /dev/null
+++ b/app-pda/libopensync/files/libopensync-0.22-swig-typeerror.patch
@@ -0,0 +1,13 @@
+diff --git a/wrapper/opensync.i b/wrapper/opensync.i
+index 623c0f4..8131158 100644
+--- a/wrapper/opensync.i
++++ b/wrapper/opensync.i
+@@ -82,7 +82,7 @@ typedef struct {} OSyncHashTable;
+ %extend OSyncChange {
+ OSyncChange(PyObject *obj=NULL) {
+ OSyncChange *change = NULL;
+- if (obj)
++ if ((obj) && (obj != Py_None))
+ change = (OSyncChange *)PyCObject_AsVoidPtr(obj);
+ else
+ change = osync_change_new();
diff --git a/app-pda/libopensync/files/libopensync-py2.6.patch b/app-pda/libopensync/files/libopensync-py2.6.patch
deleted file mode 100644
index 6fdda2c60bed..000000000000
--- a/app-pda/libopensync/files/libopensync-py2.6.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- cmake/modules/FindPythonLibs.cmake
-+++ cmake/modules/FindPythonLibs.cmake
-@@ -17,8 +17,10 @@
-
- IF(WIN32)
- FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
-- NAMES python25_d python24_d python23_d python22_d python21_d python20_d python
-+ NAMES python26_d python25_d python24_d python23_d python22_d python21_d python20_d python
- PATHS
-+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]/libs/Debug
-+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]/libs
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]/libs/Debug
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]/libs
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.4\\InstallPath]/libs/Debug
-@@ -39,7 +41,8 @@
- ENDIF(WIN32)
-
- FIND_LIBRARY(PYTHON_LIBRARY ${PREFERRED_PYTHON_VERSION}
-- NAMES python25 python2.5
-+ NAMES python26 python2.6
-+ python25 python2.5
- python24 python2.4
- python23 python2.3
- python22 python2.2
-@@ -49,6 +52,7 @@
- python15 python1.5
-
- PATHS
-+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]/libs
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]/libs
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.4\\InstallPath]/libs
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.3\\InstallPath]/libs
-@@ -59,6 +63,7 @@
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\1.5\\InstallPath]/libs
-
- PATH_SUFFIXES
-+ python2.6/config
- python2.5/config
- python2.4/config
- python2.3/config
-@@ -77,7 +82,7 @@
- SET(PYTHON_FRAMEWORK_INCLUDES)
- IF(Python_FRAMEWORKS)
- IF(NOT PYTHON_INCLUDE_PATH)
-- FOREACH(version 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
-+ FOREACH(version 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
- FOREACH(dir ${Python_FRAMEWORKS})
- SET(PYTHON_FRAMEWORK_INCLUDES ${PYTHON_FRAMEWORK_INCLUDES}
- ${dir}/Versions/${version}/include/python${version})
-@@ -91,6 +96,7 @@
-
- PATHS
- ${PYTHON_FRAMEWORK_INCLUDES}
-+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]/include
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]/include
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.4\\InstallPath]/include
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.3\\InstallPath]/include
-@@ -102,6 +108,7 @@
-
- PATH_SUFFIXES
- ${PREFERRED_PYTHON_VERSION}
-+ python2.6
- python2.5
- python2.4
- python2.3
diff --git a/app-pda/libopensync/libopensync-0.22-r1.ebuild b/app-pda/libopensync/libopensync-0.22-r1.ebuild
new file mode 100644
index 000000000000..4897c74423ce
--- /dev/null
+++ b/app-pda/libopensync/libopensync-0.22-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.22-r1.ebuild,v 1.1 2011/02/14 20:14:23 dirtyepic Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools eutils python
+
+DESCRIPTION="OpenSync synchronisation framework library"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="debug doc python"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? ( app-doc/doxygen )
+ python? ( >=dev-lang/swig-1.3.17 )"
+# test? ( >=dev-libs/check-0.9.2 )"
+
+# Tests don't pass
+RESTRICT="test"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fbsd.patch
+ epatch "${FILESDIR}"/${P}-pythonpath.patch
+ epatch "${FILESDIR}"/${P}-swig-typeerror.patch
+ eautoreconf # for pythonpath
+ find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::'
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ do_configure() {
+ econf \
+ --enable-engine \
+ --enable-tools \
+ $(use_enable python) \
+ $(use_enable debug) \
+ $(use_enable debug tracing)
+ #$(use_enable test unit-tests)
+ }
+
+ use python && python_execute_function -s do_configure
+ do_configure # do even when USE=python to generate Doxyfile in ${S}
+}
+
+src_compile() {
+ use python \
+ && python_execute_function -d -s \
+ || default
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ do_install() {
+ emake DESTDIR="${D}" install || die
+ }
+
+ use python \
+ && python_execute_function -s do_install \
+ || do_install
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+ dodoc AUTHORS NEWS README TODO
+
+ if use doc; then
+ dohtml docs/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "Enabling the 'debug' useflag is required for bug reports."
+ elog "Also see: http://www.opensync.org/wiki/tracing"
+}
diff --git a/app-pda/libopensync/libopensync-0.36-r1.ebuild b/app-pda/libopensync/libopensync-0.36-r1.ebuild
deleted file mode 100644
index e677485500af..000000000000
--- a/app-pda/libopensync/libopensync-0.36-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.36-r1.ebuild,v 1.5 2009/07/05 19:38:19 aballier Exp $
-
-inherit cmake-utils eutils
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="debug doc python"
-
-# Tests don't pass
-#>=dev-libs/check-0.9.2
-#mycmakeargs="${mycmakeargs} -DOPENSYNC_UNITTESTS=ON"
-RESTRICT="test"
-
-RDEPEND=">=dev-db/sqlite-3
- >=dev-libs/glib-2
- dev-libs/libxml2
- python? ( >=dev-lang/python-2.2 )"
-
-DEPEND="${RDEPEND}
- python? ( >=dev-lang/swig-1.3.17 )
- >=dev-util/pkgconfig-0.9.0
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "$FILESDIR/libopensync-py2.6.patch"
-}
-
-src_compile() {
- local mycmakeargs
- mycmakeargs="${mycmakeargs} -DCMAKE_SKIP_RPATH=ON
- $(cmake-utils_use debug OPENSYNC_TRACE)
- $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
- $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use_build doc DOCUMENTATION)
- "
- cmake-utils_src_compile
-
- if use doc ; then
- cd "${CMAKE_BUILD_DIR}"
- doxygen Doxyfile || die "Failed to generate docs."
- fi
-}
-
-src_test() {
- echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
-
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
-
- if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
- die "Make test failed. See above for details."
- fi
-
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use doc ; then
- cd "${CMAKE_BUILD_DIR}"
- dohtml docs/html/* || die "Failed to install docs."
- fi
-}
-
-pkg_postinst() {
- elog "Building with 'debug' useflag is highly encouraged"
- elog "and requiered for bug reports."
- elog "Also see http://www.opensync.org/wiki/tracing"
-}
diff --git a/app-pda/libopensync/libopensync-0.36-r2.ebuild b/app-pda/libopensync/libopensync-0.36-r2.ebuild
new file mode 100644
index 000000000000..b5084d84aae0
--- /dev/null
+++ b/app-pda/libopensync/libopensync-0.36-r2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.36-r2.ebuild,v 1.1 2011/02/14 20:14:23 dirtyepic Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit cmake-utils python
+
+DESCRIPTION="OpenSync synchronisation framework library"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="debug doc python" # test
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )
+ python? ( >=dev-lang/swig-1.3.17 )"
+# test? ( >=dev-libs/check-0.9.2 )"
+
+DOCS="AUTHORS CODING README"
+
+# Tests don't pass
+RESTRICT="test"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ # Has hardcoded python versions, use the module shipped with cmake instead
+ # bug #276220
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use_enable python WRAPPER)
+ $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
+ $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
+ $(cmake-utils_use debug OPENSYNC_TRACE)"
+# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
+
+ do_configure() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ # since we're using cmake's FindPythonLibs PYTHON_VERSION is
+ # not defined
+ sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
+ "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
+ fi
+ cmake-utils_src_configure || die
+ }
+
+ use python \
+ && python_execute_function -s do_configure \
+ || do_configure
+}
+
+src_compile() {
+ do_compile() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_compile || die
+ }
+
+ use python \
+ && python_execute_function -s do_compile \
+ || do_compile
+
+ if use doc ; then
+ cmake-utils_src_make DoxygenDoc || die
+ fi
+}
+
+# TODO - fix
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+
+ if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
+ die "Make test failed. See above for details."
+ fi
+
+ popd > /dev/null
+}
+
+src_install() {
+ do_install() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_install || die
+ }
+
+ use python \
+ && python_execute_function -s do_install \
+ || do_install
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ dohtml docs/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "Enabling the 'debug' useflag is required for bug reports."
+ elog "Also see: http://www.opensync.org/wiki/tracing"
+}
diff --git a/app-pda/libopensync/libopensync-0.39-r1.ebuild b/app-pda/libopensync/libopensync-0.39-r1.ebuild
index 12468765201b..700f11b6551b 100644
--- a/app-pda/libopensync/libopensync-0.39-r1.ebuild
+++ b/app-pda/libopensync/libopensync-0.39-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39-r1.ebuild,v 1.1 2011/02/12 03:51:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39-r1.ebuild,v 1.2 2011/02/14 20:14:23 dirtyepic Exp $
EAPI="3"
@@ -16,7 +16,7 @@ SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="doc python" # test
+IUSE="debug doc python" # test
RDEPEND="dev-db/sqlite:3
>=dev-libs/glib-2.12:2
@@ -30,15 +30,12 @@ DEPEND="${RDEPEND}
python? ( >=dev-lang/swig-1.3.17 )"
# test? ( >=dev-libs/check-0.9.2 )"
-# 14% tests passed, 275 tests failed out of 321
-RESTRICT="test"
-
DOCS="AUTHORS CODING ChangeLog README"
+# Tests don't pass
+RESTRICT="test"
RESTRICT_PYTHON_ABIS="3.*"
-#CMAKE_VERBOSE="1"
-
src_prepare() {
# Has hardcoded python versions, use the module shipped with cmake instead
# bug #276220
@@ -53,7 +50,9 @@ src_configure() {
$(cmake-utils_use_build doc DOCUMENTATION)
$(cmake-utils_use_enable python WRAPPER)
$(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use test OPENSYNC_UNITTESTS)"
+ $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
+ $(cmake-utils_use debug OPENSYNC_TRACE)"
+# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
do_configure() {
if use python; then
@@ -114,6 +113,8 @@ src_install() {
&& python_execute_function -s do_install \
|| do_install
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
if use doc; then
cd "${CMAKE_BUILD_DIR}"
dohtml docs/html/* || die
@@ -121,6 +122,6 @@ src_install() {
}
pkg_postinst() {
- einfo "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
- einfo "the older app-pda/msynctool."
+ elog "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
+ elog "the older app-pda/msynctool."
}
diff --git a/app-pda/libopensync/metadata.xml b/app-pda/libopensync/metadata.xml
index 0d934d06b5d0..e2225770f162 100644
--- a/app-pda/libopensync/metadata.xml
+++ b/app-pda/libopensync/metadata.xml
@@ -3,10 +3,8 @@
<pkgmetadata>
<herd>pda</herd>
<maintainer>
- <email>peper@gentoo.org</email>
- <name>Piotr Jaroszyński</name>
+ <email>dirtyepic@gentoo.org</email>
+ <name>Ryan Hill</name>
</maintainer>
- <longdescription lang="en">
- </longdescription>
</pkgmetadata>