summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-18 06:21:48 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-18 06:21:48 +0000
commit3284aec96dd490aa1b57dd7ef40d9d41ac05b732 (patch)
tree0944380b773376a8720e62596f91005bcf0ff4ff /app-pda/libopensync
parentadd ~x64-macos (diff)
downloadgentoo-2-3284aec96dd490aa1b57dd7ef40d9d41ac05b732.tar.gz
gentoo-2-3284aec96dd490aa1b57dd7ef40d9d41ac05b732.tar.bz2
gentoo-2-3284aec96dd490aa1b57dd7ef40d9d41ac05b732.zip
Prevent relinking against outgoing system libs on downgrade (bug #355291).
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libopensync')
-rw-r--r--app-pda/libopensync/ChangeLog6
-rw-r--r--app-pda/libopensync/files/libopensync-0.22-Makefile.patch82
-rw-r--r--app-pda/libopensync/libopensync-0.22-r1.ebuild16
3 files changed, 99 insertions, 5 deletions
diff --git a/app-pda/libopensync/ChangeLog b/app-pda/libopensync/ChangeLog
index 609e8d679ece..53fffaaf5cea 100644
--- a/app-pda/libopensync/ChangeLog
+++ b/app-pda/libopensync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/libopensync
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.39 2011/02/14 20:14:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.40 2011/02/18 06:21:48 dirtyepic Exp $
+
+ 18 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> libopensync-0.22-r1.ebuild,
+ +files/libopensync-0.22-Makefile.patch:
+ Prevent relinking against outgoing system libs on downgrade (bug #355291).
*libopensync-0.36-r2 (14 Feb 2011)
*libopensync-0.22-r1 (14 Feb 2011)
diff --git a/app-pda/libopensync/files/libopensync-0.22-Makefile.patch b/app-pda/libopensync/files/libopensync-0.22-Makefile.patch
new file mode 100644
index 000000000000..579b792a49d4
--- /dev/null
+++ b/app-pda/libopensync/files/libopensync-0.22-Makefile.patch
@@ -0,0 +1,82 @@
+https://bugs.gentoo.org/355291
+
+--- a/opensync/Makefile.am
++++ b/opensync/Makefile.am
+@@ -77,5 +77,5 @@ CLEANFILES = \
+ *.bbg \
+ *.da
+
+-libopensync_la_LDFLAGS = @PACKAGE_LIBS@ @GCOV_LDFLAGS@
+-libopensync_la_LIBADD = @XML_LIBS@
++libopensync_la_LDFLAGS = @GCOV_LDFLAGS@
++libopensync_la_LIBADD = @PACKAGE_LIBS@ @XML_LIBS@
+--- a/osengine/Makefile.am
++++ b/osengine/Makefile.am
+@@ -43,5 +43,5 @@ CLEANFILES = \
+ *.bbg \
+ *.da
+
+-libosengine_la_LDFLAGS = $(PACKAGE_LIBS) -R $(libdir) @GCOV_LDFLAGS@
+-libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la
++libosengine_la_LDFLAGS = @GCOV_LDFLAGS@
++libosengine_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PACKAGE_LIBS)
+--- a/osplugin/Makefile.am
++++ b/osplugin/Makefile.am
+@@ -9,8 +9,8 @@ libexec_PROGRAMS = osplugin
+ ospluginincludedir = @OPENSYNC_HEADERDIR@
+
+ osplugin_SOURCES = osplugin.c
+-osplugin_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
+-osplugin_LDADD = $(top_builddir)/opensync/libopensync.la
++osplugin_LDFLAGS = @GCOV_LDFLAGS@
++osplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
+
+ CLEANFILES = \
+ *.bb \
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -9,24 +9,24 @@ bin_PROGRAMS = osyncdump osyncstress osyncplugin osynctest osyncbinary
+ endif
+
+ osyncdump_SOURCES = osyncdump.c
+-osyncdump_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
+-osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la
++osyncdump_LDFLAGS = @GCOV_LDFLAGS@
++osyncdump_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@ @XML_LIBS@
+
+ osyncstress_SOURCES = osyncstress.c
+-osyncstress_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
+-osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
++osyncstress_LDFLAGS = @GCOV_LDFLAGS@
++osyncstress_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
+
+ osyncplugin_SOURCES = osyncplugin.c
+-osyncplugin_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
+-osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la
++osyncplugin_LDFLAGS = @GCOV_LDFLAGS@
++osyncplugin_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
+
+ osynctest_SOURCES = osynctest.c
+-osynctest_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir) @GCOV_LDFLAGS@
+-osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la
++osynctest_LDFLAGS = @GCOV_LDFLAGS@
++osynctest_LDADD = $(top_builddir)/osengine/libosengine.la $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
+
+ osyncbinary_SOURCES = osyncbinary.c
+-osyncbinary_LDFLAGS = @PACKAGE_LIBS@ -R $(libdir)
+-osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la
++osyncbinary_LDFLAGS =
++osyncbinary_LDADD = $(top_builddir)/opensync/libopensync.la @PACKAGE_LIBS@
+
+ CLEANFILES = \
+ *.bb \
+--- a/wrapper/Makefile.am
++++ b/wrapper/Makefile.am
+@@ -22,5 +22,5 @@ osbindings_LTLIBRARIES = _opensync.la
+ endif
+
+ nodist__opensync_la_SOURCES = opensync_wrap.c
+-_opensync_la_LDFLAGS = @PACKAGE_LIBS@ @XML_LIBS@ $(PYTHON_LDFLAGS) -R $(libdir) -module -avoid-version
+-_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la
++_opensync_la_LDFLAGS = -module -avoid-version
++_opensync_la_LIBADD = $(top_builddir)/opensync/libopensync.la $(PYTHON_LDFLAGS) @PACKAGE_LIBS@ @XML_LIBS@
diff --git a/app-pda/libopensync/libopensync-0.22-r1.ebuild b/app-pda/libopensync/libopensync-0.22-r1.ebuild
index 4897c74423ce..2a2022a28939 100644
--- a/app-pda/libopensync/libopensync-0.22-r1.ebuild
+++ b/app-pda/libopensync/libopensync-0.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.22-r1.ebuild,v 1.1 2011/02/14 20:14:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.22-r1.ebuild,v 1.2 2011/02/18 06:21:48 dirtyepic Exp $
EAPI="3"
@@ -36,8 +36,11 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-fbsd.patch
epatch "${FILESDIR}"/${P}-pythonpath.patch
epatch "${FILESDIR}"/${P}-swig-typeerror.patch
- eautoreconf # for pythonpath
- find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::'
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ eautoreconf
+
+ find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::' \
+ -e 's: -R $(libdir)::g'
use python && python_copy_sources
}
@@ -51,10 +54,15 @@ src_configure() {
$(use_enable debug) \
$(use_enable debug tracing)
#$(use_enable test unit-tests)
+
+ sed -i -e 's:^\(hardcode_libdir_flag_spec=\).*:\1"":g' \
+ -e 's:^\(runpath_var=\).*:\1DIE_RPATH_DIE:g' \
+ -e 's:func_apped:func_append:g' \
+ libtool
}
use python && python_execute_function -s do_configure
- do_configure # do even when USE=python to generate Doxyfile in ${S}
+ do_configure # do this even when USE=python - we need to generate Doxyfile
}
src_compile() {