summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-19 16:06:06 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-19 16:06:06 +0000
commitfab128e46d90eececfb67b17ee0cf6e1ccf77a8d (patch)
treedb3dcd0557c89e6e3c7ece1c5543671115cbdd38 /app-pda/libopensync-plugin-syncml
parentppc stable #284566 (diff)
downloadgentoo-2-fab128e46d90eececfb67b17ee0cf6e1ccf77a8d.tar.gz
gentoo-2-fab128e46d90eececfb67b17ee0cf6e1ccf77a8d.tar.bz2
gentoo-2-fab128e46d90eececfb67b17ee0cf6e1ccf77a8d.zip
Migrate to EAPI 2 in order to remove built_with_use usage. Don't allow libsyncml-0.5.0 to satisfy dependencies in order to fix bug #269187.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-pda/libopensync-plugin-syncml')
-rw-r--r--app-pda/libopensync-plugin-syncml/ChangeLog9
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild28
2 files changed, 13 insertions, 24 deletions
diff --git a/app-pda/libopensync-plugin-syncml/ChangeLog b/app-pda/libopensync-plugin-syncml/ChangeLog
index 6d76ccf08d87..aee0cb47d8d9 100644
--- a/app-pda/libopensync-plugin-syncml/ChangeLog
+++ b/app-pda/libopensync-plugin-syncml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/libopensync-plugin-syncml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.11 2008/08/03 12:54:06 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.12 2009/09/19 16:06:06 betelgeuse Exp $
+
+ 19 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ libopensync-plugin-syncml-0.36.ebuild:
+ Migrate to EAPI 2 in order to remove built_with_use usage. Don't allow
+ libsyncml-0.5.0 to satisfy dependencies in order to fix bug #269187.
03 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild
index fbd7e06fa956..c629826ae883 100644
--- a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild,v 1.2 2008/07/13 07:45:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild,v 1.3 2009/09/19 16:06:06 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit eutils cmake-utils
@@ -16,7 +16,7 @@ LICENSE="LGPL-2.1"
IUSE="http +obex"
DEPEND="=app-pda/libopensync-${PV}*
- >=app-pda/libsyncml-0.4.6"
+ ~app-pda/libsyncml-0.4.6[obex?,http?]"
RDEPEND="${DEPEND}"
pkg_setup() {
@@ -25,28 +25,12 @@ pkg_setup() {
eerror "Please enable \"obex\" or/and \"http\" USE flags."
die "Please enable \"obex\" or/and \"http\" USE flags."
fi
-
- if use obex && ! built_with_use app-pda/libsyncml obex; then
- eerror "You are trying to build ${CATEGORY}/${P} with the \"obex\""
- eerror "USE flags, but app-pda/libsyncml was built without"
- eerror "the \"obex\" USE flag."
- eerror "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
- die "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
- fi
-
- if use http && ! built_with_use app-pda/libsyncml http; then
- eerror "You are trying to build ${CATEGORY}/${P} with the \"http\""
- eerror "USE flags, but app-pda/libsyncml was built without"
- eerror "the \"http\" USE flag."
- eerror "Please rebuild app-pda/libsyncml with \"http\" USE flag."
- die "Please rebuild app-pda/libsyncml with \"http\" USE flag."
- fi
}
-src_compile() {
+src_configure() {
local mycmakeargs="
$(cmake-utils_use_enable http HTTP)
$(cmake-utils_use_enable obex OBEX)"
- cmake-utils_src_compile
+ cmake-utils_src_configure
}