summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-03 04:56:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-03 04:56:34 +0000
commit3a3f630d713dd869e4c0fced6baf34d366c90b42 (patch)
tree4028f376ad9716482c4eab239eb59e765e77a8d7 /app-pda/libimobiledevice
parentUse IMOBILEDEVICE_BACKEND USE_EXPAND. See profiles/desc/imobiledevice_backend... (diff)
downloadgentoo-2-3a3f630d713dd869e4c0fced6baf34d366c90b42.tar.gz
gentoo-2-3a3f630d713dd869e4c0fced6baf34d366c90b42.tar.bz2
gentoo-2-3a3f630d713dd869e4c0fced6baf34d366c90b42.zip
Convert USE="ssl" to IMOBILEDEVICE_BACKEND USE_EXPAND to clarify it's exactly-one-of from gnutls or openssl.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libimobiledevice')
-rw-r--r--app-pda/libimobiledevice/ChangeLog7
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index 3e03c6cf8923..ff55287b4a10 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.24 2012/04/03 04:35:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.25 2012/04/03 04:56:34 ssuominen Exp $
+
+ 03 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ libimobiledevice-1.1.2.ebuild:
+ Convert USE="ssl" to IMOBILEDEVICE_BACKEND USE_EXPAND to clarify it's
+ exactly-one-of from gnutls or openssl.
03 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
libimobiledevice-1.1.1.ebuild:
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild
index 6c04a4eb0e9b..0c7d35c7fb7d 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild,v 1.2 2012/03/31 15:39:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild,v 1.3 2012/04/03 04:56:34 ssuominen Exp $
EAPI=4
@@ -15,12 +15,12 @@ SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="python ssl static-libs"
+IUSE="imobiledevice_backend_gnutls +imobiledevice_backend_openssl python static-libs"
RDEPEND=">=app-pda/libplist-1.8-r1[python?]
>=app-pda/usbmuxd-0.1.4
- ssl? ( dev-libs/openssl:0 )
- !ssl? (
+ imobiledevice_backend_openssl? ( dev-libs/openssl:0 )
+ imobiledevice_backend_gnutls? (
dev-libs/libgcrypt
>=dev-libs/libtasn1-1.1
>=net-libs/gnutls-2.2.0
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
python? ( >=dev-python/cython-0.13 )"
+REQUIRED_USE="^^ ( imobiledevice_backend_openssl imobiledevice_backend_gnutls )"
+
DOCS=( AUTHORS NEWS README )
pkg_setup() {
@@ -45,7 +47,7 @@ src_prepare() {
src_configure() {
local myconf
use python || myconf+=' --without-cython'
- use ssl || myconf+=' --disable-openssl'
+ use imobiledevice_backend_openssl || myconf+=' --disable-openssl'
econf \
$(use_enable static-libs static) \