summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-30 16:43:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-30 16:43:35 +0000
commit1950cc8b6ef3da2704423703102916de6f9c553e (patch)
tree80a72add95d7e96ce6733f1a0e9fe116d9d04cf4 /app-pda/libimobiledevice
parentRestore missing use_enable for python. (diff)
downloadgentoo-2-1950cc8b6ef3da2704423703102916de6f9c553e.tar.gz
gentoo-2-1950cc8b6ef3da2704423703102916de6f9c553e.tar.bz2
gentoo-2-1950cc8b6ef3da2704423703102916de6f9c553e.zip
Fix building of Cython based python bindings by backporting patch from upstream wrt #471620 by Brett Royles and Martin Cyr
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda/libimobiledevice')
-rw-r--r--app-pda/libimobiledevice/ChangeLog7
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.5-cython.patch14
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild6
3 files changed, 25 insertions, 2 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index bd9493ac4f1b..55db28addb3a 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.46 2013/05/11 22:00:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.47 2013/07/30 16:43:35 ssuominen Exp $
+
+ 30 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
+ libimobiledevice-1.1.5.ebuild, +files/libimobiledevice-1.1.5-cython.patch:
+ Fix building of Cython based python bindings by backporting patch from
+ upstream wrt #471620 by Brett Royles and Martin Cyr
11 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-libimobiledevice-1.1.4-r2.ebuild, -libimobiledevice-1.1.4-r3.ebuild,
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.5-cython.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.5-cython.patch
new file mode 100644
index 000000000000..df6e6637c549
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.1.5-cython.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/471620
+http://github.com/libimobiledevice/libimobiledevice/commit/62ab50f64fa210304338a5bfccdc6a26fac5f0ec
+
+--- cython/lockdown.pxi
++++ cython/lockdown.pxi
+@@ -221,7 +221,7 @@
+ char* c_session_id = NULL
+ bint ssl_enabled
+ bytes session_id
+- err = lockdownd_start_session(self._c_client, host_id, &c_session_id, &ssl_enabled)
++ err = lockdownd_start_session(self._c_client, host_id, &c_session_id, <int *>&ssl_enabled)
+ try:
+ self.handle_error(err)
+
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild
index 02b87bc96c5d..c47b880a86ec 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild,v 1.2 2013/05/11 22:00:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.5.ebuild,v 1.3 2013/07/30 16:43:35 ssuominen Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -39,6 +39,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cython.patch
+}
+
src_configure() {
use python && python_export_best