summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-21 12:44:39 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-21 12:44:39 +0000
commitc04d9fcee24153c03a2ba292989e130e815e0ac2 (patch)
tree17807f2ca2e09ad23d8a8460d0c293c4cc85fb98 /app-pda/jpilot
parentSparc stable, Bug #204386. (diff)
downloadgentoo-2-c04d9fcee24153c03a2ba292989e130e815e0ac2.tar.gz
gentoo-2-c04d9fcee24153c03a2ba292989e130e815e0ac2.tar.bz2
gentoo-2-c04d9fcee24153c03a2ba292989e130e815e0ac2.zip
pkgconfig, gettext, to DEPEND and repoman warnings.
(Portage version: 2.1.5)
Diffstat (limited to 'app-pda/jpilot')
-rw-r--r--app-pda/jpilot/ChangeLog5
-rw-r--r--app-pda/jpilot/jpilot-0.99.7-r1.ebuild14
-rw-r--r--app-pda/jpilot/jpilot-0.99.9.ebuild14
3 files changed, 18 insertions, 15 deletions
diff --git a/app-pda/jpilot/ChangeLog b/app-pda/jpilot/ChangeLog
index 3700c6aabb36..a8bfaf67d3c8 100644
--- a/app-pda/jpilot/ChangeLog
+++ b/app-pda/jpilot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-pda/jpilot
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.36 2008/02/17 18:35:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.37 2008/05/21 12:44:39 drac Exp $
+
+ 21 May 2008; Samuli Suominen <drac@gentoo.org> jpilot-0.99.9.ebuild:
+ Move gettext and pkgconfig to DEPEND.
17 Feb 2008; nixnut <nixnut@gentoo.org> jpilot-0.99.9.ebuild:
Stable on ppc wrt bug 209068
diff --git a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
index 19b10a27ad64..b515b849794c 100644
--- a/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
+++ b/app-pda/jpilot/jpilot-0.99.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.11 2007/01/24 03:30:21 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.7-r1.ebuild,v 1.12 2008/05/21 12:44:39 drac Exp $
inherit eutils multilib
@@ -21,10 +21,10 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S} || die
+ cd "${S}"
# Patch for gcc-2.95 compilation, thanks to Matt Black in #70127
- epatch ${FILESDIR}/jpilot-0.99.7-gcc2.patch
+ epatch "${FILESDIR}"/jpilot-0.99.7-gcc2.patch
# There are four icons available. Use the third.
sed -i 's/jpilot.xpm/jpilot-icon3.xpm/' jpilot.desktop || die
@@ -36,18 +36,18 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} \
+ make install DESTDIR="${D}" \
libdir=/usr/$(get_libdir) \
docdir=/usr/share/doc/${PF} \
icondir=/usr/share/pixmaps \
desktopdir=/usr/share/applications || die "install failed"
- dodoc README TODO UPGRADING ABOUT-NLS BUGS ChangeLog COPYING INSTALL
+ dodoc README TODO UPGRADING BUGS ChangeLog
doman docs/*.1
dodir /usr/share/${PN}
insinto /usr/share/${PN}
- doins ${S}/jpilotrc.*
+ doins "${S}"/jpilotrc.*
}
pkg_postinst() {
diff --git a/app-pda/jpilot/jpilot-0.99.9.ebuild b/app-pda/jpilot/jpilot-0.99.9.ebuild
index 2179b3971bd8..a2e9a890da54 100644
--- a/app-pda/jpilot/jpilot-0.99.9.ebuild
+++ b/app-pda/jpilot/jpilot-0.99.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.9.ebuild,v 1.5 2008/02/17 18:35:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.9.ebuild,v 1.6 2008/05/21 12:44:39 drac Exp $
inherit eutils multilib
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE="nls"
-DEPEND=">=app-pda/pilot-link-0.11.8
- >=x11-libs/gtk+-2.6.10-r1
- nls? ( sys-devel/gettext )
- >=dev-perl/XML-Parser-2.34
- >=dev-util/pkgconfig-0.22"
-RDEPEND="${DEPEND}"
+RDEPEND=">=app-pda/pilot-link-0.11.8
+ >=x11-libs/gtk+-2.6.10-r1"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-perl/XML-Parser-2.34
+ >=dev-util/pkgconfig-0.22"
src_unpack() {
unpack ${A}