summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-12-28 14:35:03 +0000
committerCédric Krier <cedk@gentoo.org>2008-12-28 14:35:03 +0000
commitefe70da7836a29cbde415a3ad7b10256d3c27466 (patch)
tree8acb7c6db015ea807ed9ebb8413de428e2d68b10 /app-office
parentStable on sparc, bug #247825 (diff)
downloadgentoo-2-efe70da7836a29cbde415a3ad7b10256d3c27466.tar.gz
gentoo-2-efe70da7836a29cbde415a3ad7b10256d3c27466.tar.bz2
gentoo-2-efe70da7836a29cbde415a3ad7b10256d3c27466.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/ChangeLog7
-rw-r--r--app-office/calcurse/calcurse-2.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-office/calcurse/ChangeLog b/app-office/calcurse/ChangeLog
index b3042958b8dd..c3e165943507 100644
--- a/app-office/calcurse/ChangeLog
+++ b/app-office/calcurse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calcurse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.8 2008/11/01 16:14:13 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.9 2008/12/28 14:35:03 cedk Exp $
+
+*calcurse-2.4 (28 Dec 2008)
+
+ 28 Dec 2008; Cédric Krier <cedk@gentoo.org> +calcurse-2.4.ebuild:
+ Version bump
01 Nov 2008; Cédric Krier <cedk@gentoo.org>
-files/calcurse-2.1-cflags.patch, +files/calcurse-2.3-locale.patch,
diff --git a/app-office/calcurse/calcurse-2.4.ebuild b/app-office/calcurse/calcurse-2.4.ebuild
new file mode 100644
index 000000000000..4d36f6c64bf0
--- /dev/null
+++ b/app-office/calcurse/calcurse-2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/calcurse-2.4.ebuild,v 1.1 2008/12/28 14:35:03 cedk Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="a text-based personal organizer"
+HOMEPAGE="http://culot.org/calcurse/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_en linguas_fr linguas_de linguas_es linguas_nl"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm po/LINGUAS
+}
+
+src_compile() {
+ local ALL_LINGUAS=""
+
+ use linguas_en && ALL_LINGUAS="${ALL_LINGUAS} en"
+ use linguas_fr && ALL_LINGUAS="${ALL_LINGUAS} fr"
+ use linguas_de && ALL_LINGUAS="${ALL_LINGUAS} de"
+ use linguas_es && ALL_LINGUAS="${ALL_LINGUAS} es"
+ use linguas_nl && ALL_LINGUAS="${ALL_LINGUAS} nl"
+
+ ALL_LINGUAS="${ALL_LINGUAS}" econf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml doc/*.{html,css}
+}