summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-06-08 17:16:17 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-06-08 17:16:17 +0000
commite28cb006fd54b0a047a61991c29b186ab274c955 (patch)
tree246168c460596c7acf63d2fc635ccf8f23b00c1a /app-office
parentCleanup old versions (diff)
downloadgentoo-2-e28cb006fd54b0a047a61991c29b186ab274c955.tar.gz
gentoo-2-e28cb006fd54b0a047a61991c29b186ab274c955.tar.bz2
gentoo-2-e28cb006fd54b0a047a61991c29b186ab274c955.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/files/digest-kword-1.6.33
-rw-r--r--app-office/kword/kword-1.6.3.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 98a187ebc483..317639ced75d 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.93 2007/03/02 04:05:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.94 2007/06/08 17:16:17 carlo Exp $
+
+*kword-1.6.3 (08 Jun 2007)
+
+ 08 Jun 2007; Carsten Lohrke <carlo@gentoo.org> +kword-1.6.3.ebuild:
+ Version bump.
02 Mar 2007; Jeroen Roovers <jer@gentoo.org> kword-1.6.1-r1.ebuild:
Stable for HPPA.
diff --git a/app-office/kword/files/digest-kword-1.6.3 b/app-office/kword/files/digest-kword-1.6.3
new file mode 100644
index 000000000000..0dc1fc75f716
--- /dev/null
+++ b/app-office/kword/files/digest-kword-1.6.3
@@ -0,0 +1,3 @@
+MD5 386d388094734f9759977c3267098e30 koffice-1.6.3.tar.bz2 56829391
+RMD160 e474ba48fa983fafb61ad58fb79cddda69ec6908 koffice-1.6.3.tar.bz2 56829391
+SHA256 c3975f0a59f50aaa5547f1709b6fad54f746fd06815859b374676b426dce12cb koffice-1.6.3.tar.bz2 56829391
diff --git a/app-office/kword/kword-1.6.3.ebuild b/app-office/kword/kword-1.6.3.ebuild
new file mode 100644
index 000000000000..ff03abbc1b66
--- /dev/null
+++ b/app-office/kword/kword-1.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6.3.ebuild,v 1.1 2007/06/08 17:16:17 carlo Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange 1.6.2 $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.5
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}