summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2006-01-21 13:26:29 +0000
committerAndreas Proschofsky <suka@gentoo.org>2006-01-21 13:26:29 +0000
commitda877d3c112efcd9147535bcced8bf1e97c7f370 (patch)
treecea42849c6700427b8d5c49ca5e9fe1975bbce5f /app-office
parentFixed DEPEND for modular X. (diff)
downloadgentoo-2-da877d3c112efcd9147535bcced8bf1e97c7f370.tar.gz
gentoo-2-da877d3c112efcd9147535bcced8bf1e97c7f370.tar.bz2
gentoo-2-da877d3c112efcd9147535bcced8bf1e97c7f370.zip
Cleanup
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-office')
-rwxr-xr-xapp-office/openoffice-bin/files/2.0.0/ooo-wrapper2119
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-2.0.051
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild4
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.0.ebuild181
4 files changed, 2 insertions, 353 deletions
diff --git a/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2 b/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
deleted file mode 100755
index e67fd85a5843..000000000000
--- a/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
+++ /dev/null
@@ -1,119 +0,0 @@
-#!/usr/bin/perl -w
-#*****************************************************************************
-#
-# ooffice - Wrapper script for OpenOffice.org
-#
-# Based on the Mandrake work.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License version 2, as
-# published by the Free Software Foundation.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-#
-#*****************************************************************************
-
-use strict;
-use IO::Handle;
-use Fcntl ':flock';
-
-my $Debug = $ENV{OOO_DEBUG};
-
-# Define the vendor of this particular OOo package
-my $VendorName = 'Gentoo';
-# Define system installation directory
-# Autoconf totally sucks for @libdir@ type substitution
-my $SystemInstallDir = 'INSTDIR';
-# Suffix for parallel installable versioning
-my $BinSuffix = '2';
-# ooo-build version
-my $OOO_BUILDVERSION = 'PV';
-
-#=============================================================================
-# Main
-#=============================================================================
-
-# Parse command line arguments
-my @ooo_argv;
-my $session_quickstart;
-my $widgets_set;
-while ($ARGV[0]) {
- $_ = shift;
- if (m/^--session-quickstart/) {
- $session_quickstart = 1;
- } elsif (m/^--widgets-set/) {
- $widgets_set = shift;
- (defined $widgets_set) || die "Error: The option --widgets-set requires a value\n" .
- "For example: --widgets-set gtk\n";
- } elsif (m/^--version/) {
- print "This is OpenOffice.org $OOO_BUILDVERSION\n";
- exit 0;
- } else {
- push @ooo_argv, $_;
- }
-}
-
-if (!@ooo_argv) {
- my $arg;
- if ($0 =~ m/\/oo(calc|draw|impress|math|web|writer|base)$BinSuffix$/) {
- $arg = "-$1";
- } elsif ($0 =~ m/\/oofromtemplate$BinSuffix$/) {
- $arg = "slot:5500";
- }
-
- if ($arg) {
- push @ooo_argv, "$arg";
- $Debug && print "Append arg: $arg\n";
- }
-} else {
- $Debug && print "Ignoring type - since have filenames\n";
-}
-
-if (defined $widgets_set) {
- $ENV{SAL_USE_VCLPLUGIN} = $widgets_set;
-}
-
-# overcome ghastly up-stream evilness
-$ENV{SAL_NOEXPANDFPICKER}='TRUE';
-
-if ($session_quickstart) {
- $Debug && print "Execute quickstarter\n";
- push @ooo_argv, '-quickstart';
-}
-
-# FIXME: the following two fixes should be done by OOo itself
-# create the user config directory with safe rights 700 if it we find
-# the right path and the directory does not exist
-if (open BOOTSTRAPRC, "$SystemInstallDir/program/bootstraprc") {
- while (my $line = <BOOTSTRAPRC>) {
- chomp $line;
- if (($line =~ m/^\s*UserInstallation\s*=\s*([^\s]*)\s*$/) && ($1)) {
- my $userConfDir=$1;
- $userConfDir =~ s|\$SYSUSERCONFIG|$ENV{HOME}|;
- $userConfDir =~ s|file://||;
- mkdir ($userConfDir,0700) unless (-d $userConfDir);
- last;
- }
- }
- close BOOTSTRAPRC;
-}
-# touch ~/.recently-used with safe rights 700 if it does not exist
-if (! -f "$ENV{HOME}/.recently-used") {
- open (RECENTLY_USED, ">$ENV{HOME}/.recently-used") &&
- close RECENTLY_USED &&
- chmod 0600, "$ENV{HOME}/.recently-used";
-}
-
-if (!(-f '/proc/version')) {
- print STDERR "\n\n --- Warning - OO.o will not work without a mounted /proc filesystem --- \n\n\n";
-}
-
-# And here we go.
-exec "$SystemInstallDir/program/soffice", @ooo_argv
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0 b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0
deleted file mode 100644
index 6d840c86d4a5..000000000000
--- a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0
+++ /dev/null
@@ -1,51 +0,0 @@
-MD5 432ac5895d105c2276c4f7de5fe70c9c OOo_2.0.0_LinuxIntel_install.tar.gz 106447396
-MD5 ed9b23761bd369443d353753a787a9f4 OOo_2.0.0rc2_051005_LinuxIntel_langpack_be-BY.tar.gz 13371707
-MD5 346355c88b5cbbbf1f3b052ccc16e615 OOo_2.0.0rc2_051005_LinuxIntel_langpack_bg.tar.gz 13899627
-MD5 5e6bd1c2c1ca116185e28859bfc11f9d OOo_2.0.0rc2_051005_LinuxIntel_langpack_ca.tar.gz 13326284
-MD5 2a9ee5df7f0149c722c30d6aae6edb45 OOo_2.0.0rc2_051005_LinuxIntel_langpack_cs.tar.gz 13973989
-MD5 32aaca7c6c7aa9e733b35979a1eb1f2f OOo_2.0.0rc2_051005_LinuxIntel_langpack_cy.tar.gz 13249984
-MD5 7f51fbc5d735cb186bac62a4ec60da6e OOo_2.0.0rc2_051005_LinuxIntel_langpack_da.tar.gz 13852333
-MD5 40f662865b02bb3cfd756ccd0dccd153 OOo_2.0.0rc2_051005_LinuxIntel_langpack_de.tar.gz 14802676
-MD5 d0ba86d894b555fb79db3d0223085dc7 OOo_2.0.0rc2_051005_LinuxIntel_langpack_el.tar.gz 13377334
-MD5 0e03bcf75866771d0c72f63879529462 OOo_2.0.0rc2_051005_LinuxIntel_langpack_es.tar.gz 14122554
-MD5 54cd48efd53b1a9e28b0e4033ee70cc0 OOo_2.0.0rc2_051005_LinuxIntel_langpack_et.tar.gz 14046504
-MD5 8766bc9b8e5b481a955b3df7347ae476 OOo_2.0.0rc2_051005_LinuxIntel_langpack_fi.tar.gz 13353993
-MD5 c14dba2c7a217124eeeb9f121d062a3b OOo_2.0.0rc2_051005_LinuxIntel_langpack_fr.tar.gz 14319116
-MD5 f0b3215b30253f55b37b455dddf18039 OOo_2.0.0rc2_051005_LinuxIntel_langpack_gu-IN.tar.gz 13383503
-MD5 3b3b4f81648d97a982a01797ba642d06 OOo_2.0.0rc2_051005_LinuxIntel_langpack_hr.tar.gz 13619973
-MD5 75328efc20bfa552dc86652af556d43b OOo_2.0.0rc2_051005_LinuxIntel_langpack_hu.tar.gz 13431675
-MD5 b26ff838f489f354ce079515e7e878b2 OOo_2.0.0rc2_051005_LinuxIntel_langpack_ja.tar.gz 14867484
-MD5 b8e408fd21a496827908f6900df782d4 OOo_2.0.0rc2_051005_LinuxIntel_langpack_km.tar.gz 16716054
-MD5 01af0d6b83481fc6bee2b74b0cdeb807 OOo_2.0.0rc2_051005_LinuxIntel_langpack_ko.tar.gz 14001094
-MD5 a63b3ee7d68817917edbdf664c79b58c OOo_2.0.0rc2_051005_LinuxIntel_langpack_nl.tar.gz 14404231
-MD5 453a79de1d517d4980bc9e8c401f0418 OOo_2.0.0rc2_051005_LinuxIntel_langpack_nn.tar.gz 13308437
-MD5 0edf453a43b65ed77e7403cf117fa633 OOo_2.0.0rc2_051005_LinuxIntel_langpack_pa-IN.tar.gz 13365947
-MD5 3c280f1474b42b9395d08870d54eced1 OOo_2.0.0rc2_051005_LinuxIntel_langpack_pl.tar.gz 13630834
-MD5 2ccd6396330ab28efd592ec900a8b00f OOo_2.0.0rc2_051005_LinuxIntel_langpack_pt-BR.tar.gz 14098232
-MD5 bfc5dc1ce032aede7e0500375fc37577 OOo_2.0.0rc2_051005_LinuxIntel_langpack_ru.tar.gz 14703980
-MD5 4cc2f3d419b1bbe3aabe888dadc89e9c OOo_2.0.0rc2_051005_LinuxIntel_langpack_rw.tar.gz 13637426
-MD5 1ba901ab46483ed3278c1c97f4c78a4d OOo_2.0.0rc2_051005_LinuxIntel_langpack_sh-YU.tar.gz 13324346
-MD5 d13d5077b3285ecce886fe2f4728f090 OOo_2.0.0rc2_051005_LinuxIntel_langpack_sk.tar.gz 13869339
-MD5 43e70805d54cb4da5204207625269869 OOo_2.0.0rc2_051005_LinuxIntel_langpack_sr-CS.tar.gz 13407602
-MD5 a12d2cc3572d0be819846a82788bc427 OOo_2.0.0rc2_051005_LinuxIntel_langpack_sw-TZ.tar.gz 13467747
-MD5 e27d87c1349ab8b1bc4537dc73e46885 OOo_2.0.0rc2_051005_LinuxIntel_langpack_tr.tar.gz 13490214
-MD5 7d2ed63f9081b3017e722efbbe909d73 OOo_2.0.0rc2_051005_LinuxIntel_langpack_vi.tar.gz 13322279
-MD5 161a64330ca659bcf8d6c53f2ab93a12 OOo_2.0.0rc2_051005_LinuxIntel_langpack_zh-CN.tar.gz 14182440
-MD5 61be1bb75ef1d7ce6fbeacfd8fa8b95d OOo_2.0.0rc2_051005_LinuxIntel_langpack_zh-TW.tar.gz 14353649
-MD5 2a1f884f4ea8869690105ccfbfbcdd2b openoffice.org-af-2.0.0-3.i586.tar.gz 13328513
-MD5 c9a8f25917c3e19b72add15d13e98450 openoffice.org-bn-2.0.0-3.i586.tar.gz 13243000
-MD5 1c9d19015811741fd64e593b4bed2a4b openoffice.org-br-2.0.0-3.i586.tar.gz 14296383
-MD5 735477a881f143009a85460c8059c587 openoffice.org-en-GB-2.0.0-3.i586.tar.gz 13383707
-MD5 afd90f4d509c703698eb5d95056597da openoffice.org-ga-2.0.0-3.i586.tar.gz 13525582
-MD5 1f3ee7008bf7843d03f4a4870ff2f2f2 openoffice.org-it-2.0.0-3.i586.tar.gz 14092080
-MD5 32ebc740c896a24403ed5627a8d15ca7 openoffice.org-lt-2.0.0-3.i586.tar.gz 13285092
-MD5 604eef49bfd0bc8e39eb8c8984ee407d openoffice.org-lv-2.0.0-3.i586.tar.gz 13271040
-MD5 53c5fffe9df5b0aa124560ae582a19dd openoffice.org-mk-2.0.0-3.i586.tar.gz 14034446
-MD5 9132186edfb3cdea0edea7cbb255381c openoffice.org-nb-2.0.0-3.i586.tar.gz 13294418
-MD5 6d88430b6248ea4f65a7aea383559acc openoffice.org-ne-2.0.0-3.i586.tar.gz 13314174
-MD5 fd69e615045b1f0c2b8966148c10de11 openoffice.org-ns-2.0.0-3.i586.tar.gz 13239413
-MD5 ffba3fd1341b97c1c26a2f7a4dd34a4e openoffice.org-sl-2.0.0-3.i586.tar.gz 13247902
-MD5 697c187aa90fa116922b7fc50e6ca16d openoffice.org-sv-2.0.0-3.i586.tar.gz 13888604
-MD5 990c0d2bd171138aa444f934bba70881 openoffice.org-tn-2.0.0-3.i586.tar.gz 13335818
-MD5 4cc2ae876eaddac87bf8fdd3c588353c openoffice.org-xh-2.0.0-3.i586.tar.gz 13368819
-MD5 c1fd889236c6f049625af27f290a17a9 openoffice.org-zu-2.0.0-3.i586.tar.gz 13293562
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild
index 32b62012da89..a46e01780a0c 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild,v 1.4 2005/09/24 07:24:37 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.5.ebuild,v 1.5 2006/01/21 13:26:29 suka Exp $
# NOTE: There are two big issues that should be addressed.
#
@@ -26,7 +26,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="!app-office/openoffice
- virtual/x11
+ || ( x11-libs/libXaw virtual/x11 )
virtual/libc
>=dev-lang/perl-5.0
app-arch/zip
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.0.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.0.ebuild
deleted file mode 100644
index 7541c9738051..000000000000
--- a/app-office/openoffice-bin/openoffice-bin-2.0.0.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0.ebuild,v 1.8 2005/12/12 09:08:17 spyderous Exp $
-
-inherit eutils fdo-mime rpm multilib
-
-IUSE="gnome java"
-
-MY_PV="${PV}rc2"
-MY_PV2="${MY_PV}_051005"
-S="${WORKDIR}/OOO680_m3_native_packed-2_en-US.8968/RPMS"
-DESCRIPTION="OpenOffice productivity suite"
-
-LANGPACK="OOo_${MY_PV2}_LinuxIntel_langpack"
-LANGPACKPATH="http://oootranslation.services.openoffice.org/pub/OpenOffice.org/${MY_PV}/${LANGPACK}"
-LANGLOC="http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOO680_m3/Build-1/OOo_OOO680_m3_native_LinuxIntel_langpacks_rpm"
-LANGSUFFIX="${PV}-3.i586.tar.gz"
-
-SRC_URI="mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz
- linguas_af? ( ${LANGLOC}/openoffice.org-af-${LANGSUFFIX} )
- linguas_be_BY? ( ${LANGPACKPATH}_be-BY.tar.gz )
- linguas_bg? ( ${LANGPACKPATH}_bg.tar.gz )
- linguas_bn? ( ${LANGLOC}/openoffice.org-bn-${LANGSUFFIX} )
- linguas_br? ( ${LANGLOC}/openoffice.org-br-${LANGSUFFIX} )
- linguas_ca? ( ${LANGPACKPATH}_ca.tar.gz )
- linguas_cs? ( ${LANGPACKPATH}_cs.tar.gz )
- linguas_cy? ( ${LANGPACKPATH}_cy.tar.gz )
- linguas_da? ( ${LANGPACKPATH}_da.tar.gz )
- linguas_de? ( ${LANGPACKPATH}_de.tar.gz )
- linguas_el? ( ${LANGPACKPATH}_el.tar.gz )
- linguas_en_GB? ( ${LANGLOC}/openoffice.org-en-GB-${LANGSUFFIX} )
- linguas_es? ( ${LANGPACKPATH}_es.tar.gz )
- linguas_et? ( ${LANGPACKPATH}_et.tar.gz )
- linguas_fi? ( ${LANGPACKPATH}_fi.tar.gz )
- linguas_fr? ( ${LANGPACKPATH}_fr.tar.gz )
- linguas_ga? ( ${LANGLOC}/openoffice.org-ga-${LANGSUFFIX} )
- linguas_gu_IN? ( ${LANGPACKPATH}_gu-IN.tar.gz )
- linguas_hr? ( ${LANGPACKPATH}_hr.tar.gz )
- linguas_hu? ( ${LANGPACKPATH}_hu.tar.gz )
- linguas_it? ( ${LANGLOC}/openoffice.org-it-${LANGSUFFIX} )
- linguas_ja? ( ${LANGPACKPATH}_ja.tar.gz )
- linguas_km? ( ${LANGPACKPATH}_km.tar.gz )
- linguas_ko? ( ${LANGPACKPATH}_ko.tar.gz )
- linguas_lt? ( ${LANGLOC}/openoffice.org-lt-${LANGSUFFIX} )
- linguas_lv? ( ${LANGLOC}/openoffice.org-lv-${LANGSUFFIX} )
- linguas_mk? ( ${LANGLOC}/openoffice.org-mk-${LANGSUFFIX} )
- linguas_nb? ( ${LANGLOC}/openoffice.org-nb-${LANGSUFFIX} )
- linguas_ne? ( ${LANGLOC}/openoffice.org-ne-${LANGSUFFIX} )
- linguas_nl? ( ${LANGPACKPATH}_nl.tar.gz )
- linguas_nn? ( ${LANGPACKPATH}_nn.tar.gz )
- linguas_ns? ( ${LANGLOC}/openoffice.org-ns-${LANGSUFFIX} )
- linguas_pa_IN? ( ${LANGPACKPATH}_pa-IN.tar.gz )
- linguas_pl? ( ${LANGPACKPATH}_pl.tar.gz )
- linguas_pt_BR? ( ${LANGPACKPATH}_pt-BR.tar.gz )
- linguas_ru? ( ${LANGPACKPATH}_ru.tar.gz )
- linguas_rw? ( ${LANGPACKPATH}_rw.tar.gz )
- linguas_sh_YU? ( ${LANGPACKPATH}_sh-YU.tar.gz )
- linguas_sk? ( ${LANGPACKPATH}_sk.tar.gz )
- linguas_sl? ( ${LANGLOC}/openoffice.org-sl-${LANGSUFFIX} )
- linguas_sr_CS? ( ${LANGPACKPATH}_sr-CS.tar.gz )
- linguas_sv? ( ${LANGLOC}/openoffice.org-sv-${LANGSUFFIX} )
- linguas_sw_TZ? ( ${LANGPACKPATH}_sw-TZ.tar.gz )
- linguas_tn? ( ${LANGLOC}/openoffice.org-tn-${LANGSUFFIX} )
- linguas_tr? ( ${LANGPACKPATH}_tr.tar.gz )
- linguas_vi? ( ${LANGPACKPATH}_vi.tar.gz )
- linguas_xh? ( ${LANGLOC}/openoffice.org-xh-${LANGSUFFIX} )
- linguas_zh_CN? ( ${LANGPACKPATH}_zh-CN.tar.gz )
- linguas_zh_TW? ( ${LANGPACKPATH}_zh-TW.tar.gz )
- linguas_zu? ( ${LANGLOC}/openoffice.org-zu-${LANGSUFFIX} )"
-
-HOMEPAGE="http://www.openoffice.org/"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="x86 ~amd64"
-
-RDEPEND="!app-office/openoffice
- || ( x11-libs/libXaw virtual/x11 )
- sys-libs/glibc
- >=dev-lang/perl-5.0
- app-arch/zip
- app-arch/unzip
- java? ( !amd64? ( >=virtual/jre-1.4.1 )
- amd64? ( app-emulation/emul-linux-x86-java ) )
- amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )
- linguas_ja? ( >=media-fonts/kochi-substitute-20030809-r3 )
- linguas_zh_CN? ( >=media-fonts/arphicfonts-0.1-r2 )
- linguas_zh_TW? ( >=media-fonts/arphicfonts-0.1-r2 )"
-
-DEPEND="${RDEPEND}
- sys-apps/findutils"
-
-PROVIDE="virtual/ooo"
-
-src_unpack() {
-
- unpack ${A}
-
- for i in base calc core01 core02 core03 core03u core04 core04u core05 core05u core06 core07 core08 core09 core10 draw impress math writer graphicfilter pyuno spellcheck testtool xsltfilter ; do
- rpm_unpack ${S}/openoffice.org-${i}-${PV}-3.i586.rpm
- done
-
- rpm_unpack ${S}/desktop-integration/openoffice.org-freedesktop-menus-${PV}-3.noarch.rpm
-
- use gnome && rpm_unpack ${S}/openoffice.org-gnome-integration-${PV}-3.i586.rpm
- use java && rpm_unpack ${S}/openoffice.org-javafilter-${PV}-3.i586.rpm
-
- strip-linguas en af be_BY bg bn br ca cs cy da de el en_GB es et fi fr ga gu_IN hr hu it ja km ko lt lv mk nb ne nl nn ns pa_IN pl pt_BR ru rw sh_YU sk sl sr_CS sv sw_TZ tn tr vi xh zh_CN zh_TW zu
-
- for i in ${LINGUAS}; do
- i="${i/_/-}"
- if [ ${i} != "en" ] ; then
- rpm_unpack openoffice.org-${i}-${PV}-*.i586.rpm
- rpm_unpack openoffice.org-${i}-help-${PV}-*.i586.rpm
- rpm_unpack openoffice.org-${i}-res-${PV}-*.i586.rpm
- fi
- done
-
-}
-
-src_install () {
-
- #Multilib install dir magic for AMD64
- has_multilib_profile && ABI=x86
- INSTDIR="/usr/$(get_libdir)/openoffice"
-
- einfo "Installing OpenOffice.org into build root..."
- dodir ${INSTDIR}
- mv ${WORKDIR}/opt/openoffice.org2.0/* ${D}${INSTDIR}
-
- #Menu entries, icons and mime-types
- cd ${D}${INSTDIR}/share/xdg/
- sed -i -e s/'Exec=openoffice.org-2.0-printeradmin'/'Exec=oopadmin2'/g printeradmin.desktop || die
-
- for desk in base calc draw impress math printeradmin writer; do
- mv ${desk}.desktop openoffice.org-2.0-${desk}.desktop
- sed -i -e s/openoffice.org-2.0/ooffice2/g openoffice.org-2.0-${desk}.desktop || die
- sed -i -e s/openofficeorg-20-${desk}/ooo-${desk}2/g openoffice.org-2.0-${desk}.desktop || die
- domenu openoffice.org-2.0-${desk}.desktop
- insinto /usr/share/pixmaps
- newins ${WORKDIR}/usr/share/icons/gnome/48x48/apps/openofficeorg-20-${desk}.png ooo-${desk}2.png
- done
-
- insinto /usr/share/mime/packages
- doins ${WORKDIR}/usr/share/mime/packages/openoffice.org.xml
-
- # Install wrapper script
- newbin ${FILESDIR}/${PV}/ooo-wrapper2 ooffice2
- sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
- sed -i -e "s|INSTDIR|${INSTDIR}|g" ${D}/usr/bin/ooffice2 || die
-
- # Component symlinks
- for app in base calc draw fromtemplate impress math web writer; do
- dosym ooffice2 /usr/bin/oo${app}2
- done
-
- dosym ${INSTDIR}/program/spadmin.bin /usr/bin/oopadmin2
-
- # Change user install dir
- sed -i -e s/.openoffice.org2/.ooo-2.0/g ${D}${INSTDIR}/program/bootstraprc || die
-
- # Non-java weirdness see bug #99366
- use !java && rm -f ${D}${INSTDIR}/program/javaldx
-}
-
-pkg_postinst() {
-
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-
- [ -x /sbin/chpax ] && [ -e /usr/lib/openoffice/program/soffice.bin ] && chpax -zm /usr/lib/openoffice/program/soffice.bin
-
- einfo " To start OpenOffice.org, run:"
- einfo
- einfo " $ ooffice2"
- einfo
- einfo " Also, for individual components, you can use any of:"
- einfo
- einfo " oobase2, oocalc2, oodraw2, oofromtemplate2, ooimpress2, oomath2,"
- einfo " ooweb2 or oowriter2"
-}