summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-20 16:09:14 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-20 16:09:14 +0000
commitcd58e55f5926c41f6c8459c6bd2caea746ec61f9 (patch)
tree9f7d6cc5a6b8e9eb313f2d2e955be031dfd445d6 /app-office
parentkoffice doesn't work against some versions of python-2.0-r4, aounr the <=1.5 ... (diff)
downloadgentoo-2-cd58e55f5926c41f6c8459c6bd2caea746ec61f9.tar.gz
gentoo-2-cd58e55f5926c41f6c8459c6bd2caea746ec61f9.tar.bz2
gentoo-2-cd58e55f5926c41f6c8459c6bd2caea746ec61f9.zip
added python-2.0-r5 dep, removed python-libs tcltk check
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/koffice-1.1.ebuild21
1 files changed, 2 insertions, 19 deletions
diff --git a/app-office/koffice/koffice-1.1.ebuild b/app-office/koffice/koffice-1.1.ebuild
index c47ea03f54e4..43e4e3b93cc9 100644
--- a/app-office/koffice/koffice-1.1.ebuild
+++ b/app-office/koffice/koffice-1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.ebuild,v 1.7 2001/10/20 15:48:40 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.ebuild,v 1.8 2001/10/20 16:09:14 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
@@ -17,7 +17,7 @@ SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
DEPEND="$DEPEND
>=kde-base/kdelibs-2.2
- >=dev-lang/python-2.0-r4"
+ >=dev-lang/python-2.0-r5"
# >=sys-devel/automake-1.4
# >=sys-devel/autoconf-1.13"
# hm. This was in achim's original. are these versions superior to the ones we have by default in a current-day rc6?
@@ -26,24 +26,7 @@ RDEPEND="$RDEPEND
>=kde-base/kdelibs-2.2"
src_unpack() {
- #checkpython || exit 1
base_src_unpack all patch
kde-objprelink-patch
}
-checkpython() {
- #libs=`python-config --libs`
- if [ -z "`echo $libs | grep -- -ltk`" ]; then
- echo "
- ERROR: koffice requires a python built against tcl-tk.
-Please add tcltk to your USE flag list, remerge dev-lang/python,
-and try emerging koffice again.
-You can remove tcltk from USE again after remerging python.
-
-I got: python-config --libs =
-$libs
-and was expecting the output to contain -ltk, but it didn't.
-"
- return 1
- fi
-}