summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-19 22:10:49 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-19 22:10:49 +0000
commitcc86ce6d0eb921e86e2fb2da0ade6a0a5fa687d1 (patch)
tree466fd91a14fab718ff229e2450ec3581c1e7a9ad /app-office
parentUpdate list of calligra features (diff)
downloadgentoo-2-cc86ce6d0eb921e86e2fb2da0ade6a0a5fa687d1.tar.gz
gentoo-2-cc86ce6d0eb921e86e2fb2da0ade6a0a5fa687d1.tar.bz2
gentoo-2-cc86ce6d0eb921e86e2fb2da0ade6a0a5fa687d1.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/ChangeLog10
-rw-r--r--app-office/calligra/calligra-2.3.74.ebuild (renamed from app-office/calligra/calligra-2.3.73.ebuild)105
-rw-r--r--app-office/calligra/files/calligra-2.3.74-jpeglcms-2.patch21
-rw-r--r--app-office/calligra/files/calligra-2.3.74-jpeglcms.patch26
-rw-r--r--app-office/calligra/metadata.xml4
5 files changed, 99 insertions, 67 deletions
diff --git a/app-office/calligra/ChangeLog b/app-office/calligra/ChangeLog
index 28dc63ab5af2..048f3357dd2e 100644
--- a/app-office/calligra/ChangeLog
+++ b/app-office/calligra/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/calligra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra/ChangeLog,v 1.2 2011/08/04 16:30:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra/ChangeLog,v 1.3 2011/08/19 22:10:49 dilfridge Exp $
+
+*calligra-2.3.74 (19 Aug 2011)
+
+ 19 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ -calligra-2.3.73.ebuild, +calligra-2.3.74.ebuild,
+ +files/calligra-2.3.74-jpeglcms.patch,
+ +files/calligra-2.3.74-jpeglcms-2.patch, metadata.xml:
+ Version bump
04 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org> calligra-2.3.73.ebuild:
media-libs/libwpg to app-text/libwpg
diff --git a/app-office/calligra/calligra-2.3.73.ebuild b/app-office/calligra/calligra-2.3.74.ebuild
index 1ea11dd4f2d0..c94e68d8bdbd 100644
--- a/app-office/calligra/calligra-2.3.73.ebuild
+++ b/app-office/calligra/calligra-2.3.74.ebuild
@@ -1,11 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra/calligra-2.3.73.ebuild,v 1.2 2011/08/04 16:30:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra/calligra-2.3.74.ebuild,v 1.1 2011/08/19 22:10:49 dilfridge Exp $
+
+# note: files that need to be checked for dependencies etc:
+# CMakeLists.txt, kexi/CMakeLists.txt kexi/migration/CMakeLists.txt
+# krita/CMakeLists.txt
EAPI=4
KDE_SCM=git
-KDE_MINIMAL=4.6
+KDE_MINIMAL=4.6.4
OPENGL_REQUIRED=optional
KDE_HANDBOOK=optional
KDE_LINGUAS_LIVE_OVERRIDE=true
@@ -18,25 +22,33 @@ HOMEPAGE="http://www.calligra-suite.org/"
LICENSE="GPL-2"
SLOT="4"
[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
-IUSE="+boost +crypt +eigen +exif fftw +fontconfig freetds +gif glew +glib +gsf
-gsl +iconv +jpeg jpeg2k +kdcraw kdepim +lcms mysql +mso +okular openctl openexr
-+pdf +png postgres +semantic-desktop +ssl tiff +threads +truetype
-+wmf word-perfect +xml +xslt"
+IUSE="+crypt +eigen +exif fftw +fontconfig freetds +gif glew +glib +gsf
+gsl +iconv +jpeg jpeg2k +kdcraw kdepim +lcms marble mysql +mso +okular openctl openexr
++pdf postgres +semantic-desktop +ssl sybase tiff +threads +truetype
++wmf word-perfect xbase +xml +xslt"
-CAL_FTS="braindump flow karbon kexi kpresenter krita tables words"
+# please do not sort here, order is same as in CMakeLists.txt
+CAL_FTS="kexi words flow plan stage tables krita karbon braindump active"
for cal_ft in ${CAL_FTS}; do
IUSE+=" calligra_features_${cal_ft}"
done
unset cal_ft
+REQUIRED_USE="
+ calligra_features_tables? ( eigen )
+ calligra_features_krita? ( eigen exif lcms )
+ calligra_features_plan? ( kdepim )
+"
+
RDEPEND="
!app-office/koffice-libs
dev-db/sqlite:3
dev-lang/perl
+ dev-libs/boost
dev-libs/libxml2
$(add_kdebase_dep knewstuff)
+ media-libs/libpng
sys-libs/zlib
- boost? ( dev-libs/boost )
crypt? ( app-crypt/qca:2 )
eigen? ( dev-cpp/eigen:2 )
exif? ( media-gfx/exiv2 )
@@ -54,6 +66,7 @@ RDEPEND="
kdcraw? ( $(add_kdebase_dep libkdcraw) )
kdepim? ( $(add_kdebase_dep kdepimlibs) )
lcms? ( media-libs/lcms:2 )
+ marble? ( $(add_kdebase_dep marble) )
mysql? ( virtual/mysql )
okular? ( $(add_kdebase_dep okular) )
openctl? ( >=media-libs/opengtl-0.9.15 )
@@ -62,10 +75,13 @@ RDEPEND="
app-text/poppler
media-gfx/pstoedit
)
- png? ( media-libs/libpng )
- postgres? ( dev-db/postgresql-base )
+ postgres? (
+ dev-db/postgresql-base
+ =dev-libs/libpqxx-3*
+ )
semantic-desktop? ( dev-libs/soprano )
ssl? ( dev-libs/openssl )
+ sybase? ( dev-db/freetds )
tiff? ( media-libs/tiff )
truetype? ( media-libs/freetype:2 )
word-perfect? (
@@ -73,67 +89,25 @@ RDEPEND="
app-text/libwps
app-text/libwpg
)
+ xbase? ( dev-db/xbase )
xslt? ( dev-libs/libxslt )
+ calligra_features_kexi? ( >=dev-db/sqlite-3.7.3 )
"
DEPEND="${RDEPEND}"
-# By default all bulds are enabled.
-# When you find out what some option does just describe it here and
-# make it optional if required.
-# The list is copied from ccmake output.
-#
-# BUILD_artistictextshape
-# BUILD_braindump - note collection app ; USE_EXPAND
-# BUILD_calligra - the generic "open file" office app ; default on
-# BUILD_chartshape
-# BUILD_colorengines
-# BUILD_commentshape
-# BUILD_converter
-# BUILD_cstester
-# BUILD_defaultTools
-# BUILD_divineProportion
-# BUILD_doc - handbook stuff, handled by KDE_HANDBOOK=optional
-# BUILD_dockers
-# BUILD_flow - flowcharting app ; used to be kivio ; USE_EXPAND
-# BUILD_generic_wrapper
-# BUILD_karbon - vector drawing app ; handled as USE_EXPAND
-# BUILD_kexi - database manager ; handled as USE_EXPAND
-# BUILD_kformula << formula editor, should be part of base libs
-# BUILD_koabstraction << part of base libs
-# BUILD_koreport << reporting library, should be part of base libs
-# BUILD_kounavail << part of base libs
-# BUILD_kpresenter - presentation creator ; handled as USE_EXPAND (now stage ???)
-# BUILD_krita - image editor ; handled as USE_EXPAND
-# BUILD_kthesaurus << thesaurus framework, should be part of base libs
-# BUILD_libkowmf << wmf filter ; handled as wmf useflag
-# BUILD_libmsooxml << msooxml filter ; handled as mso useflag
-# BUILD_mdb
-# BUILD_mobile << "Maemo 5 Office UI for KOffice" ; always off
-# BUILD_musicshape
-# BUILD_pathshapes
-# BUILD_pictureshape
-# BUILD_pluginshape
-# BUILD_quickprint
-# BUILD_reporting
-# BUILD_scan
-# BUILD_slidecompare
-# BUILD_staging
-# BUILD_tables - table editor ; handled as USE_EXPAND
-# BUILD_textediting
-# BUILD_textshape
-# BUILD_thumbnail
-# BUILD_treeshape
-# BUILD_variables
-# BUILD_vectorshape
-# BUILD_videoshape
-# BUILD_words - text editor ; handled as USE_EXPAND
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.74-jpeglcms.patch"
+ "${FILESDIR}/${PN}-2.3.74-jpeglcms-2.patch"
+)
src_configure() {
local cal_ft
# first write out things we want to hard-enable
local mycmakeargs=(
- "-DWITH_LibXml2=ON" # harddep for few parts
+ "-DWITH_Boost=ON"
+ "-DWITH_LibXml2=ON"
+ "-DWITH_PNG=ON"
"-DWITH_ZLIB=ON"
"-DGHNS=ON"
"-DWITH_X11=ON"
@@ -148,13 +122,12 @@ src_configure() {
"-DCREATIVEONLY=OFF"
"-DWITH_TINY=OFF"
"-DWITH_CreateResources=OFF" # NOT PACKAGED: http://create.freedesktop.org/
- "-DWITH_DCMTK=OFF" # NOT PACKAGED: http://www.dcmtk.org/dcmtk.php.en
- "-DWITH_Spnav=OFF" # NOT PACKAGED: http://spacenav.sourceforge.net/
+ "-DWITH_DCMTK=OFF" # NOT PACKAGED: http://www.dcmtk.org/dcmtk.php.en
+ "-DWITH_Spnav=OFF" # NOT PACKAGED: http://spacenav.sourceforge.net/
)
# regular options
mycmakeargs+=(
- $(cmake-utils_use_with boost Boost)
$(cmake-utils_use_with crypt QCA2)
$(cmake-utils_use_with eigen Eigen2)
$(cmake-utils_use_with exif Exiv2)
@@ -173,6 +146,7 @@ src_configure() {
$(cmake-utils_use_with kdcraw Kdcraw)
$(cmake-utils_use_with kdepim KdepimLibs)
$(cmake-utils_use_with lcms LCMS2)
+ $(cmake-utils_use_with marble Marble)
$(cmake-utils_use_with mysql MySQL)
$(cmake-utils_use_with okular Okular)
$(cmake-utils_use_with openctl OpenCTL)
@@ -180,15 +154,16 @@ src_configure() {
$(cmake-utils_use_with opengl OpenGL)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with pdf Pstoedit)
- $(cmake-utils_use_with png PNG)
$(cmake-utils_use_with postgres PostgreSQL)
$(cmake-utils_use_with semantic-desktop Soprano)
$(cmake-utils_use_with ssl OpenSSL)
+ $(cmake-utils_use_with sybase FreeTDS)
$(cmake-utils_use_with tiff TIFF)
$(cmake-utils_use_with threads Threads)
$(cmake-utils_use_with truetype Freetype)
$(cmake-utils_use_with word-perfect WPD)
$(cmake-utils_use_with word-perfect WPG)
+ $(cmake-utils_use_with xbase XBase)
$(cmake-utils_use_with xslt LibXslt)
$(cmake-utils_use_build wmf libkowmf)
$(cmake-utils_use_build mso libmsooxml)
diff --git a/app-office/calligra/files/calligra-2.3.74-jpeglcms-2.patch b/app-office/calligra/files/calligra-2.3.74-jpeglcms-2.patch
new file mode 100644
index 000000000000..986139fcb2ed
--- /dev/null
+++ b/app-office/calligra/files/calligra-2.3.74-jpeglcms-2.patch
@@ -0,0 +1,21 @@
+diff -ruN calligra-2.3.74.orig/krita/plugins/formats/jpeg/CMakeLists.txt calligra-2.3.74/krita/plugins/formats/jpeg/CMakeLists.txt
+--- calligra-2.3.74.orig/krita/plugins/formats/jpeg/CMakeLists.txt 2011-08-12 15:51:32.000000000 +0200
++++ calligra-2.3.74/krita/plugins/formats/jpeg/CMakeLists.txt 2011-08-19 23:41:02.000000000 +0200
+@@ -16,7 +16,7 @@
+
+ kde4_add_plugin(kritajpegimport ${kritajpegimport_PART_SRCS})
+
+-target_link_libraries(kritajpegimport kritaui jpeg ${LCMS_LIBRARIES} ${EXIV2_LIBRARIES} )
++target_link_libraries(kritajpegimport kritaui jpeg ${LCMS2_LIBRARIES} ${EXIV2_LIBRARIES} )
+
+ install(TARGETS kritajpegimport DESTINATION ${PLUGIN_INSTALL_DIR})
+
+@@ -31,7 +31,7 @@
+
+ kde4_add_plugin(kritajpegexport ${kritajpegexport_PART_SRCS})
+
+-target_link_libraries(kritajpegexport kritaui jpeg ${LCMS_LIBRARIES} ${EXIV2_LIBRARIES} )
++target_link_libraries(kritajpegexport kritaui jpeg ${LCMS2_LIBRARIES} ${EXIV2_LIBRARIES} )
+
+ install(TARGETS kritajpegexport DESTINATION ${PLUGIN_INSTALL_DIR})
+
diff --git a/app-office/calligra/files/calligra-2.3.74-jpeglcms.patch b/app-office/calligra/files/calligra-2.3.74-jpeglcms.patch
new file mode 100644
index 000000000000..2f9810b5456c
--- /dev/null
+++ b/app-office/calligra/files/calligra-2.3.74-jpeglcms.patch
@@ -0,0 +1,26 @@
+From: Boudewijn Rempt <boud@valdyas.org>
+Date: Tue, 16 Aug 2011 15:50:16 +0000
+Subject: Allow jpeg filter to build with both versions of lcms
+X-Git-Url: http://quickgit.kde.org/?p=calligra.git&amp;a=commitdiff&amp;h=0b4a019f25a7098c8899d3920db2e1901833aaf7
+---
+Allow jpeg filter to build with both versions of lcms
+
+Use HAVE_LCMS, not LCMS_FOUND.
+---
+
+
+--- a/krita/plugins/formats/CMakeLists.txt
++++ b/krita/plugins/formats/CMakeLists.txt
+@@ -31,9 +31,9 @@ if(KDCRAW_FOUND)
+ add_subdirectory( raw )
+ endif(KDCRAW_FOUND)
+
+-if(JPEG_FOUND AND LCMS_FOUND)
++if(JPEG_FOUND AND HAVE_LCMS)
+ add_subdirectory(jpeg)
+-endif(JPEG_FOUND AND LCMS_FOUND)
++endif(JPEG_FOUND AND HAVE_LCMS)
+
+ if(TIFF_FOUND)
+ add_subdirectory(tiff)
+
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index 21d5610103bb..608cd4656872 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -5,18 +5,20 @@
<email>dilfridge@gentoo.org</email>
</maintainer>
<herd>kde</herd>
+ <herd>openoffice</herd>
<use>
- <flag name="boost">Enable <pkg>dev-libs/boost</pkg> templating support</flag>
<flag name="eigen">Enable <pkg>dev-cpp/eigen</pkg> mathematical templates support</flag>
<flag name="glew">Enable <pkg>media-libs/glew</pkg> opengl extension library support</flag>
<flag name="glib">Enable support for C library routines from <pkg>dev-libs/glib</pkg></flag>
<flag name="gsf">Enable support for ODT structures extraction via <pkg>gnome-extra/libgsf</pkg></flag>
<flag name="kdcraw">Enable support for KDE image manipulating interface via <pkg>kde-base/libkdcraw</pkg></flag>
<flag name="kdepim">Enable support for KDEPIM resources integration</flag>
+ <flag name="marble">Enable displaying of maps using Marble</flag>
<flag name="mso">Enable support for various MS Office TM file formats</flag>
<flag name="okular">Enable bindings for <pkg>kde-base/okular</pkg></flag>
<flag name="openctl">Enable support for transformation algorithms via <pkg>media-libs/opengtl</pkg></flag>
<flag name="word-perfect">Enable support for various WordPerfect file formats</flag>
+ <flag name="xbase">Enable support for xbase compatible database formats</flag>
<flag name="xslt">Enable xslt and exslt support format support</flag>
</use>
</pkgmetadata>