summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-12-10 15:47:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-12-10 15:47:51 +0000
commitc95a7bd8f3f2364d280c099e096b3267c391d54e (patch)
tree31074933eb933a10d4c8edb9b3d38d97afabf52a /app-office
parentBump asn1-types to 0.2.2 (diff)
downloadgentoo-2-c95a7bd8f3f2364d280c099e096b3267c391d54e.tar.gz
gentoo-2-c95a7bd8f3f2364d280c099e096b3267c391d54e.tar.bz2
gentoo-2-c95a7bd8f3f2364d280c099e096b3267c391d54e.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/orage/ChangeLog7
-rw-r--r--app-office/orage/orage-4.10.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 94a81c93b17d..b4948e16f3f6 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/orage
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.74 2013/05/05 17:18:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.75 2013/12/10 15:47:51 ssuominen Exp $
+
+*orage-4.10.0 (10 Dec 2013)
+
+ 10 Dec 2013; Samuli Suominen <ssuominen@gentoo.org> +orage-4.10.0.ebuild:
+ Version bump.
05 May 2013; Samuli Suominen <ssuominen@gentoo.org> -orage-4.8.3.ebuild:
old
diff --git a/app-office/orage/orage-4.10.0.ebuild b/app-office/orage/orage-4.10.0.ebuild
new file mode 100644
index 000000000000..f99cb85e0c7e
--- /dev/null
+++ b/app-office/orage/orage-4.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.10.0.ebuild,v 1.1 2013/12/10 15:47:51 ssuominen Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify +xfce_plugins_clock"
+
+RDEPEND=">=dev-libs/libical-0.48:=
+ dev-libs/popt:=
+ >=x11-libs/gtk+-2.10:2
+ berkdb? ( >=sys-libs/db-4 )
+ dbus? ( >=dev-libs/dbus-glib-0.100 )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.10 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable xfce_plugins_clock libxfce4panel)
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ imagesdir="${EPREFIX}"/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
+}