summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-08-10 20:06:10 +0000
committerVlastimil Babka <caster@gentoo.org>2010-08-10 20:06:10 +0000
commitb818320dfcca36446a92ea98eacb0d291ac1f52d (patch)
treedbbb77de7f4379851d0ab7e27b1022a6d2bb9d2b /app-office
parentStable for HPPA (bug #328797). (diff)
downloadgentoo-2-b818320dfcca36446a92ea98eacb0d291ac1f52d.tar.gz
gentoo-2-b818320dfcca36446a92ea98eacb0d291ac1f52d.tar.bz2
gentoo-2-b818320dfcca36446a92ea98eacb0d291ac1f52d.zip
Version bump. Removes tabbed interface.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-1.0.9.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 19a640cb5513..cf2f47520847 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.51 2010/08/07 22:56:11 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.52 2010/08/10 20:06:10 caster Exp $
+
+*taskcoach-1.0.9 (10 Aug 2010)
+
+ 10 Aug 2010; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.0.9.ebuild:
+ Version bump. Removes tabbed interface.
*taskcoach-1.0.8 (07 Aug 2010)
diff --git a/app-office/taskcoach/taskcoach-1.0.9.ebuild b/app-office/taskcoach/taskcoach-1.0.9.ebuild
new file mode 100644
index 000000000000..4a8ae8932574
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.0.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.0.9.ebuild,v 1.1 2010/08/10 20:06:10 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}
+
+pkg_postinst() {
+ elog "With version 1.0, taskcoach could be stabilized if there is enough user interest."
+ elog "If you run a stable stable system and had to keyword taskcoach, please comment/vote"
+ elog "on http://bugs.gentoo.org/show_bug.cgi?id=311841"
+}