summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-10-01 22:03:57 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-10-01 22:03:57 +0000
commitb4254fe5cf465a9988f0c983aaf2f0aacbed64d0 (patch)
tree468b6fee13fa8483580e6413548621088811f129 /app-office
parentmanifest (Manifest recommit) (diff)
downloadgentoo-2-b4254fe5cf465a9988f0c983aaf2f0aacbed64d0.tar.gz
gentoo-2-b4254fe5cf465a9988f0c983aaf2f0aacbed64d0.tar.bz2
gentoo-2-b4254fe5cf465a9988f0c983aaf2f0aacbed64d0.zip
version bump, masked for now
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/ChangeLog9
-rw-r--r--app-office/openoffice-bin/files/1.1.3/ooffice-wrapper-1.3279
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.1.31
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.3.ebuild208
4 files changed, 496 insertions, 1 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index b4c90b84f729..cbfab3b72985 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.48 2004/09/20 01:49:26 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.49 2004/10/01 22:03:57 suka Exp $
+
+*openoffice-bin-1.1.3 (02 Oct 2004)
+
+ 02 Oct 2004; suka@gentoo.org +files/1.1.3/ooffice-wrapper-1.3,
+ +openoffice-bin-1.1.3.ebuild:
+ Version bump. Masked for now, will unmask after the official release
+ announcement
19 Sep 2004; Travis Tilley <lv@gentoo.org> openoffice-bin-1.1.2.ebuild:
stable on amd64
diff --git a/app-office/openoffice-bin/files/1.1.3/ooffice-wrapper-1.3 b/app-office/openoffice-bin/files/1.1.3/ooffice-wrapper-1.3
new file mode 100644
index 000000000000..779dc98d73bb
--- /dev/null
+++ b/app-office/openoffice-bin/files/1.1.3/ooffice-wrapper-1.3
@@ -0,0 +1,279 @@
+#!/bin/sh
+#
+# Wrapper script for openoffice
+#
+# (C) Peter 'Nidd' Novodvorsky, 2001,2002
+# (C) Martin 'empty' Quinson, 2002.
+# Modifications by Chris Halls
+# Modifications by Lucien Saviot
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+# this string should be exactly as in ~/.sversionrc
+PV=<pv>
+OOVERSION="OpenOffice.org ${PV}"
+
+##
+## Source system configuration file
+##
+[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
+
+# Migration to new user install dir
+if [ -d "$HOME/.openoffice/1.1.2" ] ; then
+ mv $HOME/.openoffice/1.1.2 $HOME/.openoffice/1.1.3
+ sed -i -e s/'.openoffice\/1.1.2'/'.openoffice\/1.1.3'/g $HOME/.sversionrc
+ sed -i -e s/1.1.2/1.1.3/g $HOME/.openoffice/1.1.3/user/basic/*.xlc
+ echo "Your user install dir has been moved over to the new version"
+fi
+
+#Make smooth up- and downgrading between minor versions possible
+if [ -e "$HOME/.sversionrc" ] ; then
+ sed -i -e s/1.1.2/1.1.3/g $HOME/.sversionrc
+fi
+
+###
+### Get user settings directory from ~/.sversionrc and echo directory name to stdout
+### get_settings_dir <Version>
+### return: 0 - directory found,
+### 1 - ~/.sversionrc non existent
+### 2 - entry exists in ~/.sversionrc but directory not found
+### 3 - ~/.sversionrc exists but no entry found
+get_settings_dir()
+{
+ [ -r ${HOME}/.sversionrc ] || exit 1
+ # warning, .sversionrc is DOS encoded so strip ^M
+ settings_dir="`tr -d '\r' < ~/.sversionrc | sed -n "/^$1=/s%^$1=file://\(.*\)$%\1%p"`"
+ echo "$settings_dir"
+ [ -n "$settings_dir" ] || exit 3
+ [ -d "$settings_dir" ] || exit 2
+}
+
+##
+## where does OO live for this user ?
+##
+OOHOME="`get_settings_dir "$OOVERSION"`"
+if [ $? -eq 2 ] ; then
+ # .sversionrc contains a version yet the directory does not exist
+ echo "I'm confused because I can't find OpenOffice's user files."
+ echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
+ echo "but they are not. Please fix the situation manually."
+ echo "You may want to edit ~/.sversionrc to indicate where is OO"
+ echo "installed, or remove it if you did remove your installation"
+ echo "directory manually (you bad one)."
+ exit 1
+fi
+
+##
+## Unset SESSION_MANAGER if gnome-session is the session manager
+## See http://www.openoffice.org/issues/show_bug.cgi?id=4494
+##
+SMPID=`echo $SESSION_MANAGER | sed --quiet "s,local.*/,,p"`
+if [ -n "$SMPID" ] && [ -L /proc/"$SMPID"/exe ]; then
+
+ SESMGR="`readlink -f /proc/$SMPID/exe`"
+ case "$SESMGR" in
+ /usr/bin/gnome-session*)
+ echo "Gnome session manager detected - session management disabled"
+ unset SESSION_MANAGER
+ ;;
+ esac
+fi
+
+##
+## Add known Debian fonts locations to search path
+##
+## Please report if you have problems with fonts, or know of non-defoma integrated packages that place fonts in other
+## paths.
+##
+
+# Default font path. This is used if SAL_FONTPATH_USER is not defined.
+DEBOO_FONTPATH="/usr/lib/X11/fonts/misc/;/usr/lib/X11/fonts/cyrillic/;\
+/usr/lib/X11/fonts/100dpi/:unscaled;/usr/lib/X11/fonts/75dpi/:unscaled;\
+/usr/lib/X11/fonts/Type1/;/usr/lib/X11/fonts/CID;/usr/lib/X11/fonts/Speedo/;\
+/usr/lib/X11/fonts/100dpi/;/usr/lib/X11/fonts/75dpi/;\
+/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType;\
+/usr/lib/X11/fonts/TrueType;\
+/usr/share/fonts/truetype/kochi;\
+/usr/lib/X11/fonts/TrueType/larabie-straight;\
+/usr/lib/X11/fonts/TrueType/larabie-uncommon"
+
+SAL_FONTPATH_USER=${SAL_FONTPATH_USER:-"$DEBOO_FONTPATH"}
+export SAL_FONTPATH_USER
+
+## search LOCALE
+if [ -n "$LC_ALL" ]; then
+ LOCALE="$LC_ALL"
+ # OOo doesn't understand LC_ALL, so set LANG
+ LANG="$LC_ALL"
+elif [ -n "$LANG" ]; then
+ LOCALE="$LANG"
+elif [ -n "$LC_MESSAGES" ]; then
+ LOCALE="$LC_MESSAGES"
+ LANG="$LC_MESSAGES"
+else
+ LOCALE="en_US"
+fi
+
+# Set locale to en_US if locale is C
+if [ "x$LOCALE" = "xC" ] ; then LOCALE="en_US"; fi
+
+LOCALEOO=`echo $LOCALE | sed 's/_/-/'`
+
+##
+## install OO for this user if needed
+##
+if [ -z "$OOHOME" ] ; then
+ if [ -e /etc/openoffice/autoresponse-<pv>.conf ] && \
+ grep -q DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf ; then
+
+# Do not take old settings as migration results in broken behaviour
+#
+# UPDATEFLAG=""
+# if oldhome="`get_settings_dir "OpenOffice.org 1.0.3"`" ; then
+# OOHOME="$oldhome"
+# echo "Using settings from 1.0.3: /${oldhome}"
+# /bin/echo -e "OpenOffice.org <pv>=file://$oldhome\r" >> ~/.sversionrc
+# UPDATEFLAG="-update:/$oldhome"
+# fi
+ # first install
+ OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf | \
+ sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
+
+ if [ -d "$OOHOME" ]; then
+ echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
+ echo "yet the directory $OOHOME exists."
+ echo "Please remove $OOHOME and try again."
+ exit 1
+ fi
+
+ echo "running openoffice.org setup..."
+ if ! /opt/OpenOffice.org/program/setup ${UPDATEFLAG} -R:/etc/openoffice/autoresponse-<pv>.conf >& /dev/null; then
+ echo "setup failed.. abort"
+ exit 1
+ fi
+
+
+# fi
+
+ echo "Setup complete. Running openoffice.org..."
+
+else
+ echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
+ echo "the /etc/openoffice/autoresponse-<pv>.conf file manually ?"
+ echo "This file should contain DESTINATIONPATH"
+ exit 1
+ fi
+fi
+
+##
+## If no file is specified on the command line, which application to start?
+## The wrapper can be called from several links in /usr/bin
+##
+if [ $# = 0 ]; then
+ case `basename $0` in
+ oocalc) set -- private:factory/scalc;;
+ oodraw) set -- private:factory/sdraw;;
+ ooimpress) set -- private:factory/simpress;;
+ oomath) set -- private:factory/smath;;
+ oowriter) set -- private:factory/swriter;;
+ oohtml) set -- private:factory/swriter/web;;
+ oomaster) set -- private:factory/swriter/Global;;
+ esac
+fi
+
+## Previous dead installation?
+[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
+
+# There is no locale import file
+## Change the ooLocale key in SETUPFILE acording to LOCALE
+#TMPFILE=`mktemp -t oooLocale.XXXXXXXXXX` && {
+# cat >${TMPFILE} <<EOF
+#<?xml version="1.0" encoding="UTF-8"?>
+#<oor:node xmlns:oor="http://openoffice.org/2001/registry" xmlns:xs="http://www.w3.org/2001/XMLSchema" oor:name="Setup" oor:package="org.openoffice">
+# <node oor:name="L10N">
+# <prop oor:name="ooLocale" oor:type="xs:string">
+# <value>$LOCALEOO</value>
+# </prop>
+# </node>
+#</oor:node>
+#EOF
+# ooconfigimport $TMPFILE >/dev/null
+# rm -f ${TMPFILE}
+#}
+
+# Check whether the programs actually link to anything, or are from an old
+# version.
+
+if [ ! -s $OOHOME/setup ]; then
+ echo "${OOHOME}/setup links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/setup ${OOHOME}/setup
+fi
+if [ ! -s $OOHOME/soffice ]; then
+ echo "${OOHOME}/soffice links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/soffice
+fi
+if [ ! -s $OOHOME/spadmin ]; then
+ echo "${OOHOME}/spadmin links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/spadmin
+fi
+
+
+##
+## That's it. Launch the beast (with the given args)
+##
+LANG=$LOCALE
+export LANG
+case `basename $0` in
+ oosetup) exec "$OOHOME/setup"
+ ;;
+ oopadmin) exec "$OOHOME/spadmin"
+ ;;
+ *) exec "$OOHOME/soffice" "$@"
+ ;;
+esac
+## Changelog
+# 2003/04/01 halls
+# * Version 1.1beta
+# 2003/02/03 halls
+# * Check for nonexistent ooLocale every run
+# 2003/01/09 halls
+# * Version 1.0.2
+# 12/15 saviot
+# * Change ooLocale at startup in Setup.xml
+# <ooLocale cfg:type="string"/> doesn't work for help.
+# 12/03 challs
+# * Add Debian font paths to user font path
+# 11/14 saviot
+# * correct handling of UI language
+# * don't change Linguistic.xml after first startup(#168780)
+# * TODO: provide better defaults on first startup
+# 10/03 challs
+# * Fix use with LC_ALL
+# 07/10 challs
+# * use 1.0.1 directory and improve error checking
+# 07/02 challs
+# * use readlink in /proc/PID/exe to get
+# real session manager name
+# 06/12 challs
+# * merge into main package
+# * change $@ to "$@"
+# * source configuration file:
+# /etc/openoffice/openoffice.conf
+# 06/12 mquinson
+# * strace only when DEBUG is set to yes
+# * readd the $@ to pass the args to soffice
+# 06/06 mquinson
+# * Make sure the OLDLOCALE is never empty
+# * handle the case where the locale is C
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.3 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.3
new file mode 100644
index 000000000000..73ee417f4f30
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.3
@@ -0,0 +1 @@
+MD5 1d87f6c730b6fa5252d7dfd4d2c69de4 OOo_1.1.3_LinuxIntel_install.tar.gz 80123557
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.3.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.3.ebuild
new file mode 100644
index 000000000000..f2fa843c66a4
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.3.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.3.ebuild,v 1.1 2004/10/01 22:03:57 suka Exp $
+
+# NOTE: There are two big issues that should be addressed.
+#
+# 1) Language support and fonts should be addressed.
+
+LOC="/opt"
+
+INSTDIR="${LOC}/OpenOffice.org"
+MY_P="OOo_${PV}_LinuxIntel_install"
+use ppc && MY_P="OOo_${PV}_LinuxPowerPC_en_installer"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="OpenOffice productivity suite"
+HOMEPAGE="http://www.openoffice.org/"
+SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )"
+
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="kde gnome"
+
+DEPEND="sys-apps/findutils
+ virtual/libc
+ >=dev-lang/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
+ !app-office/openoffice
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
+RDEPEND="virtual/libc
+ >=dev-lang/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
+ !app-office/openoffice
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
+
+src_install() {
+ # Sandbox issues; bug #8587
+ addpredict "/user"
+ addpredict "/share"
+ addpredict "/pspfontcache"
+ addpredict "/usr/bin/soffice"
+ addpredict "/root/.gconfd"
+ addpredict "/opt/OpenOffice.org/foo.tmp"
+ addpredict "/opt/OpenOffice.org/delme"
+
+ # Sandbox issues; bug 8063
+ addpredict "/dev/dri"
+
+ # Autoresponse file for main installation
+ cat > ${T}/rsfile-global <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_NETWORK
+ INSTALLATIONTYPE=STANDARD
+ DESTINATIONPATH=<destdir>
+ OUTERPATH=
+ LOGFILE=
+ LANGUAGELIST=<LANGUAGE>
+
+ [JAVA]
+ JavaSupport=preinstalled_or_none
+ END_RS
+
+ # Autoresponse file for user installation
+ cat > ${T}/rsfile-local <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_WORKSTATION
+ INSTALLATIONTYPE=WORKSTATION
+ DESTINATIONPATH=<home>/.openoffice/<pv>
+
+ [JAVA]
+ JavaSupport=none
+ END_RS
+
+ # Fixing install location in response file
+ sed -e "s|<destdir>|${D}${INSTDIR}|" \
+ ${T}/rsfile-global > ${T}/autoresponse
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ cd ${S}
+ ./setup -nogui -v -r:${T}/autoresponse || die "The setup program failed"
+
+ echo
+ einfo "Removing build root from registry..."
+ # Remove totally useless stuff.
+ rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh}
+ # Remove build root from registry and co
+ egrep -rl "${D}" ${D}${INSTDIR}/* | \
+ xargs -i perl -pi -e "s|${D}||g" {} || :
+
+ einfo "Fixing permissions..."
+ # Fix permissions
+ find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
+ chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
+
+ # Fix symlinks
+ for x in "soffice program/spadmin" \
+ "program/setup setup" \
+ "program/spadmin spadmin"
+ do
+ dosym $(echo ${x} | awk '{print $1}') \
+ ${INSTDIR}/$(echo ${x} | awk '{print $2}')
+ done
+
+ # Install user autoresponse file
+ insinto /etc/openoffice
+ sed -e "s|<pv>|${PV}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
+ doins ${T}/autoresponse-${PV}.conf
+
+ # Install wrapper script
+ exeinto /usr/bin
+ sed -e "s|<pv>|${PV}|g" \
+ ${FILESDIR}/${PV}/ooffice-wrapper-1.3 > ${T}/ooffice
+ doexe ${T}/ooffice
+
+ # Component symlinks
+ for app in calc draw impress math writer web setup padmin; do
+ dosym ooffice /usr/bin/oo${app}
+ done
+
+ einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
+ if use gnome
+ then
+ insinto /usr/share/gnome/apps/OpenOffice.org
+ # Install the files needed for the catagory
+ doins ${D}${INSTDIR}/share/gnome/net/.directory
+ doins ${D}${INSTDIR}/share/gnome/net/.order
+
+ # Change this to ooo*.desktop from *.desktop for now, since
+ # otherwise two sets of icons will appear in the GNOME menu.
+ # <brad@gentoo.org> (04 Aug 2003)
+ for x in ${D}${INSTDIR}/share/gnome/net/ooo*.desktop
+ do
+ # We have to handle soffice and setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ perl -pi -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+ if use kde
+ then
+ local kdeloc="${D}${INSTDIR}/share/kde/net/"
+
+ insinto /usr/share/applnk/OpenOffice.org\ 1.1
+ # Install the files needed for the category
+ doins ${kdeloc}/.directory
+ dodir /usr/share
+ # Install the icons and mime info
+ cp -a ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
+
+ for x in ${kdeloc}/*.desktop
+ do
+ # We have to handle soffice and setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ perl -pi -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+
+ # Remove unneeded stuff
+ rm -rf ${D}${INSTDIR}/share/cde
+
+ # Make sure these do not get nuked.
+ keepdir ${INSTDIR}/user/registry/res/en-us/org/openoffice/{Office,ucb}
+ keepdir ${INSTDIR}/user/psprint/{driver,fontmetric}
+ keepdir ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
+
+ #touch files to make portage uninstalling happy (#22593)
+ find ${D} -type f -exec touch {} \;
+}
+
+pkg_preinst() {
+
+ # The one with OO-1.0.0 was not valid
+ if [ -f ${ROOT}/etc/openoffice/autoresponse.conf ]
+ then
+ rm -f ${ROOT}/etc/openoffice/autoresponse.conf
+ fi
+}
+
+pkg_postinst() {
+
+ einfo "******************************************************************"
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oocalc, oodraw, ooimpress, oomath, ooweb or oowriter"
+ einfo
+ einfo "******************************************************************"
+}
+