summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-02-21 00:03:17 +0000
committerAron Griffis <agriffis@gentoo.org>2002-02-21 00:03:17 +0000
commitab5a752f9309eb3c87e053ef6dc39f9a112c0a9e (patch)
tree5136aa06b8bac970d0ca6c7c683ed0e5bfbdd637 /app-office
parentfixed permissions on postdrop and postqueue. (diff)
downloadgentoo-2-ab5a752f9309eb3c87e053ef6dc39f9a112c0a9e.tar.gz
gentoo-2-ab5a752f9309eb3c87e053ef6dc39f9a112c0a9e.tar.bz2
gentoo-2-ab5a752f9309eb3c87e053ef6dc39f9a112c0a9e.zip
Fixed to not violate sandbox
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx-base/ChangeLog23
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r11
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.4-r1.ebuild39
3 files changed, 55 insertions, 8 deletions
diff --git a/app-office/lyx-base/ChangeLog b/app-office/lyx-base/ChangeLog
index 025e784716f1..0b6f1434fc77 100644
--- a/app-office/lyx-base/ChangeLog
+++ b/app-office/lyx-base/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for app-office/lyx-base
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/ChangeLog,v 1.2 2002/02/21 00:03:17 agriffis Exp $
+
+*lyx-base-1.1.6.4-r1 (20 Feb 2002)
+
+ 20 Feb 2002; Aron Griffis <agriffis@gentoo.org> lyx-base-1.1.6.4-r1.ebuild :
+
+ Fixed to not violate sandbox.
*lyx-base-1.1.6.4 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r1 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r1
new file mode 100644
index 000000000000..8c46a40b69b1
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r1
@@ -0,0 +1 @@
+MD5 de8fc7e0f390f12db4093098f8fee9d6 lyx-1.1.6fix4.tar.gz 5564584
diff --git a/app-office/lyx-base/lyx-base-1.1.6.4-r1.ebuild b/app-office/lyx-base/lyx-base-1.1.6.4-r1.ebuild
new file mode 100644
index 000000000000..f49bef9ce65a
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/lyx-base-1.1.6.4-r1.ebuild,v 1.1 2002/02/21 00:03:17 agriffis Exp $
+
+# The real version of LyX is 1.1.6fix4. As Portage has no support for
+# arbitrary suffixes like 'fix', this is translated into 1.1.6.4.
+P=lyx-1.1.6fix4
+S=${WORKDIR}/${P}
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-devel/ld.so"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir='$(prefix)/share/info' \
+ --mandir='$(prefix)/share/man' || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install-strip
+}