summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-18 09:03:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-18 09:03:05 +0000
commita694e1f438762e7e7163409b589123b519196e18 (patch)
tree2146da00866391a45d413d148692fa6f9dc5f43f /app-office
parentinitial commit (diff)
downloadgentoo-2-a694e1f438762e7e7163409b589123b519196e18.tar.gz
gentoo-2-a694e1f438762e7e7163409b589123b519196e18.tar.bz2
gentoo-2-a694e1f438762e7e7163409b589123b519196e18.zip
Add patch that disables the header check for clucene, for some reason the check fails even if the header is around and working.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog8
-rw-r--r--app-office/libreoffice/files/libreoffice-3.6-clucene-remove-wrong-check.patch25
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild6
3 files changed, 36 insertions, 3 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index abb8de040a50..04d2969e3602 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.282 2012/04/17 11:26:30 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.283 2012/04/18 09:03:05 scarabeus Exp $
+
+ 18 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libreoffice-3.6-clucene-remove-wrong-check.patch,
+ libreoffice-3.5.2.2.ebuild, libreoffice-9999-r2.ebuild:
+ Add patch that disables the header check for clucene, for some reason the
+ check fails even if the header is around and working.
17 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-3.5.2.2.ebuild,
libreoffice-9999-r2.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-3.6-clucene-remove-wrong-check.patch b/app-office/libreoffice/files/libreoffice-3.6-clucene-remove-wrong-check.patch
new file mode 100644
index 000000000000..1cecf082725d
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-3.6-clucene-remove-wrong-check.patch
@@ -0,0 +1,25 @@
+diff --git a/configure.in b/configure.in
+index ed16f92..8934bb5 100644
+--- a/configure.in
++++ b/configure.in
+@@ -5877,20 +5877,6 @@ if test "$with_system_clucene" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_CLUCENE=YES
+ PKG_CHECK_MODULES(CLUCENE, libclucene-core)
+-
+- AC_LANG_PUSH([C++])
+- save_CXXFLAGS=$CXXFLAGS
+- save_CPPFLAGS=$CPPFLAGS
+- CXXFLAGS="$CXXFLAGS $CLUCENE_CFLAGS"
+- CPPFLAGS="$CPPFLAGS $CLUCENE_CFLAGS"
+- dnl http://sourceforge.net/tracker/index.php?func=detail&aid=3392466&group_id=80013&atid=558446
+- dnl https://bugzilla.redhat.com/show_bug.cgi?id=794795
+- AC_CHECK_HEADER([CLucene/analysis/cjk/CJKAnalyzer.h], [],
+- [AC_MSG_ERROR([Your version of libclucene has contribs-lib missing.])], [])
+- CXXFLAGS=$save_CXXFLAGS
+- CPPFLAGS=$save_CPPFLAGS
+- AC_LANG_POP([C++])
+-
+ CLUCENE_LIBS="$CLUCENE_LIBS -lclucene-contribs-lib"
+ else
+ AC_MSG_RESULT([internal])
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 6363ef6c0b49..57f00bbbddc0 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.48 2012/04/17 11:26:30 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.49 2012/04/18 09:03:05 scarabeus Exp $
EAPI=4
@@ -195,11 +195,13 @@ DEPEND="${COMMON_DEPEND}
>=dev-java/ant-core-1.7
test? ( dev-java/junit:4 )
)
+ test? ( dev-util/cppunit )
"
PATCHES=(
- # this can't be upstreamed :(
+ # not upstreamable stuff
"${FILESDIR}/${PN}-3.6-system-pyuno.patch"
+ "${FILESDIR}/${PN}-3.6-clucene-remove-wrong-check.patch"
)
REQUIRED_USE="