summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-24 12:20:24 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-24 12:20:24 +0000
commit9af179593fc0d3ee8daa5863c3dafee68e10438c (patch)
treee634af8c46f29377a7041d5420cc885dc993f072 /app-office
parenttypo fix, objprelink should work now (diff)
downloadgentoo-2-9af179593fc0d3ee8daa5863c3dafee68e10438c.tar.gz
gentoo-2-9af179593fc0d3ee8daa5863c3dafee68e10438c.tar.bz2
gentoo-2-9af179593fc0d3ee8daa5863c3dafee68e10438c.zip
fixed a patch for gnumeric 0.70 and removed the other versions snce they contain errors, use gnumeric-0.70-r1
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.651
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.661
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.671
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.70-r1 (renamed from app-office/gnumeric/files/digest-gnumeric-0.70)0
-rw-r--r--app-office/gnumeric/files/gnumeric-0.70-gdk-gc-ref.patch81
-rw-r--r--app-office/gnumeric/gnumeric-0.65.ebuild82
-rw-r--r--app-office/gnumeric/gnumeric-0.66.ebuild80
-rw-r--r--app-office/gnumeric/gnumeric-0.67.ebuild81
-rw-r--r--app-office/gnumeric/gnumeric-0.68.ebuild81
-rw-r--r--app-office/gnumeric/gnumeric-0.70-r1.ebuild (renamed from app-office/gnumeric/gnumeric-0.70.ebuild)77
10 files changed, 121 insertions, 364 deletions
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.65 b/app-office/gnumeric/files/digest-gnumeric-0.65
deleted file mode 100644
index b079e55622a1..000000000000
--- a/app-office/gnumeric/files/digest-gnumeric-0.65
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d31a2258b3f8ded219677a54f4fbe23f gnumeric-0.65.tar.gz
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.66 b/app-office/gnumeric/files/digest-gnumeric-0.66
deleted file mode 100644
index 0abd6304aa01..000000000000
--- a/app-office/gnumeric/files/digest-gnumeric-0.66
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bf68ff3dc11fec0e01281ab77a1584d9 gnumeric-0.66.tar.gz
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.67 b/app-office/gnumeric/files/digest-gnumeric-0.67
deleted file mode 100644
index 3d42eac4689e..000000000000
--- a/app-office/gnumeric/files/digest-gnumeric-0.67
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cad1e3adbefe5f2da480c79cb054a8cf gnumeric-0.67.tar.gz
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.70 b/app-office/gnumeric/files/digest-gnumeric-0.70-r1
index efb6fbb20ba7..efb6fbb20ba7 100644
--- a/app-office/gnumeric/files/digest-gnumeric-0.70
+++ b/app-office/gnumeric/files/digest-gnumeric-0.70-r1
diff --git a/app-office/gnumeric/files/gnumeric-0.70-gdk-gc-ref.patch b/app-office/gnumeric/files/gnumeric-0.70-gdk-gc-ref.patch
new file mode 100644
index 000000000000..38dbb19f6a8b
--- /dev/null
+++ b/app-office/gnumeric/files/gnumeric-0.70-gdk-gc-ref.patch
@@ -0,0 +1,81 @@
+Index: src/item-bar.c
+===================================================================
+RCS file: /cvs/gnome/gnumeric/src/item-bar.c,v
+retrieving revision 1.139
+retrieving revision 1.142
+diff -u -r1.139 -r1.142
+--- src/item-bar.c 2001/08/20 21:51:35 1.139
++++ src/item-bar.c 2001/08/24 07:37:25 1.142
+@@ -37,7 +37,7 @@
+ GnomeCanvasItem canvas_item;
+
+ GnumericCanvas *gcanvas;
+- GdkGC *gc, *lines, *shade; /* Draw gc */
++ GdkGC *text_gc, *lines, *shade;
+ GdkCursor *normal_cursor;
+ GdkCursor *change_cursor;
+ StyleFont *normal_font, *bold_font;
+@@ -156,7 +156,8 @@
+ {
+ ItemBar *ib;
+ GdkWindow *window;
+- GdkGC *gc;
++ GtkStyle *style;
++ GtkWidget *button;
+
+ if (GNOME_CANVAS_ITEM_CLASS (item_bar_parent_class)->realize)
+ (*GNOME_CANVAS_ITEM_CLASS (item_bar_parent_class)->realize)(item);
+@@ -164,23 +165,21 @@
+ ib = ITEM_BAR (item);
+ window = GTK_WIDGET (item->canvas)->window;
+
+- /* Configure our gc */
+- ib->gc = gc = gdk_gc_new (window);
+- {
+- GtkWidget *w = gtk_button_new ();
+- GtkStyle *style;
+- gtk_widget_ensure_style (w);
++ button = gtk_button_new ();
+
+- style = gtk_widget_get_style (w);
+- gdk_gc_set_foreground (ib->gc, &style->text[GTK_STATE_NORMAL]);
++ /* Configure our gc */
++ gtk_widget_ensure_style (button);
++ style = gtk_widget_get_style (button);
+
+- ib->shade = gdk_gc_ref (style->dark_gc[GTK_STATE_NORMAL]);
+- gtk_widget_destroy (w);
+- }
++ ib->text_gc = gdk_gc_new (window);
++ gdk_gc_set_foreground (ib->text_gc, &style->text[GTK_STATE_NORMAL]);
++ ib->shade = gdk_gc_new (window);
++ gdk_gc_set_foreground (ib->shade, &style->dark[GTK_STATE_NORMAL]);
+ ib->lines = gdk_gc_new (window);
+- gdk_gc_copy (ib->lines, gc);
++ gdk_gc_copy (ib->lines, ib->text_gc);
+ gdk_gc_set_line_attributes (ib->lines, 2, GDK_LINE_SOLID,
+ GDK_CAP_NOT_LAST, GDK_JOIN_MITER);
++ gtk_widget_destroy (button);
+
+ ib->normal_cursor = gdk_cursor_new (GDK_ARROW);
+ if (ib->is_col_header)
+@@ -195,7 +194,7 @@
+ {
+ ItemBar *ib = ITEM_BAR (item);
+
+- gdk_gc_unref (ib->gc);
++ gdk_gc_unref (ib->text_gc);
+ gdk_gc_unref (ib->lines);
+ gdk_gc_unref (ib->shade);
+ gdk_cursor_destroy (ib->change_cursor);
+@@ -243,8 +242,8 @@
+ rect->x + 1, rect->y + 1, rect->width-2, rect->height-2);
+ gtk_draw_shadow (canvas->style, drawable, GTK_STATE_NORMAL, shadow,
+ rect->x, rect->y, rect->width, rect->height);
+- gdk_gc_set_clip_rectangle (ib->gc, rect);
+- gdk_draw_string (drawable, font, ib->gc,
++ gdk_gc_set_clip_rectangle (ib->text_gc, rect);
++ gdk_draw_string (drawable, font, ib->text_gc,
+ rect->x + (rect->width - len) / 2,
+ rect->y + (rect->height - texth) / 2 + font->ascent + 1,
+ str);
diff --git a/app-office/gnumeric/gnumeric-0.65.ebuild b/app-office/gnumeric/gnumeric-0.65.ebuild
deleted file mode 100644
index 8e122ec9c688..000000000000
--- a/app-office/gnumeric/gnumeric-0.65.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.65.ebuild,v 1.4 2001/06/11 08:11:28 hallski Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- >=gnome-libs/libole2-0.2.3
- >=dev-util/xml-i18n-tools-0.8.4
- perl? ( >=sys-devel/perl-5 )
- python? ( >=dev-lang/python-2.0 )
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- nls? ( sys-devel/gettext )
- bonobo? ( >=gnome-base/bonobo-1.0 )"
-
-RDEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- bonobo? ( >=gnome-base/bonobo-1.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ "`use bonobo`" ] ; then
- myconf="$myconf --with-bonobo"
- else
- myconf="$myconf --without-bonobo"
- fi
- if [ "`use gb`" ]; then
- #does not work atm
- myconf="$myconf --without-gb"
- else
- myconf="$myconf --without-gb"
- fi
- if [ "`use perl`" ]; then
- myconf="$myconf --with-perl"
- else
- myconf="$myconf --without-perl"
- fi
- if [ "`use python`" ]; then
- myconf="$myconf --with-python"
- else
- myconf="$myconf --without-python"
- fi
- if [ "`use libgda`" ]; then
- myconf="$myconf --with-gda"
- else
- myconf="$myconf --without-gda"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
- cd ${S}
- try pmake
-}
-
-src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/app-office/gnumeric/gnumeric-0.66.ebuild b/app-office/gnumeric/gnumeric-0.66.ebuild
deleted file mode 100644
index 6009051f58eb..000000000000
--- a/app-office/gnumeric/gnumeric-0.66.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.66.ebuild,v 1.1 2001/06/28 09:47:57 hallski Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- >=gnome-libs/libole2-0.2.3
- >=dev-util/xml-i18n-tools-0.8.4
- perl? ( >=sys-devel/perl-5 )
- python? ( >=dev-lang/python-2.0 )
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- nls? ( sys-devel/gettext )
- bonobo? ( >=gnome-base/bonobo-1.0 )"
-
-RDEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- bonobo? ( >=gnome-base/bonobo-1.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ -z "`use bonobo`" ] ; then
- myconf="$myconf --without-bonobo"
- fi
- if [ "`use gb`" ]; then
- #does not work atm
- myconf="$myconf --without-gb"
- else
- myconf="$myconf --without-gb"
- fi
- if [ "`use perl`" ]; then
- myconf="$myconf --with-perl"
- else
- myconf="$myconf --without-perl"
- fi
- if [ "`use python`" ]; then
- myconf="$myconf --with-python"
- else
- myconf="$myconf --without-python"
- fi
- if [ "`use libgda`" ]; then
- myconf="$myconf --with-gda"
- else
- myconf="$myconf --without-gda"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
- cd ${S}
- try pmake
-}
-
-src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/app-office/gnumeric/gnumeric-0.67.ebuild b/app-office/gnumeric/gnumeric-0.67.ebuild
deleted file mode 100644
index 01684a2d9e42..000000000000
--- a/app-office/gnumeric/gnumeric-0.67.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.66.ebuild,v 1.1 2001/06/28 09:47:57 hallski Exp
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- >=gnome-base/libxml-1.8.14
- >=gnome-libs/libole2-0.2.3
- >=dev-util/xml-i18n-tools-0.8.4
- perl? ( >=sys-devel/perl-5 )
- python? ( >=dev-lang/python-2.0 )
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- nls? ( sys-devel/gettext )
- bonobo? ( >=gnome-base/bonobo-1.0 )"
-
-RDEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- bonobo? ( >=gnome-base/bonobo-1.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ -z "`use bonobo`" ] ; then
- myconf="$myconf --without-bonobo"
- fi
- if [ "`use gb`" ]; then
- #does not work atm
- myconf="$myconf --without-gb"
- else
- myconf="$myconf --without-gb"
- fi
- if [ "`use perl`" ]; then
- myconf="$myconf --with-perl"
- else
- myconf="$myconf --without-perl"
- fi
- if [ "`use python`" ]; then
- myconf="$myconf --with-python"
- else
- myconf="$myconf --without-python"
- fi
- if [ "`use libgda`" ]; then
- myconf="$myconf --with-gda"
- else
- myconf="$myconf --without-gda"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
- cd ${S}
- try pmake
-}
-
-src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/app-office/gnumeric/gnumeric-0.68.ebuild b/app-office/gnumeric/gnumeric-0.68.ebuild
deleted file mode 100644
index 10f807623f1c..000000000000
--- a/app-office/gnumeric/gnumeric-0.68.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.66.ebuild,v 1.1 2001/06/28 09:47:57 hallski Exp
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="gnumeric"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
-HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
-
-DEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- >=gnome-base/libxml-1.8.14
- >=gnome-libs/libole2-0.2.3
- >=dev-util/xml-i18n-tools-0.8.4
- perl? ( >=sys-devel/perl-5 )
- python? ( >=dev-lang/python-2.0 )
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- nls? ( sys-devel/gettext )
- bonobo? ( >=gnome-base/bonobo-1.0 )"
-
-RDEPEND=">=gnome-base/gnome-print-0.29
- >=gnome-base/gal-0.8.0
- gb? ( >=gnome-libs/gb-0.0.19 )
- libgda? ( >=gnome-libs/libgda-0.2.9 )
- bonobo? ( >=gnome-base/bonobo-1.0 ) "
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ -z "`use bonobo`" ] ; then
- myconf="$myconf --without-bonobo"
- fi
- if [ "`use gb`" ]; then
- #does not work atm
- myconf="$myconf --without-gb"
- else
- myconf="$myconf --without-gb"
- fi
- if [ "`use perl`" ]; then
- myconf="$myconf --with-perl"
- else
- myconf="$myconf --without-perl"
- fi
- if [ "`use python`" ]; then
- myconf="$myconf --with-python"
- else
- myconf="$myconf --without-python"
- fi
- if [ "`use libgda`" ]; then
- myconf="$myconf --with-gda"
- else
- myconf="$myconf --without-gda"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --without-evolution ${myconf}
- cd ${S}
- try pmake
-}
-
-src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
-
-}
-
-
-
-
-
-
diff --git a/app-office/gnumeric/gnumeric-0.70.ebuild b/app-office/gnumeric/gnumeric-0.70-r1.ebuild
index 10f807623f1c..e5c58521d670 100644
--- a/app-office/gnumeric/gnumeric-0.70.ebuild
+++ b/app-office/gnumeric/gnumeric-0.70-r1.ebuild
@@ -28,49 +28,52 @@ RDEPEND=">=gnome-base/gnome-print-0.29
bonobo? ( >=gnome-base/bonobo-1.0 ) "
src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e 's:"%d,:"%d",:' configure.orig > configure
+ unpack ${A}
+ cd ${S}
+
+ patch -p0 < ${FILESDIR}/${P}-gdk-gc-ref.patch
+# cp configure configure.orig
+# sed -e 's:"%d,:"%d",:' configure.orig > configure
}
src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ -z "`use bonobo`" ] ; then
- myconf="$myconf --without-bonobo"
- fi
- if [ "`use gb`" ]; then
- #does not work atm
- myconf="$myconf --without-gb"
- else
- myconf="$myconf --without-gb"
- fi
- if [ "`use perl`" ]; then
- myconf="$myconf --with-perl"
- else
- myconf="$myconf --without-perl"
- fi
- if [ "`use python`" ]; then
- myconf="$myconf --with-python"
- else
- myconf="$myconf --without-python"
- fi
- if [ "`use libgda`" ]; then
- myconf="$myconf --with-gda"
- else
- myconf="$myconf --without-gda"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --without-evolution ${myconf}
- cd ${S}
- try pmake
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "`use bonobo`" ] ; then
+ myconf="$myconf --without-bonobo"
+ fi
+ if [ "`use gb`" ]; then
+ #does not work atm
+ myconf="$myconf --without-gb"
+ else
+ myconf="$myconf --without-gb"
+ fi
+ if [ "`use perl`" ]; then
+ myconf="$myconf --with-perl"
+ else
+ myconf="$myconf --without-perl"
+ fi
+ if [ "`use python`" ]; then
+ myconf="$myconf --with-python"
+ else
+ myconf="$myconf --without-python"
+ fi
+ if [ "`use libgda`" ]; then
+ myconf="$myconf --with-gda"
+ else
+ myconf="$myconf --without-gda"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --without-evolution ${myconf}
+
+ emake || die "Building of package failed."
}
src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
- dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+ make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install || die
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
}