summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-07 12:27:57 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-07 12:27:57 +0000
commit9acd848fd8937e488e5375782367370694ab4b51 (patch)
treecd1b87c11b4524bfba0bb3edb6c7b9440aaaf325 /app-office
parentVersion bump. (diff)
downloadgentoo-2-9acd848fd8937e488e5375782367370694ab4b51.tar.gz
gentoo-2-9acd848fd8937e488e5375782367370694ab4b51.tar.bz2
gentoo-2-9acd848fd8937e488e5375782367370694ab4b51.zip
Revision bump adds upstream parallel build fix wrt bug #407611.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kmymoney/ChangeLog8
-rw-r--r--app-office/kmymoney/files/kmymoney-4.6.2-fix-parallel-build.patch21
-rw-r--r--app-office/kmymoney/kmymoney-4.6.2-r1.ebuild85
3 files changed, 113 insertions, 1 deletions
diff --git a/app-office/kmymoney/ChangeLog b/app-office/kmymoney/ChangeLog
index 47e876060fbc..665f8f1d7c6c 100644
--- a/app-office/kmymoney/ChangeLog
+++ b/app-office/kmymoney/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kmymoney
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.31 2012/05/03 20:00:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/ChangeLog,v 1.32 2012/05/07 12:27:57 johu Exp $
+
+*kmymoney-4.6.2-r1 (07 May 2012)
+
+ 07 May 2012; Johannes Huber <johu@gentoo.org>
+ +files/kmymoney-4.6.2-fix-parallel-build.patch, +kmymoney-4.6.2-r1.ebuild:
+ Revision bump adds upstream parallel build fix wrt bug #407611.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> kmymoney-4.6.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/app-office/kmymoney/files/kmymoney-4.6.2-fix-parallel-build.patch b/app-office/kmymoney/files/kmymoney-4.6.2-fix-parallel-build.patch
new file mode 100644
index 000000000000..15ea2e4d9a4c
--- /dev/null
+++ b/app-office/kmymoney/files/kmymoney-4.6.2-fix-parallel-build.patch
@@ -0,0 +1,21 @@
+commit 25ee292b205e6085ba624b8ac8a45fe11a99e5cc
+Author: Cristian Oneț <onet.cristian@gmail.com>
+Date: Tue Apr 10 20:25:26 2012 +0300
+
+ The kmymoney_base target must depend on the kmm_config config target to avoid build failures when aggresive parallel make is used.
+
+ BUG: 297008
+
+diff --git a/kmymoney/widgets/CMakeLists.txt b/kmymoney/widgets/CMakeLists.txt
+index 20d910d..5c6d28d 100644
+--- a/kmymoney/widgets/CMakeLists.txt
++++ b/kmymoney/widgets/CMakeLists.txt
+@@ -89,6 +89,8 @@ ADD_CUSTOM_TARGET(generate_base_ui_srcs DEPENDS
+ # We can compile the uncritical sources without KMM_DESIGNER flags
+ KDE4_ADD_LIBRARY(kmymoney_base STATIC ${_uncritial_common_sources})
+
++ADD_DEPENDENCIES(kmymoney_base kmm_config)
++
+ ########### QtDesigner Widget Library (kmymoneywidgets) #################
+ # we never link against this library,
+ # but it is needed for uic and QtDesigner
diff --git a/app-office/kmymoney/kmymoney-4.6.2-r1.ebuild b/app-office/kmymoney/kmymoney-4.6.2-r1.ebuild
new file mode 100644
index 000000000000..7c3740815dc0
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.6.2-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney/kmymoney-4.6.2-r1.ebuild,v 1.1 2012/05/07 12:27:57 johu Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et
+ eu fi fr ga gl hu it ja lt ms nds nl pl pt
+ pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
+ KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+ KDE_HANDBOOK="optional"
+ SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2"
+fi
+
+VIRTUALX_REQUIRED=test
+
+inherit kde4-base
+
+DESCRIPTION="Personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug calendar doc hbci ofx quotes test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=app-office/libalkimia-4.3.2
+ dev-cpp/glibmm:2
+ dev-cpp/libxmlpp:2.6
+ dev-libs/boost
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/libgpg-error
+ dev-libs/libxml2
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ calendar? ( dev-libs/libical )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( dev-perl/Finance-Quote )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.6.1-qt48.patch"
+ "${FILESDIR}/${P}-fix-parallel-build.patch"
+)
+
+RESTRICT=test
+# bug 399467
+
+src_configure() {
+ mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ $(cmake-utils_use test KDE4_BUILD_TESTS)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}