summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-05-19 11:26:37 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-05-19 11:26:37 +0000
commit99d5fcace56eb6d56f714cb7ffdae0951fae6ef5 (patch)
treedd84d65569c5010c0f3e8c35a339b1bee6c76e1b /app-office
parentMask eselect-1.1_rc1. (diff)
downloadgentoo-2-99d5fcace56eb6d56f714cb7ffdae0951fae6ef5.tar.gz
gentoo-2-99d5fcace56eb6d56f714cb7ffdae0951fae6ef5.tar.bz2
gentoo-2-99d5fcace56eb6d56f714cb7ffdae0951fae6ef5.zip
Fix build problems with gcc-4.4 (bug #269452) and glibc-2.10.1 (bug #270263) and correct post-install message for bash completion (bug #270185)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog9
-rw-r--r--app-office/openoffice/files/buildfix-gcc44.diff20
-rw-r--r--app-office/openoffice/files/ooo_getline.diff42
-rw-r--r--app-office/openoffice/openoffice-3.1.0.ebuild6
4 files changed, 74 insertions, 3 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 96de98eae556..53ed5b0be5aa 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/openoffice
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.462 2009/05/17 07:53:04 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.463 2009/05/19 11:26:36 suka Exp $
+
+ 19 May 2009; Andreas Proschofsky <suka@gentoo.org>
+ +files/buildfix-gcc44.diff, openoffice-3.1.0.ebuild,
+ +files/ooo_getline.diff:
+ Fix build problems with gcc-4.4 (bug #269452) and glibc-2.10.1 (bug
+ #270263) and correct post-install message for bash completion (bug
+ #270185)
*openoffice-3.1.0 (17 May 2009)
diff --git a/app-office/openoffice/files/buildfix-gcc44.diff b/app-office/openoffice/files/buildfix-gcc44.diff
new file mode 100644
index 000000000000..5da661e1f2d4
--- /dev/null
+++ b/app-office/openoffice/files/buildfix-gcc44.diff
@@ -0,0 +1,20 @@
+--- sw/source/core/doc/docbm.cxx 2009-05-17 16:41:34.765483089 -0500
++++ sw/source/core/doc/docbm.cxx 2009-05-17 16:41:39.141355157 -0500
+@@ -33,6 +33,7 @@
+ #include "precompiled_sw.hxx"
+
+
++#include <cstdio>
+ #include <tools/pstm.hxx>
+ #include <svx/linkmgr.hxx>
+ #include <fmtanchr.hxx>
+--- sw/source/filter/ww8/WW8TableInfo.cxx 2009-05-17 17:06:33.556313757 -0500
++++ sw/source/filter/ww8/WW8TableInfo.cxx 2009-05-17 17:06:46.964547351 -0500
+@@ -32,6 +32,7 @@
+ #include "precompiled_sw.hxx"
+
+ #include <iostream>
++#include <cstdio>
+ #include "WW8TableInfo.hxx"
+ #include "swtable.hxx"
+ #include "pam.hxx"
diff --git a/app-office/openoffice/files/ooo_getline.diff b/app-office/openoffice/files/ooo_getline.diff
new file mode 100644
index 000000000000..9fed114c3979
--- /dev/null
+++ b/app-office/openoffice/files/ooo_getline.diff
@@ -0,0 +1,42 @@
+--- soltools/mkdepend/def.h.orig 2009-05-18 15:28:59.000000000 +0200
++++ soltools/mkdepend/def.h 2009-05-18 15:29:36.000000000 +0200
+@@ -154,7 +154,7 @@
+
+ char *copy();
+ char *base_name();
+-char *getline();
++char *ooo_getline();
+ char *isdefined();
+ struct filepointer *getfile();
+ struct inclist *newinclude();
+--- soltools/mkdepend/main.c.orig 2009-05-18 15:29:08.000000000 +0200
++++ soltools/mkdepend/main.c 2009-05-18 15:30:23.000000000 +0200
+@@ -548,7 +548,7 @@
+ * Get the next line. We only return lines beginning with '#' since that
+ * is all this program is ever interested in.
+ */
+-char *getline(filep)
++char *ooo_getline(filep)
+ register struct filepointer *filep;
+ {
+ register char *p, /* walking pointer */
+--- soltools/mkdepend/parse.c.orig 2009-05-18 15:29:17.000000000 +0200
++++ soltools/mkdepend/parse.c 2009-05-18 15:30:43.000000000 +0200
+@@ -45,7 +45,7 @@
+ register int type;
+ boolean recfailOK;
+
+- while ((line = getline(filep))) {
++ while ((line = ooo_getline(filep))) {
+ switch(type = deftype(line, filep, file_red, file, TRUE, symbols)) {
+ case IF:
+ doif:
+@@ -168,7 +168,7 @@
+ register char *line;
+ register int type;
+
+- while ((line = getline(filep))) {
++ while ((line = ooo_getline(filep))) {
+ switch(type = deftype(line, filep, file_red, file, FALSE, symbols)) {
+ case IF:
+ case IFFALSE:
diff --git a/app-office/openoffice/openoffice-3.1.0.ebuild b/app-office/openoffice/openoffice-3.1.0.ebuild
index 37ed40a86d23..1fb874b72003 100644
--- a/app-office/openoffice/openoffice-3.1.0.ebuild
+++ b/app-office/openoffice/openoffice-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.1.0.ebuild,v 1.1 2009/05/17 07:53:04 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.1.0.ebuild,v 1.2 2009/05/19 11:26:36 suka Exp $
WANT_AUTOMAKE="1.9"
EAPI="2"
@@ -228,6 +228,8 @@ src_unpack() {
epatch "${FILESDIR}/gentoo-${PV}.diff"
epatch "${FILESDIR}/ooo-env_log.diff"
cp -f "${FILESDIR}/base64.diff" "${S}/patches/hotfixes" || die
+ cp -f "${FILESDIR}/buildfix-gcc44.diff" "${S}/patches/hotfixes" || die
+ cp -f "${FILESDIR}/ooo_getline.diff" "${S}/patches/hotfixes" || die
#Use flag checks
if use java ; then
@@ -369,7 +371,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
- bash-completion_pkg_postinst
+ BASH_COMPLETION_NAME=ooffice && bash-completion_pkg_postinst
[[ -x /sbin/chpax ]] && [[ -e /usr/$(get_libdir)/openoffice/program/soffice.bin ]] && chpax -zm /usr/$(get_libdir)/openoffice/program/soffice.bin