summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-10-10 22:17:32 +0000
committerVlastimil Babka <caster@gentoo.org>2010-10-10 22:17:32 +0000
commit93efc8a7e27b46f004b2bd06b846b79aa091fb64 (patch)
treea793a00c9eefa546fed94814f1bec9b7a1df8d65 /app-office
parentFix openmotif dependency. (diff)
downloadgentoo-2-93efc8a7e27b46f004b2bd06b846b79aa091fb64.tar.gz
gentoo-2-93efc8a7e27b46f004b2bd06b846b79aa091fb64.tar.bz2
gentoo-2-93efc8a7e27b46f004b2bd06b846b79aa091fb64.zip
Backport fix for upstream bug 3081666 from upstream svn.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taskcoach/ChangeLog8
-rw-r--r--app-office/taskcoach/files/3081666.patch18
-rw-r--r--app-office/taskcoach/taskcoach-1.1.4-r1.ebuild59
3 files changed, 84 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 1a13c21bbd6a..88b51dafb87a 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.59 2010/10/01 07:09:06 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.60 2010/10/10 22:17:32 caster Exp $
+
+*taskcoach-1.1.4-r1 (10 Oct 2010)
+
+ 10 Oct 2010; Vlastimil Babka <caster@gentoo.org> +files/3081666.patch,
+ +taskcoach-1.1.4-r1.ebuild:
+ Backport fix for upstream bug 3081666 from upstream svn.
*taskcoach-1.1.4 (01 Oct 2010)
diff --git a/app-office/taskcoach/files/3081666.patch b/app-office/taskcoach/files/3081666.patch
new file mode 100644
index 000000000000..a425f5b340de
--- /dev/null
+++ b/app-office/taskcoach/files/3081666.patch
@@ -0,0 +1,18 @@
+--- branches/Release1_1_Branch/taskcoach/taskcoachlib/gui/dialog/editor.py 2010/09/04 19:10:18 3595
++++ branches/Release1_1_Branch/taskcoach/taskcoachlib/gui/dialog/editor.py 2010/10/05 20:49:36 3657
+@@ -687,9 +687,12 @@
+ @patterns.eventSource
+ def ok(self, event=None): # pylint: disable-msg=W0221
+ for item in self.items:
+- item.setBudget(self._budgetEntry.get(), event=event)
+- item.setHourlyFee(self._hourlyFeeEntry.get(), event=event)
+- item.setFixedFee(self._fixedFeeEntry.get(), event=event)
++ if len(self.items) == 1 or self._budgetLabel.IsChecked():
++ item.setBudget(self._budgetEntry.get(), event=event)
++ if len(self.items) == 1 or self._hourlyFeeLabel.IsChecked():
++ item.setHourlyFee(self._hourlyFeeEntry.get(), event=event)
++ if len(self.items) == 1 or self._fixedFeeLabel.IsChecked():
++ item.setFixedFee(self._fixedFeeEntry.get(), event=event)
+
+
+ class PageWithViewer(Page):
diff --git a/app-office/taskcoach/taskcoach-1.1.4-r1.ebuild b/app-office/taskcoach/taskcoach-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..09a4122bcf8c
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.1.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.1.4-r1.ebuild,v 1.1 2010/10/10 22:17:32 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/3081666.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}