summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:05:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:05:54 +0000
commit8b3347302a9ab689d2b9762c71a974153fe6ea95 (patch)
tree9e0f57af84854c450d2ed2e583726c425bb368f5 /app-office
parentVersion bump (diff)
downloadgentoo-2-8b3347302a9ab689d2b9762c71a974153fe6ea95.tar.gz
gentoo-2-8b3347302a9ab689d2b9762c71a974153fe6ea95.tar.bz2
gentoo-2-8b3347302a9ab689d2b9762c71a974153fe6ea95.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/pybliographer/ChangeLog8
-rw-r--r--app-office/pybliographer/metadata.xml9
-rw-r--r--app-office/pybliographer/pybliographer-1.2.14.ebuild74
3 files changed, 90 insertions, 1 deletions
diff --git a/app-office/pybliographer/ChangeLog b/app-office/pybliographer/ChangeLog
index 8319af47c754..bf72d860eaaf 100644
--- a/app-office/pybliographer/ChangeLog
+++ b/app-office/pybliographer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/pybliographer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/ChangeLog,v 1.23 2011/01/27 15:11:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/ChangeLog,v 1.24 2011/07/29 22:05:54 bicatali Exp $
+
+*pybliographer-1.2.14 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +pybliographer-1.2.14.ebuild, metadata.xml:
+ Version bump
27 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pybliographer-1.2.12-r1.ebuild:
diff --git a/app-office/pybliographer/metadata.xml b/app-office/pybliographer/metadata.xml
index 9fb3e2e0729e..18e73de69700 100644
--- a/app-office/pybliographer/metadata.xml
+++ b/app-office/pybliographer/metadata.xml
@@ -3,4 +3,13 @@
<pkgmetadata>
<herd>tex</herd>
<herd>python</herd>
+<longdescription lang='en'>
+ Pybliographer is a tool for managing bibliographic databases, with
+ the following features:
+ * a user-friendly Gnome interface for editing, searching, inserting
+ your citations in LyX, Kile and OpenOffice.org, searching external
+ databases like PubMed, Web of Science, Citeseer, and more.
+ * powerful APIs to integrate these features into your own custom
+ application, with your own specific database schema.
+</longdescription>
</pkgmetadata>
diff --git a/app-office/pybliographer/pybliographer-1.2.14.ebuild b/app-office/pybliographer/pybliographer-1.2.14.ebuild
new file mode 100644
index 000000000000..e89dd0ad376a
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.14.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/pybliographer-1.2.14.ebuild,v 1.1 2011/07/29 22:05:54 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+
+inherit autotools gnome2 python
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DOCS="AUTHORS ChangeLog* NEWS TODO README"
+
+DEPEND=">=app-text/recode-3.6-r1
+ app-text/scrollkeeper
+ dev-libs/glib:2
+ dev-python/gconf-python:2
+ dev-python/gnome-vfs-python:2
+ dev-python/libgnome-python:2
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ >=dev-python/python-bibtex-1.2.5"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Disable byte-compilation of Python modules.
+ sed -i \
+ -e "/import compileall/d" \
+ Makefile.am || die "sed failed"
+
+ # Install Python modules into site-packages directories.
+ find -name Makefile.am | xargs sed -i \
+ -e "/^pybdir[[:space:]]*=[[:space:]]*/s:\$(datadir):$(python_get_sitedir):" || die "sed failed"
+ sed -i \
+ -e "s:\${datadir}/@PACKAGE@:$(python_get_sitedir)/@PACKAGE@:" \
+ etc/installer.in || die "sed failed"
+ sed -i \
+ -e "s:gladedir = \$(datadir):gladedir = $(python_get_sitedir):" \
+ Pyblio/GnomeUI/glade/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure --disable-depchecks
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs -r 2 "${ED}usr/bin"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize pybliographer
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pybliographer
+}