summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-03-23 23:50:49 +0000
committerDan Armak <danarmak@gentoo.org>2002-03-23 23:50:49 +0000
commit892844d879f489290dc1b7c72f3bd93891fd4fa7 (patch)
treea002cf602a461f659c008a524425860edda6e897 /app-office
parentnew revision with some pkg_postinst() fixes (several illegal things have (diff)
downloadgentoo-2-892844d879f489290dc1b7c72f3bd93891fd4fa7.tar.gz
gentoo-2-892844d879f489290dc1b7c72f3bd93891fd4fa7.tar.bz2
gentoo-2-892844d879f489290dc1b7c72f3bd93891fd4fa7.zip
close bug #1215, see changelog
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx-base/ChangeLog7
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r31
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.4-r3.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/app-office/lyx-base/ChangeLog b/app-office/lyx-base/ChangeLog
index 23505c0255e2..f33024680596 100644
--- a/app-office/lyx-base/ChangeLog
+++ b/app-office/lyx-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx-base
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/ChangeLog,v 1.3 2002/03/18 14:45:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/ChangeLog,v 1.4 2002/03/23 23:50:49 danarmak Exp $
+
+*lyx-base-1.1.6.4-r2 (18 Mar 2002)
+
+ 24 Mar 2002; Dan Armak <danarmak@gentoo.org> New revsion: close bug #1215.
+ Added configure parameter --with-extra-inc=/usr/X11R6/include.
*lyx-base-1.1.6.4-r2 (18 Mar 2002)
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r3 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r3
new file mode 100644
index 000000000000..8c46a40b69b1
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.4-r3
@@ -0,0 +1 @@
+MD5 de8fc7e0f390f12db4093098f8fee9d6 lyx-1.1.6fix4.tar.gz 5564584
diff --git a/app-office/lyx-base/lyx-base-1.1.6.4-r3.ebuild b/app-office/lyx-base/lyx-base-1.1.6.4-r3.ebuild
new file mode 100644
index 000000000000..09159521af74
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx-base/lyx-base-1.1.6.4-r3.ebuild,v 1.1 2002/03/23 23:50:49 danarmak Exp $
+
+# The real version of LyX is 1.1.6fix4. As Portage has no support for
+# arbitrary suffixes like 'fix', this is translated into 1.1.6.4.
+MY_P=lyx-1.1.6fix4
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${MY_P}.tar.gz"
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir='$(prefix)/share/info' \
+ --with-extra-inc=/usr/X11R6/include \
+ --mandir='$(prefix)/share/man' \
+ ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install-strip
+}