summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-08 18:13:41 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-08 18:13:41 +0000
commit86d6d7b1762afe85a23af8e72f47e0b3fdf85943 (patch)
treee272d4140885b077f24f2b3243c167975500096a /app-office
parentMatch require path to where the shared object actually is, fixes bug 316523. (diff)
downloadgentoo-2-86d6d7b1762afe85a23af8e72f47e0b3fdf85943.tar.gz
gentoo-2-86d6d7b1762afe85a23af8e72f47e0b3fdf85943.tar.bz2
gentoo-2-86d6d7b1762afe85a23af8e72f47e0b3fdf85943.zip
Do not byte-compile scripts, 247683, Fix code for PYTHON ABI, 311677
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog8
-rw-r--r--app-office/lyx/files/1.6.7-python.patch26
-rw-r--r--app-office/lyx/lyx-1.6.7-r1.ebuild167
3 files changed, 200 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index f99340f06041..75d1025edab1 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/lyx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.206 2010/07/24 15:55:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.207 2010/08/08 18:13:41 jlec Exp $
+
+*lyx-1.6.7-r1 (08 Aug 2010)
+
+ 08 Aug 2010; Justin Lecher <jlec@gentoo.org> lyx-1.6.7.ebuild,
+ +lyx-1.6.7-r1.ebuild:
+ Do not byte-compile scripts, 247683, Fix code for PYTHON ABI, 311677
24 Jul 2010; Raúl Porcel <armin76@gentoo.org> lyx-1.6.6.1.ebuild:
ia64/sparc stable wrt #321447
diff --git a/app-office/lyx/files/1.6.7-python.patch b/app-office/lyx/files/1.6.7-python.patch
new file mode 100644
index 000000000000..3717cc80185e
--- /dev/null
+++ b/app-office/lyx/files/1.6.7-python.patch
@@ -0,0 +1,26 @@
+diff --git a/src/graphics/GraphicsConverter.cpp b/src/graphics/GraphicsConverter.cpp
+index 97c4f68..8f05e62 100644
+--- a/src/graphics/GraphicsConverter.cpp
++++ b/src/graphics/GraphicsConverter.cpp
+@@ -262,7 +262,7 @@ static void build_script(FileName const & from_file,
+ LYXERR(Debug::GRAPHICS, "build_script ... ");
+ typedef Graph::EdgePath EdgePath;
+
+- script << "#!/usr/bin/env python\n"
++ script << "#!/usr/bin/env python2\n"
+ "# -*- coding: utf-8 -*-\n"
+ "import os, shutil, sys\n\n"
+ "def unlinkNoThrow(file):\n"
+diff --git a/src/support/os.cpp b/src/support/os.cpp
+index 6984d2c..e6f17ff 100644
+--- a/src/support/os.cpp
++++ b/src/support/os.cpp
+@@ -26,7 +26,7 @@ string const python()
+ {
+ // Use the -tt switch so that mixed tab/whitespace indentation is
+ // an error
+- static string const command("python -tt");
++ static string const command("python2 -tt");
+ return command;
+ }
+
diff --git a/app-office/lyx/lyx-1.6.7-r1.ebuild b/app-office/lyx/lyx-1.6.7-r1.ebuild
new file mode 100644
index 000000000000..cd6a817d0f2e
--- /dev/null
+++ b/app-office/lyx/lyx-1.6.7-r1.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.6.7-r1.ebuild,v 1.1 2010/08/08 18:13:41 jlec Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+
+inherit qt4 eutils flag-o-matic font python toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+#SRC_URI="http://www.lyx.org/~jamatos/lyx-1.6/${MY_P}.tar.bz2 #for betas
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/pre/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls latex monolithic-build html rtf dot docbook dia subversion rcs svg"
+
+LANGS="ar ca cs de el en es eu fi fr gl he hu id it ja nb nn pl pt ro ru sk tr uk zh_CN zh_TW"
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ app-text/aiksaurus
+ virtual/aspell-dict
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34"
+
+RDEPEND="${COMMONDEPEND}
+ || ( dev-texlive/texlive-fontsextra app-text/ptex )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick )
+ cups? ( virtual/lpr )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/noweb
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )"
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+
+pkg_setup() {
+ python_set_active_version 2
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-python.patch
+ echo "#!/bin/sh" > config/py-compile
+ sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ --with-aspell --without-included-boost --disable-stdlib-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}