summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-02 12:22:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-02 12:22:25 +0000
commit83c2cdaf0677f9feb4d1e2d64989b9e2937598e4 (patch)
treedf39707dda93ee05deb815a3854441315554f0d4 /app-office
parentRevision bump: EAPI 4, add ~amd64 and ~amd64-linux keywords wrt bug #440678 (diff)
downloadgentoo-2-83c2cdaf0677f9feb4d1e2d64989b9e2937598e4.tar.gz
gentoo-2-83c2cdaf0677f9feb4d1e2d64989b9e2937598e4.tar.bz2
gentoo-2-83c2cdaf0677f9feb4d1e2d64989b9e2937598e4.zip
Bump to latest to fix sec issue #440922, 3.5 straing to stable, not much stuff else to break shit up. Also fix the poppler crash with pdf import filter #430670.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog13
-rw-r--r--app-office/libreoffice/files/libreoffice-3.6.3.2-fix-poppler.patch49
-rw-r--r--app-office/libreoffice/libreoffice-3.5.7.2.ebuild (renamed from app-office/libreoffice/libreoffice-3.5.6.2.ebuild)4
-rw-r--r--app-office/libreoffice/libreoffice-3.6.3.2.ebuild (renamed from app-office/libreoffice/libreoffice-3.6.2.2.ebuild)3
4 files changed, 65 insertions, 4 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 3a105e8f80f4..c21ef2fd002d 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.383 2012/10/30 21:00:29 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.384 2012/11/02 12:22:25 scarabeus Exp $
+
+*libreoffice-3.6.3.2 (02 Nov 2012)
+*libreoffice-3.5.7.2 (02 Nov 2012)
+
+ 02 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libreoffice-3.6.3.2-fix-poppler.patch, +libreoffice-3.5.7.2.ebuild,
+ +libreoffice-3.6.3.2.ebuild, -libreoffice-3.5.6.2.ebuild,
+ -libreoffice-3.6.2.2.ebuild:
+ Bump to latest to fix sec issue #440922, 3.5 straing to stable, not much stuff
+ else to break shit up. Also fix the poppler crash with pdf import filter
+ #430670.
30 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Use new switch for paralel jobs count. Solves quite few bugs we had on gentoo
diff --git a/app-office/libreoffice/files/libreoffice-3.6.3.2-fix-poppler.patch b/app-office/libreoffice/files/libreoffice-3.6.3.2-fix-poppler.patch
new file mode 100644
index 000000000000..6ae1dd175485
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-3.6.3.2-fix-poppler.patch
@@ -0,0 +1,49 @@
+From 1296db324d5962ff904c0ed488a62132dd36a66f Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Wed, 31 Oct 2012 17:00:18 +0000
+Subject: fix sdext build with poppler >= 0.19.x
+
+Conflicts:
+
+ configure.ac
+
+Change-Id: I655e8e15c7f7a8c292b3a1820ee48c29e847d05a
+Signed-off-by: Tomas Chvatal <tchvatal@suse.cz>
+---
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 87c0ab2..9d38e9b 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -497,7 +497,9 @@ void PDFOutDev::endPage()
+ printf("endPage\n");
+ }
+
+-#if POPPLER_CHECK_VERSION(0, 17, 0)
++#if POPPLER_CHECK_VERSION(0, 19, 0)
++void PDFOutDev::processLink(AnnotLink *link)
++#elif POPPLER_CHECK_VERSION(0, 17, 0)
+ void PDFOutDev::processLink(AnnotLink *link, Catalog *)
+ #else
+ void PDFOutDev::processLink(Link* link, Catalog*)
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index bba8f58..1911d57 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -201,10 +201,12 @@ namespace pdfi
+ // virtual void cvtDevToUser(double dx, double dy, double *ux, double *uy);
+ // virtual void cvtUserToDev(double ux, double uy, int *dx, int *dy);
+
+- #if POPPLER_CHECK_VERSION(0, 17, 0)
+- virtual void processLink(AnnotLink *link, Catalog *catalog);
+- #else
+ //----- link borders
++ #if POPPLER_CHECK_VERSION(0, 19, 0)
++ virtual void processLink(AnnotLink *link);
++ #elif POPPLER_CHECK_VERSION(0, 17, 0)
++ virtual void processLink(AnnotLink *link, Catalog *catalog);
++ #else
+ virtual void processLink(Link *link, Catalog *catalog);
+ #endif
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-office/libreoffice/libreoffice-3.5.6.2.ebuild b/app-office/libreoffice/libreoffice-3.5.7.2.ebuild
index 148fc7473e8a..183d0dd1f88e 100644
--- a/app-office/libreoffice/libreoffice-3.5.6.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.5.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.6.2.ebuild,v 1.3 2012/08/31 14:08:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.7.2.ebuild,v 1.1 2012/11/02 12:22:25 scarabeus Exp $
EAPI=4
@@ -17,7 +17,7 @@ PYTHON_USE_WITH="threads,xml"
# everyone happy.
DEV_URI="
http://dev-builds.libreoffice.org/pre-releases/src
- http://download.documentfoundation.org/libreoffice/src/3.5.6/
+ http://download.documentfoundation.org/libreoffice/src/3.5.7/
http://download.documentfoundation.org/libreoffice/old/src
"
EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
diff --git a/app-office/libreoffice/libreoffice-3.6.2.2.ebuild b/app-office/libreoffice/libreoffice-3.6.3.2.ebuild
index 133240050e9c..a2243f7e1e48 100644
--- a/app-office/libreoffice/libreoffice-3.6.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.6.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.2.2.ebuild,v 1.1 2012/09/25 14:03:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.3.2.ebuild,v 1.1 2012/11/02 12:22:25 scarabeus Exp $
EAPI=4
@@ -216,6 +216,7 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-3.6-system-pyuno.patch"
"${FILESDIR}/${PN}-3.6-separate-checks.patch"
+ "${FILESDIR}/${P}-fix-poppler.patch"
)
REQUIRED_USE="