summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-04-11 21:00:39 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-04-11 21:00:39 +0000
commit75304b5a0bef0ec8846bf2eaa5f9b9c62a507900 (patch)
tree4256066721b1715aab4fa657d9f94d29fed0d3a1 /app-office
parentBump to stable (Manifest recommit) (diff)
downloadgentoo-2-75304b5a0bef0ec8846bf2eaa5f9b9c62a507900.tar.gz
gentoo-2-75304b5a0bef0ec8846bf2eaa5f9b9c62a507900.tar.bz2
gentoo-2-75304b5a0bef0ec8846bf2eaa5f9b9c62a507900.zip
Removing ancient version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.1202
-rw-r--r--app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.2238
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.0.22
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild217
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild4
5 files changed, 2 insertions, 661 deletions
diff --git a/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.1 b/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.1
deleted file mode 100644
index 0fb6909c8e6b..000000000000
--- a/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.1
+++ /dev/null
@@ -1,202 +0,0 @@
-#!/bin/sh
-#
-# Wrapper script for openoffice
-#
-# (C) Peter 'Nidd' Novodvorsky, 2001,2002
-# (C) Martin 'empty' Quinson, 2002.
-# Modifications by Chris Halls
-
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-# this string should be exactly as in ~/.sversionrc
-OOVERSION="OpenOffice.org <pv>"
-
-##
-## Source system configuration file
-##
-[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
-
-##
-## where does OO live for this user ?
-##
-OOHOME=""
-if [ -e ~/.sversionrc ] && grep -q "$OOVERSION" ~/.sversionrc ; then
- # already installed for this user (warning, .sversionrc is DOS encoded)
- OOHOME=`grep "^$OOVERSION=" ~/.sversionrc| \
- sed "s|^$OOVERSION=file://||" | \
- xargs echo`
- if [ ! -e $OOHOME ] ; then
- echo "I'm confused because I can't find OpenOffice's user files."
- echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
- echo "but they are not. Please fix the situation manually."
- echo "You may want to edit ~/.sversionrc to indicate where is OO"
- echo "installed, or remove it if you did remove your installation"
- echo "directory manually (you bad one)."
- exit 1
- fi
-fi
-
-##
-## Unset SESSION_MANAGER if gnome-session is the session manager
-## See http://www.openoffice.org/issues/show_bug.cgi?id=4494
-##
-SMPID=`echo $SESSION_MANAGER | sed --quiet "s,local.*/,,p"`
-if [ -n "$SMPID" ] && [ -L /proc/"$SMPID"/exe ]; then
- SESMGR="`readlink -f /proc/$SMPID/exe`"
- if [ "$SESMGR" = "/usr/bin/gnome-session" ]; then
- echo "Gnome session manager detected - session management disabled"
- unset SESSION_MANAGER
- fi
-fi
-
-##
-## install OO for this user if needed
-##
-if [ -z "$OOHOME" ] ; then
- if [ -e /etc/openoffice/autoresponse.conf ] && \
- grep -q DESTINATIONPATH /etc/openoffice/autoresponse.conf ; then
- # first install
- OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse.conf | \
- sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
-
- if [ -d "$OOHOME" ]; then
- echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
- echo "yet the directory $OOHOME exists."
- echo "Please remove $OOHOME and try again."
- exit 1
- fi
- echo "running openoffice.org setup..."
- if ! /opt/OpenOffice.org<pv>/program/setup -R:/etc/openoffice/autoresponse.conf >& /dev/null; then
- echo "setup failed.. abort"
- exit 1
- fi
- echo "Setup complete. Running openoffice.org..."
- else
- echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
- echo "the /etc/openoffice/autoresponse.conf file manually ?"
- echo "This file should contain DESTINATIONPATH"
- exit 1
- fi
-fi
-
-##
-## If no file is specified on the command line, which application to start?
-## The wrapper can be called from several links in /usr/bin
-##
-if [ $# = 0 ]; then
- case `basename $0` in
- oocalc) set -- private:factory/scalc;;
- oodraw) set -- private:factory/sdraw;;
- ooimpress) set -- private:factory/simpress;;
- oomath) set -- private:factory/smath;;
- oowriter) set -- private:factory/swriter;;
- esac
-fi
-
-##
-##
-## Change the config files to conform to current locale used
-##
-
-# Fix some variable to make the paths shorter in the rest
-LINGFILE="$OOHOME/user/config/registry/instance/org/openoffice/Office/Linguistic.xml"
-SETUPFILE="$OOHOME/user/config/registry/instance/org/openoffice/Setup.xml"
-
-
-# Search the right locale
-OLDLOCALE=""
-if [ -e $LINGFILE ] ; then
- OLDLOCALE=`grep 'DefaultLocale cfg' $LINGFILE|sed 's/<[^>]*>//g'|sed 's/[[:blank:]]//g'`
-fi
-if [ -z $OLDLOCALE ]; then OLDLOCALE="en-US"; fi
-if [ "x$OLDLOCALE" = "xC" ]; then OLDLOCALE="en-US"; fi
-
-LOCALE=$LC_ALL
-if [ -z $LOCALE ] ; then LOCALE="$LC_MESSAGES"; fi
-if [ -z $LOCALE ] ; then LOCALE="$LANG"; fi
-if [ -z $LOCALE ] ; then LOCALE="en-US"; fi
-if [ "x$LOCALE" = "xC" ] ; then LOCALE="en-US"; fi
-
-if [ $LOCALE != $OLDLOCALE ] ; then
-
- # Change instdb.ins
- cp $OOHOME/instdb.ins $OOHOME/instdb.ins.$OLDLOCALE
- sed "s/>$OLDLOCALE</>$LOCALE</" $OOHOME/instdb.ins.$OLDLOCALE > $OOHOME/instdb.ins
-
- # Create Linguistic.xml if don't exists
- if [ ! -e $LINGFILE.$OLDLOCALE ] ; then
- # get a default one, and change en-US to OLDLOCALE inside. I guess this is a noop, but I'm not sure
- sed "s/>en-US</>$OLDLOCALE</" \
- < /opt/OpenOffice.org<pv>/share/config/registry/instance/org/openoffice/Office/Linguistic.xml \
- > $LINGFILE.$OLDLOCALE
- fi
-
- # change Linguistic.xml
- sed "s/>$OLDLOCALE</>$LOCALE</" $LINGFILE.$OLDLOCALE > $LINGFILE
-
- # Change Setup.xml
- if grep -q '<ooLocale cfg:type' $SETUPFILE ; then
- cp $SETUPFILE $SETUPFILE.$OLDLOCALE
- sed "s/>$OLDLOCALE</>$LOCALE</" $SETUPFILE.$OLDLOCALE > $SETUPFILE
- else # ooLocale entry does not exists in Setup.xml
- cp $SETUPFILE $SETUPFILE.tmp
-
- cat $SETUPFILE.tmp | \
- perl -e "while (<>) { /<Office>/ && print \"<L10N>\n<ooLocale cfg:type=\\\"string\\\">$LOCALE</ooLocale>\n</L10N>\n\";print \$_;}" > \
- $SETUPFILE
- # this perl command is to add a <L10N> section if it does not exists.
- # On my machine, it produce the following patch:
-
- # <Setup state="modified" cfg:package="org.openoffice" xmlns="http://openoffice.org/2000/registry/components/Setup" xmlns:cfg="http://openoffice.org/2000/registry/instance" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance">
- #+ <L10N>
- #+ <ooLocale cfg:type="string">fr_FR@euro</ooLocale>
- #+ </L10N>
- # <Office>
-
- rm $SETUPFILE.tmp
- fi # change Setup.xml
-
-fi # LOCALE != OLDLOCALE
-
-## Previous dead installation?
-[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
-
-##
-## That's it. Launch the beast (with the given args)
-##
-export LD_PRELOAD=/usr/lib/libfreetype.so
-case `basename $0` in
- oosetup) exec "$OOHOME/setup" ;;
- oopadmin) exec "$OOHOME/spadmin" ;;
- *) exec "$OOHOME/soffice" "$@" ;;
-esac
-
-## Changelog
-# 07/10 challs
-# * use 1.0.1 directory and improve error checking
-# 07/02 challs
-# * use readlink in /proc/PID/exe to get
-# real session manager name
-# 06/12 challs
-# * merge into main package
-# * change $@ to "$@"
-# * source configuration file:
-# /etc/openoffice/openoffice.conf
-# 06/12 mquinson
-# * strace only when DEBUG is set to yes
-# * readd the $@ to pass the args to soffice
-# 06/06 mquinson
-# * Make sure the OLDLOCALE is never empty
-# * handle the case where the locale is C
diff --git a/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.2 b/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.2
deleted file mode 100644
index 5f92769b809c..000000000000
--- a/app-office/openoffice-bin/files/1.0.2/ooffice-wrapper-1.2
+++ /dev/null
@@ -1,238 +0,0 @@
-#!/bin/sh
-#
-# Wrapper script for openoffice
-#
-# (C) Peter 'Nidd' Novodvorsky, 2001,2002
-# (C) Martin 'empty' Quinson, 2002.
-# Modifications by Chris Halls
-# Modifications by Lucien Saviot
-
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-# this string should be exactly as in ~/.sversionrc
-OOVERSION="OpenOffice.org <pv>"
-
-##
-## Source system configuration file
-##
-[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
-
-###
-### Get user settings directory from ~/.sversionrc and echo directory name to stdout
-### get_settings_dir <Version>
-### return: 0 - directory found,
-### 1 - ~/.sversionrc non existent
-### 2 - entry exists in ~/.sversionrc but directory not found
-### 3 - ~/.sversionrc exists but no entry found
-get_settings_dir()
-{
- [ -r ~/.sversionrc ] || exit 1
- # warning, .sversionrc is DOS encoded so strip ^M
- settings_dir="`tr -d '\r' < ~/.sversionrc | sed -n "/^$1=/s%^$1=file://\(.*\)$%\1%p"`"
- echo "$settings_dir"
- [ -n "$settings_dir" ] || exit 3
- [ -d "$settings_dir" ] || exit 2
-}
-
-##
-## where does OO live for this user ?
-##
-OOHOME="`get_settings_dir "$OOVERSION"`"
-if [ $? -eq 2 ] ; then
- # .sversionrc contains a version yet the directory does not exist
- echo "I'm confused because I can't find OpenOffice's user files."
- echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
- echo "but they are not. Please fix the situation manually."
- echo "You may want to edit ~/.sversionrc to indicate where is OO"
- echo "installed, or remove it if you did remove your installation"
- echo "directory manually (you bad one)."
- exit 1
-fi
-
-##
-## Unset SESSION_MANAGER if gnome-session is the session manager
-## See http://www.openoffice.org/issues/show_bug.cgi?id=4494
-##
-SMPID=`echo $SESSION_MANAGER | sed --quiet "s,local.*/,,p"`
-if [ -n "$SMPID" ] && [ -L /proc/"$SMPID"/exe ]; then
-
- SESMGR="`readlink -f /proc/$SMPID/exe`"
- case "$SESMGR" in
- /usr/bin/gnome-session*)
- echo "Gnome session manager detected - session management disabled"
- unset SESSION_MANAGER
- ;;
- esac
-fi
-
-##
-## Add known Debian fonts locations to search path
-##
-## Please report if you have problems with fonts, or know of non-defoma integrated packages that place fonts in other
-## paths.
-##
-
-# Default font path. This is used if SAL_FONTPATH_USER is not defined.
-DEBOO_FONTPATH="/usr/lib/X11/fonts/misc/;/usr/lib/X11/fonts/cyrillic/;\
-/usr/lib/X11/fonts/100dpi/:unscaled;/usr/lib/X11/fonts/75dpi/:unscaled;\
-/usr/lib/X11/fonts/Type1/;/usr/lib/X11/fonts/CID;/usr/lib/X11/fonts/Speedo/;\
-/usr/lib/X11/fonts/100dpi/;/usr/lib/X11/fonts/75dpi/;\
-/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType;\
-/usr/lib/X11/fonts/TrueType;\
-/usr/share/fonts/truetype/kochi;\
-/usr/lib/X11/fonts/TrueType/larabie-straight;\
-/usr/lib/X11/fonts/TrueType/larabie-uncommon"
-
-SAL_FONTPATH_USER=${SAL_FONTPATH_USER:-"$DEBOO_FONTPATH"}
-export SAL_FONTPATH_USER
-
-## search LOCALE
-if [ -n "$LC_ALL" ]; then
- LOCALE="$LC_ALL"
- # OOo doesn't understand LC_ALL, so set LANG
- LANG="$LC_ALL"
-elif [ -n "$LANG" ]; then
- LOCALE="$LANG"
-elif [ -n "$LC_MESSAGES" ]; then
- LOCALE="$LC_MESSAGES"
- LANG="$LC_MESSAGES"
-else
- LOCALE="en_US"
-fi
-
-# Set locale to en_US if locale is C
-if [ "x$LOCALE" = "xC" ] ; then LOCALE="en_US"; fi
-
-LOCALEOO=`echo $LOCALE | sed 's/_/-/'`
-
-##
-## install OO for this user if needed
-##
-if [ -z "$OOHOME" ] ; then
- if [ -e /etc/openoffice/autoresponse.conf ] && \
- grep -q DESTINATIONPATH /etc/openoffice/autoresponse.conf ; then
- # first install
- OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse.conf | \
- sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
-
- if [ -d "$OOHOME" ]; then
- echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
- echo "yet the directory $OOHOME exists."
- echo "Please remove $OOHOME and try again."
- exit 1
- fi
-
- if oldhome="`get_settings_dir "OpenOffice.org 1.0.1"`" ; then
- OOHOME="$oldhome"
- echo "Using settings from 1.0.1"
- /bin/echo -e "OpenOffice.org <pv>=file://$oldhome\r" >> ~/.sversionrc
- else
- echo "running openoffice.org setup..."
- if ! /opt/OpenOffice.org<pv>/program/setup -R:/etc/openoffice/autoresponse.conf >& /dev/null; then
- echo "setup failed.. abort"
- exit 1
- fi
-
-
- fi
-
- echo "Setup complete. Running openoffice.org..."
-
-else
- echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
- echo "the /etc/openoffice/autoresponse.conf file manually ?"
- echo "This file should contain DESTINATIONPATH"
- exit 1
- fi
-fi
-
-##
-## If no file is specified on the command line, which application to start?
-## The wrapper can be called from several links in /usr/bin
-##
-if [ $# = 0 ]; then
- case `basename $0` in
- oocalc) set -- private:factory/scalc;;
- oodraw) set -- private:factory/sdraw;;
- ooimpress) set -- private:factory/simpress;;
- oomath) set -- private:factory/smath;;
- oowriter) set -- private:factory/swriter;;
- oohtml) set -- private:factory/swriter/web;;
- oomaster) set -- private:factory/swriter/Global;;
- esac
-fi
-
-## Previous dead installation?
-[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
-
-SETUPFILE="$OOHOME/user/config/registry/instance/org/openoffice/Setup.xml"
-mv $SETUPFILE $SETUPFILE.tmp
-
-if ! grep -q "\<ooLocale" $SETUPFILE.tmp ; then
- # Set ooLocale to nothing in $SETUPFILE. The UI language is handled by LANG.
- # A good value for ooLocale will be set before starting.
- cat $SETUPFILE.tmp | \
- perl -e "while (<>) { /<Office>/ && print \" <L10N>\n <ooLocale cfg:type=\\\"string\\\"/>\n </L10N>\n\";print \$_;}" > \
- $SETUPFILE
- rm -f $SETUPFILE.tmp
- mv $SETUPFILE $SETUPFILE.tmp
-fi
-
-## Change the ooLocale key in SETUPFILE acording to LOCALE
-cat $SETUPFILE.tmp | \
- sed 's#<ooLocale\>[^/]*/[^>]*>#<ooLocale cfg:type="string">'$LOCALEOO'</ooLocale>#'\
- > $SETUPFILE
-rm -f $SETUPFILE.tmp
-
-##
-## That's it. Launch the beast (with the given args)
-##
-LANG=$LOCALE
-export LANG
-export LD_PRELOAD=/usr/lib/libfreetype.so
-exec "$OOHOME/soffice" "$@"
-
-## Changelog
-# 2003/02/03 halls
-# * Check for nonexistent ooLocale every run
-# 2003/01/09 halls
-# * Version 1.0.2
-# 12/15 saviot
-# * Change ooLocale at startup in Setup.xml
-# <ooLocale cfg:type="string"/> doesn't work for help.
-# 12/03 challs
-# * Add Debian font paths to user font path
-# 11/14 saviot
-# * correct handling of UI language
-# * don't change Linguistic.xml after first startup(#168780)
-# * TODO: provide better defaults on first startup
-# 10/03 challs
-# * Fix use with LC_ALL
-# 07/10 challs
-# * use 1.0.1 directory and improve error checking
-# 07/02 challs
-# * use readlink in /proc/PID/exe to get
-# real session manager name
-# 06/12 challs
-# * merge into main package
-# * change $@ to "$@"
-# * source configuration file:
-# /etc/openoffice/openoffice.conf
-# 06/12 mquinson
-# * strace only when DEBUG is set to yes
-# * readd the $@ to pass the args to soffice
-# 06/06 mquinson
-# * Make sure the OLDLOCALE is never empty
-# * handle the case where the locale is C
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.2 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.2
deleted file mode 100644
index ef11da4f0658..000000000000
--- a/app-office/openoffice-bin/files/digest-openoffice-bin-1.0.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 c875899cb0036a40de377d46ab87b310 OOo_1.0.2_LinuxIntel_install.tar.gz 72667992
-MD5 6ef6fb8519300dcc0e87b32cb7d288dc OOo_1.0.2_LinuxPowerPC_installer.tar.gz 65305787
diff --git a/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild b/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild
deleted file mode 100644
index a5fe6b79d42b..000000000000
--- a/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild
+++ /dev/null
@@ -1,217 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild,v 1.19 2004/02/22 19:47:37 agriffis Exp $
-
-IUSE="kde gnome"
-
-inherit virtualx
-
-# NOTE: There are two big issues that should be addressed.
-#
-# 1) Language support and fonts should be addressed.
-
-LOC="/opt"
-
-INSTDIR="${LOC}/OpenOffice.org${PV}"
-MY_PV="`echo ${PV} | gawk '{ print toupper($1) }'`"
-
-if [ `use ppc` ]; then
- MY_P="OOo_${MY_PV}_LinuxPowerPC_installer"
- S="${WORKDIR}/${MY_P}"
-else
- MY_P="OOo_${MY_PV}_LinuxIntel_install"
- S="${WORKDIR}/install"
-fi;
-
-DESCRIPTION="OpenOffice productivity suite"
-SRC_URI="x86? ( http://ny1.mirror.openoffice.org/stable/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
- http://sf1.mirror.openoffice.org/stable/${PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz )
- ppc? ( ftp://ftp.yellowdoglinux.com/pub/yellowdog/software/openoffice/OOo_${MY_PV}_LinuxPowerPC_installer.tar.gz )"
-HOMEPAGE="http://www.openoffice.org"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.0
- virtual/x11
- app-arch/zip
- app-arch/unzip
- || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
- !app-office/openoffice"
-
-LICENSE="LGPL-2 | SISSL-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc -sparc"
-
-src_install() {
-
- # Sandbox issues; bug #8587
- addpredict "/user"
- addpredict "/share"
-
- # Sandbox issues; bug 8063
- addpredict "/dev/dri"
-
- # Autoresponse file for main installation
- cat > ${T}/rsfile-global <<-"END_RS"
- [ENVIRONMENT]
- INSTALLATIONMODE=INSTALL_NETWORK
- INSTALLATIONTYPE=STANDARD
- DESTINATIONPATH=<destdir>
- OUTERPATH=
- LOGFILE=
- LANGUAGELIST=<LANGUAGE>
-
- [JAVA]
- JavaSupport=preinstalled_or_none
- END_RS
-
- # Autoresponse file for user isntallation
- cat > ${T}/rsfile-local <<-"END_RS"
- [ENVIRONMENT]
- INSTALLATIONMODE=INSTALL_WORKSTATION
- INSTALLATIONTYPE=WORKSTATION
- DESTINATIONPATH=<home>/.openoffice/<pv>
-
- [JAVA]
- JavaSupport=none
- END_RS
-
- # Fixing install location in response file
- sed -e "s|<destdir>|${D}${INSTDIR}|" \
- ${T}/rsfile-global > ${T}/autoresponse
-
- einfo "Installing OpenOffice.org into build root..."
- dodir ${INSTDIR}
- cd ${S}
- # Setup virtualmake
- export maketype="./setup"
- # We need X to install...
- virtualmake "-v -r:${T}/autoresponse"
-
- #fix the libstdc++.so symlink
- cd ${D}/${INSTDIR}/program
- ln -sf libstdc++.so.3.0.4 libstdc++.so.3
- ln -sf libstdc++.so.3.0.4 libstdc++
-
- echo
- einfo "Removing build root from registry..."
- # Remove totally useless stuff.
- rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh}
- # Remove build root from registry and co
- egrep -rl "${D}" ${D}${INSTDIR}/* | \
- xargs -i perl -pi -e "s|${D}||g" {} || :
-
- einfo "Fixing permissions..."
- # Fix permissions
- find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
- chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
-
- # Fix symlinks
- for x in "soffice program/spadmin" \
- "program/setup setup" \
- "program/spadmin spadmin"
- do
- dosym $(echo ${x} | awk '{print $1}') \
- ${INSTDIR}/$(echo ${x} | awk '{print $2}')
- done
-
- # Install user autoresponse file
- insinto /etc/openoffice
- sed -e "s|<pv>|${PV}|g" ${T}/rsfile-local > ${T}/autoresponse.conf
- doins ${T}/autoresponse.conf
-
- # Install wrapper script
- exeinto /usr/bin
- sed -e "s|<pv>|${PV}|g" \
- ${FILESDIR}/${PV}/ooffice-wrapper-1.2 > ${T}/ooffice
- doexe ${T}/ooffice
- # Component symlinks
- dosym ooffice /usr/bin/oocalc
- dosym ooffice /usr/bin/oodraw
- dosym ooffice /usr/bin/ooimpress
- dosym ooffice /usr/bin/oomath
- dosym ooffice /usr/bin/oowriter
- dosym ooffice /usr/bin/oosetup
- dosym ooffice /usr/bin/oopadmin
-
- einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
- if [ -n "`use gnome`" ]
- then
- insinto /usr/share/gnome/apps/OpenOffice.org
- # Install the files needed for the catagory
- doins ${D}${INSTDIR}/share/gnome/net/.directory
- doins ${D}${INSTDIR}/share/gnome/net/.order
-
- for x in ${D}${INSTDIR}/share/gnome/net/*.desktop
- do
- # We have to handle setup differently
- perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
- # Now fix the rest
- perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
- doins ${x}
- done
- fi
-
- if [ -n "`use kde`" ]
- then
- local kdeloc="${D}${INSTDIR}/share/kde/net/applnk/OpenOffice.org${PV}"
-
- # Portage do not work with the space ..
- mv ${D}${INSTDIR}/share/kde/net/applnk/OpenOffice.org\ ${PV} ${kdeloc}
-
- insinto /usr/share/applnk/OpenOffice.org
- # Install the files needed for the catagory
- doins ${kdeloc}/.directory
- doins ${kdeloc}/.order
- dodir /usr/share
- # Install the icons and mime info
- cp -a ${D}${INSTDIR}/share/kde/net/mimelnk/share/* ${D}/usr/share
-
- for x in ${kdeloc}/*.desktop
- do
- # We have to handle setup differently
- perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
- # Now fix the rest
- perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
- doins ${x}
- done
- fi
-
- # Unneeded, as they get installed into /usr/share...
- rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
-
- for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
- echo 'Categories=Application;Office;' >> ${f}
- done
-
-
- # Make sure these do not get nuked.
- keepdir ${INSTDIR}/user/config/registry/instance/org/openoffice/{Office,ucb}
- keepdir ${INSTDIR}/user/psprint/{driver,fontmetric}
- keepdir ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
-}
-
-pkg_preinst() {
-
- # The one with OO-1.0.0 was not valid
- if [ -f ${ROOT}/etc/openoffice/autoresponse.conf ]
- then
- rm -f ${ROOT}/etc/openoffice/autoresponse.conf
- fi
-}
-
-pkg_postinst() {
-
- einfo "******************************************************************"
- einfo " To start OpenOffice.org, run:"
- einfo
- einfo " $ ooffice"
- einfo
- einfo " Also, for individual components, you can use any of:"
- einfo
- einfo " oocalc, oodraw, ooimpress, oomath or oowriter"
- einfo
- einfo " If the fonts appear garbled in the user interface refer to "
- einfo " Bug 8539, or http://www.openoffice.org/FAQs/fontguide.html#8"
- einfo
- einfo "******************************************************************"
-}
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
index 8c62e413a121..108647c20262 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild,v 1.4 2004/04/05 13:56:44 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild,v 1.5 2004/04/11 21:00:39 suka Exp $
IUSE="kde gnome"
@@ -39,7 +39,7 @@ RDEPEND="virtual/glibc
LICENSE="LGPL-2 | SISSL-1.1"
SLOT="0"
-KEYWORDS="~x86 -ppc -sparc"
+KEYWORDS="x86 -ppc -sparc"
src_install() {
# Sandbox issues; bug #8587