summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-02-24 12:16:58 +0000
committerTorsten Veller <tove@gentoo.org>2009-02-24 12:16:58 +0000
commit74db3a219b17195b30d67ec949e9bcae5b9e67bf (patch)
treeed455051f4f0d99e379ad02f37f1a06c53093930 /app-office
parentversion bump thanks to upstream maintainer - Hendrik-Jan Thomassen (diff)
downloadgentoo-2-74db3a219b17195b30d67ec949e9bcae5b9e67bf.tar.gz
gentoo-2-74db3a219b17195b30d67ec949e9bcae5b9e67bf.tar.bz2
gentoo-2-74db3a219b17195b30d67ec949e9bcae5b9e67bf.zip
Version bump. Uses EAPI=2
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/gnucash-2.2.9.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 1979d5e7ed97..c240ea252265 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.179 2009/01/30 18:26:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.180 2009/02/24 12:16:58 tove Exp $
+
+*gnucash-2.2.9 (24 Feb 2009)
+
+ 24 Feb 2009; Torsten Veller <tove@gentoo.org> +gnucash-2.2.9.ebuild:
+ Version bump. Uses EAPI=2 now.
30 Jan 2009; Torsten Veller <tove@gentoo.org> gnucash-2.2.8.ebuild:
aqbanking should be built with qt3 if hbci is in USE (#255174)
diff --git a/app-office/gnucash/gnucash-2.2.9.ebuild b/app-office/gnucash/gnucash-2.2.9.ebuild
new file mode 100644
index 000000000000..983625aecf9b
--- /dev/null
+++ b/app-office/gnucash/gnucash-2.2.9.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.2.9.ebuild,v 1.1 2009/02/24 12:16:58 tove Exp $
+
+EAPI=2
+
+inherit eutils gnome2
+
+DOC_VER="2.2.0"
+
+DESCRIPTION="A personal finance manager"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.lzma"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="+doc ofx hbci chipcard debug quotes"
+
+# FIXME: rdepend on dev-libs/qof when upstream fix their mess (see configure.in)
+
+RDEPEND=">=dev-libs/glib-2.6.3
+ >=dev-scheme/guile-1.8.3[deprecated,regex]
+ >=dev-scheme/slib-3.1.4
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/popt-1.5
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libgnomeui-2.4
+ >=gnome-base/libglade-2.4
+ >=gnome-extra/gtkhtml-3.14
+ >=dev-libs/libxml2-2.5.10
+ >=gnome-base/gconf-2
+ >=x11-libs/goffice-0.6[gnome]
+ ofx? ( >=dev-libs/libofx-0.7.0 )
+ hbci? ( net-libs/aqbanking[qt3]
+ chipcard? ( sys-libs/libchipcard )
+ )
+ quotes? ( dev-perl/DateManip
+ >=dev-perl/Finance-Quote-1.11
+ dev-perl/HTML-TableExtract )
+ media-libs/libart_lgpl
+ x11-libs/pango"
+
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/libtool
+ >=app-text/scrollkeeper-0.3"
+
+PDEPEND="doc? ( >=app-doc/gnucash-docs-${DOC_VER} )"
+ELTCONF="--patch-only"
+DOCS="doc/README.OFX doc/README.HBCI"
+
+# FIXME: no the best thing to do but it'd be even better to fix autofoo
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ local diemessage=""
+ if ! built_with_use gnome-extra/libgsf gnome ; then
+ diemessage="${diemessage}gnome-extra/libgsf must be built with gnome use flag. "
+ fi
+ [ -n "${diemessage}" ] && die ${diemessage}
+
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable ofx)
+ $(use_enable hbci aqbanking)
+ --disable-doxygen
+ --enable-locale-specific-tax
+ --disable-error-on-warning"
+}
+
+src_test() {
+ GUILE_WARN_DEPRECATED=no \
+ GNC_DOT_DIR="${T}"/.gnucash \
+ emake check \
+ || die "Make check failed. See above for details."
+}
+
+src_install() {
+ gnome2_src_install GNC_DOC_INSTALL_DIR=/usr/share/doc/${PF}
+
+ rm -rf "${D}"/usr/share/doc/${PF}/{examples/,COPYING,INSTALL,*win32-bin.txt,projects.html}
+# prepalldocs
+ mv "${D}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
+ dodoc "${T}"/cantuseprepalldocs/* || die
+}