summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-08-20 20:54:29 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-08-20 20:54:29 +0000
commit6a9a9ebfaf779df8eb43bfe8c7d71f6c52bf3f9e (patch)
tree1b68a6630d5d5d60110ea38f2f62ca6cecdc0199 /app-office
parentfix digest (diff)
downloadgentoo-2-6a9a9ebfaf779df8eb43bfe8c7d71f6c52bf3f9e.tar.gz
gentoo-2-6a9a9ebfaf779df8eb43bfe8c7d71f6c52bf3f9e.tar.bz2
gentoo-2-6a9a9ebfaf779df8eb43bfe8c7d71f6c52bf3f9e.zip
fix some sandbox issues and correct gcc warning
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-ximian/ChangeLog7
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild8
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild8
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild8
4 files changed, 21 insertions, 10 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index 437294d1db0f..3fb5f9b6e6e7 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.57 2004/08/20 06:24:29 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.58 2004/08/20 20:54:29 suka Exp $
+
+ 20 Aug 2004; suka@gentoo.org openoffice-ximian-1.1.55.ebuild,
+ openoffice-ximian-1.1.61.ebuild, openoffice-ximian-1.3.0.ebuild:
+ fix some sandbox issues and fix gcc-statement (this package only works with
+ gcc 3.2 or gcc 3.3 atm)
*openoffice-ximian-1.3.0 (20 Aug 2004)
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
index af48f6ee9983..88a15addf044 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.15 2004/07/17 21:32:17 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.55.ebuild,v 1.16 2004/08/20 20:54:29 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -189,7 +189,7 @@ oo_setup() {
export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
# Just recheck gcc version ...
- if [ "$(gcc-version)" != 3.2 -a "$(gcc-version)" != "3.3" ]
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
then
# See if we can get a gcc profile we know is proper ...
if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1 &> /dev/null
@@ -197,7 +197,7 @@ oo_setup() {
export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1):${PATH}"
export GCC_PROFILE="${CHOST}-3.2.1"
else
- eerror "This build needs gcc-3.2.1 or later!"
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
eerror
eerror "Use gcc-config to change your gcc profile:"
eerror
@@ -365,6 +365,8 @@ src_install() {
addpredict "/dev/dri"
addpredict "/usr/bin/soffice"
addpredict "/pspfontcache"
+ addpredict "/opt/OpenOffice.org/foo.tmp"
+ addpredict "/opt/OpenOffice.org/delme"
# The install part should now be relatively OK compared to
# what it was. Basically we use autoresponse files to install
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild
index 0d713bfbcb6b..3cb2e225d563 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild,v 1.1 2004/08/01 13:57:26 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.61.ebuild,v 1.2 2004/08/20 20:54:29 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -196,7 +196,7 @@ oo_setup() {
export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
# Just recheck gcc version ...
- if [ "$(gcc-version)" != 3.2 -a "$(gcc-version)" != "3.3" ]
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
then
# See if we can get a gcc profile we know is proper ...
if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1 &> /dev/null
@@ -204,7 +204,7 @@ oo_setup() {
export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1):${PATH}"
export GCC_PROFILE="${CHOST}-3.2.1"
else
- eerror "This build needs gcc-3.2.1 or later!"
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
eerror
eerror "Use gcc-config to change your gcc profile:"
eerror
@@ -393,6 +393,8 @@ src_install() {
addpredict "/dev/dri"
addpredict "/usr/bin/soffice"
addpredict "/pspfontcache"
+ addpredict "/opt/OpenOffice.org/foo.tmp"
+ addpredict "/opt/OpenOffice.org/delme"
# The install part should now be relatively OK compared to
# what it was. Basically we use autoresponse files to install
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild
index 433cdb00b962..7eb81b6f7923 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild,v 1.1 2004/08/20 06:24:29 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.0.ebuild,v 1.2 2004/08/20 20:54:29 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -196,7 +196,7 @@ oo_setup() {
export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
# Just recheck gcc version ...
- if [ "$(gcc-version)" != 3.2 -a "$(gcc-version)" != "3.3" ]
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
then
# See if we can get a gcc profile we know is proper ...
if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1 &> /dev/null
@@ -204,7 +204,7 @@ oo_setup() {
export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1):${PATH}"
export GCC_PROFILE="${CHOST}-3.2.1"
else
- eerror "This build needs gcc-3.2.1 or later!"
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
eerror
eerror "Use gcc-config to change your gcc profile:"
eerror
@@ -376,6 +376,8 @@ src_install() {
addpredict "/dev/dri"
addpredict "/usr/bin/soffice"
addpredict "/pspfontcache"
+ addpredict "/opt/OpenOffice.org/foo.tmp"
+ addpredict "/opt/OpenOffice.org/delme"
# The install part should now be relatively OK compared to
# what it was. Basically we use autoresponse files to install