summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-31 18:16:38 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-31 18:16:38 +0000
commit6341cf3c879d655edcdd9fc49d10d53e0fe4cf38 (patch)
treef3db0db60fdd5bc5f07b46f3d43fcd80135e2ded /app-office
parentVersion bump, remove old. (diff)
downloadgentoo-2-6341cf3c879d655edcdd9fc49d10d53e0fe4cf38.tar.gz
gentoo-2-6341cf3c879d655edcdd9fc49d10d53e0fe4cf38.tar.bz2
gentoo-2-6341cf3c879d655edcdd9fc49d10d53e0fe4cf38.zip
Version bump.
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/gnumeric-1.10.17.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index cbf0f6735403..f2f054ac1d8f 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.226 2011/07/24 11:07:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.227 2011/07/31 18:16:38 pacho Exp $
+
+*gnumeric-1.10.17 (31 Jul 2011)
+
+ 31 Jul 2011; Pacho Ramos <pacho@gentoo.org> +gnumeric-1.10.17.ebuild:
+ Version bump.
24 Jul 2011; Raúl Porcel <armin76@gentoo.org> gnumeric-1.10.15.ebuild:
alpha/ia64/sparc stable wrt #372349
diff --git a/app-office/gnumeric/gnumeric-1.10.17.ebuild b/app-office/gnumeric/gnumeric-1.10.17.ebuild
new file mode 100644
index 000000000000..41aec4c6cee7
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.10.17.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.10.17.ebuild,v 1.1 2011/07/31 18:16:38 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="xz"
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://projects.gnome.org/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="perl python"
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.12:2
+ >=gnome-extra/libgsf-1.14.19
+ >=x11-libs/goffice-0.8.15:0.8
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.12
+
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/cairo[svg]
+
+ perl? ( dev-lang/perl )
+ python? ( >=dev-python/pygtk-2:2 )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --disable-static
+ --without-gnome
+ --without-gda
+ --with-zlib
+ $(use_with perl)
+ $(use_with python)"
+ DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README"
+ use python && python_set_active_version 2
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}