summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-10 17:22:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-10 17:22:26 +0000
commit6288c272fb03fb1d53bb00abf727ae686814f53f (patch)
tree1336d658563b69723e16408e227e0eda0bd1f2f8 /app-office
parentsys-kernel/genkernel: Bump to 3.4.13 (diff)
downloadgentoo-2-6288c272fb03fb1d53bb00abf727ae686814f53f.tar.gz
gentoo-2-6288c272fb03fb1d53bb00abf727ae686814f53f.tar.bz2
gentoo-2-6288c272fb03fb1d53bb00abf727ae686814f53f.zip
Fix check target to work with -j wrt #315949 by Kevin McCarthy.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/ical/ChangeLog6
-rw-r--r--app-office/ical/files/ical-3.0-makefile.patch (renamed from app-office/ical/files/ical-3.0-ldflags.patch)10
-rw-r--r--app-office/ical/ical-3.0-r1.ebuild6
3 files changed, 18 insertions, 4 deletions
diff --git a/app-office/ical/ChangeLog b/app-office/ical/ChangeLog
index 2f9bc54bc97b..13d40f14ad34 100644
--- a/app-office/ical/ChangeLog
+++ b/app-office/ical/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/ical
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.32 2011/02/05 17:46:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.33 2011/02/10 17:22:25 ssuominen Exp $
+
+ 10 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> ical-3.0-r1.ebuild,
+ +files/ical-3.0-makefile.patch:
+ Fix check target to work with -j wrt #315949 by Kevin McCarthy.
05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> ical-3.0-r1.ebuild,
+files/ical-3.0-ldflags.patch:
diff --git a/app-office/ical/files/ical-3.0-ldflags.patch b/app-office/ical/files/ical-3.0-makefile.patch
index 36c1599f8ca7..ecc911c16908 100644
--- a/app-office/ical/files/ical-3.0-ldflags.patch
+++ b/app-office/ical/files/ical-3.0-makefile.patch
@@ -1,4 +1,5 @@
Add LDFLAGS to linker calls
+Fix deps on check targets for parallel tests
Patch by Kevin McCarthy <signals42@gmail.com>
@@ -21,3 +22,12 @@ Patch by Kevin McCarthy <signals42@gmail.com>
$(LIB1): FRC
@echo making in calendar
+@@ -195,7 +195,7 @@
+ check_text:
+ @ICAL_LIBRARY=$(srcdir) ./ical -nodisplay -f $(srcdir)/tests/no_x.tcl
+
+-check_x:
++check_x: check_text
+ @ICAL_LIBRARY=$(srcdir) ./ical -f $(srcdir)/tests/x.tcl
+
+ # Rules for shipping html documentation
diff --git a/app-office/ical/ical-3.0-r1.ebuild b/app-office/ical/ical-3.0-r1.ebuild
index 8a51d47f3d34..dba52ee4d75a 100644
--- a/app-office/ical/ical-3.0-r1.ebuild
+++ b/app-office/ical/ical-3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-3.0-r1.ebuild,v 1.5 2011/02/05 17:46:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-3.0-r1.ebuild,v 1.6 2011/02/10 17:22:25 ssuominen Exp $
EAPI=3
inherit autotools eutils multilib virtualx
@@ -22,7 +22,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-newtcl.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-makefile.patch
sed -i \
-e 's:8.4 8.3:8.6 8.5 8.4 8.3:g' \
@@ -44,7 +44,7 @@ src_compile() {
src_test() {
if [[ ${EUID} != 0 ]]; then
- Xmake -j1 check || die
+ Xemake check || die
fi
}