summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-19 08:23:07 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-19 08:23:07 +0000
commit622bf8223260b1dbb6122c99f75c2f90cbc477f2 (patch)
tree382f664db6ad678b99c0627a95036f7fe96ae664 /app-office
parentMarked 1.93.2 stable (x86). New release, closes bug #45102. (Manifest recommit) (diff)
downloadgentoo-2-622bf8223260b1dbb6122c99f75c2f90cbc477f2.tar.gz
gentoo-2-622bf8223260b1dbb6122c99f75c2f90cbc477f2.tar.bz2
gentoo-2-622bf8223260b1dbb6122c99f75c2f90cbc477f2.zip
fix vfs stuff to work
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-2.0.6.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-office/abiword/abiword-2.0.6.ebuild b/app-office/abiword/abiword-2.0.6.ebuild
index e7b682fd45c9..dc54cbb7efaf 100644
--- a/app-office/abiword/abiword-2.0.6.ebuild
+++ b/app-office/abiword/abiword-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.6.ebuild,v 1.2 2004/04/18 01:43:06 khai Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.6.ebuild,v 1.3 2004/04/19 08:23:07 foser Exp $
inherit eutils
@@ -41,17 +41,6 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_compile() {
- econf \
- `use_enable gnome` \
- `use_with xml2 libxml2` \
- `use_enable spell enchant` \
- `use_enable debug` \
- --enable-bidi \
- --enable-threads \
- --without-ImageMagick \
- --disable-scripting \
- --disable-gucharmap \
- --with-sys-wv || die
# this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
# The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
@@ -59,6 +48,18 @@ src_compile() {
cat configure.old |sed s:-pedantic::g >configure
rm -f configure.old
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --disable-gucharmap \
+ --with-sys-wv || die
+
emake all-recursive || die
# Build plugins