summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-08 23:22:29 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-08 23:22:29 +0000
commit5cefac9a0894cb610fcb7f9c3d7dbae3bc681465 (patch)
tree197fda42b8cb7464211e030ed85b1068e1c6cc6d /app-office
parentVersion upgrade. (diff)
downloadgentoo-2-5cefac9a0894cb610fcb7f9c3d7dbae3bc681465.tar.gz
gentoo-2-5cefac9a0894cb610fcb7f9c3d7dbae3bc681465.tar.bz2
gentoo-2-5cefac9a0894cb610fcb7f9c3d7dbae3bc681465.zip
updated solved, #78
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.5-r11
-rw-r--r--app-office/gnucash/gnucash-1.6.5-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.5-r1 b/app-office/gnucash/files/digest-gnucash-1.6.5-r1
new file mode 100644
index 000000000000..6e79263bf5d0
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.5-r1
@@ -0,0 +1 @@
+MD5 1d711b754fa533b9ee2c4865a2ef9fac gnucash-1.6.5.tar.gz 13979648
diff --git a/app-office/gnucash/gnucash-1.6.5-r1.ebuild b/app-office/gnucash/gnucash-1.6.5-r1.ebuild
new file mode 100644
index 000000000000..c78a43e43aca
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.5-r1.ebuild,v 1.1 2002/01/08 23:22:29 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gnucash.sourceforge.net"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.10
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/guile
+ cp argv-list-converters.c argv-list-converters.c.old
+ sed -e "s,printf,g_print,g" \
+ argv-list-converters.c.old > argv-list-converters.c
+ rm argv-list-converters.c.old
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ $myconf || die
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+
+}
+