summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-15 01:00:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-15 01:00:44 +0000
commit459f6007af90ffec82ed9774b2c4e2740107aedd (patch)
tree216f92ab89bcc04e1a78a672d918be5f9df2c838 /app-office
parentBump to 2.6.8. Bug fixes. (diff)
downloadgentoo-2-459f6007af90ffec82ed9774b2c4e2740107aedd.tar.gz
gentoo-2-459f6007af90ffec82ed9774b2c4e2740107aedd.tar.bz2
gentoo-2-459f6007af90ffec82ed9774b2c4e2740107aedd.zip
Bump to 2.6.8. Bug fixes.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword-plugins/ChangeLog8
-rw-r--r--app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/app-office/abiword-plugins/ChangeLog b/app-office/abiword-plugins/ChangeLog
index 9547cf539b71..dc1c20648e67 100644
--- a/app-office/abiword-plugins/ChangeLog
+++ b/app-office/abiword-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/abiword-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.61 2009/02/20 00:20:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.62 2009/03/15 01:00:44 eva Exp $
+
+*abiword-plugins-2.6.8 (15 Mar 2009)
+
+ 15 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +abiword-plugins-2.6.8.ebuild:
+ Bump to 2.6.8. Bug fixes.
*abiword-plugins-2.6.6 (20 Feb 2009)
diff --git a/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild b/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild
new file mode 100644
index 000000000000..38150975e2de
--- /dev/null
+++ b/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.6.8.ebuild,v 1.1 2009/03/15 01:00:44 eva Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="Set of plugins for abiword"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/abiword/${PV}/source/${P}.tar.gz
+ http://www.abisource.com/downloads/abiword/${PV}/source/${P//-plugins/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cxx debug gnome grammar jabber jpeg libgda math ots pdf readline svg thesaurus wmf wordperfect"
+
+# FIXME: add asio support (better wait on boost 1.35)
+# add abiscan when we get gnome-scan
+
+RDEPEND="=app-office/abiword-${PV}*
+ >=media-libs/fontconfig-1
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ x11-libs/libXft
+ >=gnome-base/libglade-2
+ >=gnome-extra/libgsf-1.14.4
+ cxx? ( >=dev-libs/boost-1.33.1 )
+ gnome? ( >=x11-libs/goffice-0.4:0.4 )
+ grammar? ( >=dev-libs/link-grammar-4.2.2 )
+ !alpha? ( !ia64? ( jabber? (
+ >=dev-libs/libxml2-2.4
+ >=net-libs/loudmouth-1.0.1 ) ) )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ libgda? (
+ =gnome-extra/libgda-1*
+ =gnome-extra/libgnomedb-1* )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ !ia64? ( !ppc64? ( !sparc? ( ots? ( >=app-text/ots-0.5 ) ) ) )
+ pdf? ( >=app-text/poppler-0.5.0-r1 )
+ readline? ( sys-libs/readline )
+ thesaurus? ( >=app-text/aiksaurus-1.2 )
+ wordperfect? ( >=app-text/libwpd-0.8 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ svg? ( >=gnome-base/librsvg-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ if use gnome && ! built_with_use x11-libs/goffice gnome; then
+ eerror "abiword-plugin requires x11-libs/goffice to be compiled"
+ eerror "with USE=\"gnome\""
+ die "gnome support missing in x11-libs/goffice"
+ fi
+
+ if use jabber && ! use cxx; then
+ eerror "AbiCollab needs dev-libs/boost to be build"
+ die "Add USE=\"cxx\" to build AbiCollab plugin"
+ fi
+}
+
+src_compile() {
+ local myconf="--enable-all \
+ --with-abiword="${WORKDIR}/abiword-${PV}" \
+ $(use_with cxx boost) \
+ $(use_with cxx OpenXML) \
+ $(use_enable debug) \
+ $(use_with gnome abigoffice) \
+ $(use_with grammar abigrammar) \
+ $(use_with jabber abicollab) \
+ $(use_with jpeg) \
+ $(use_with libgda gda) \
+ $(use_with math abimathview) \
+ $(use_with ots) \
+ $(use_with pdf) \
+ $(use_with readline abicommand)
+ $(use_with svg librsvg) \
+ $(use_with thesaurus aiksaurus) \
+ $(use_with wmf) \
+ $(use_with wordperfect wpg) \
+ --disable-abiscan \
+ --without-psion"
+
+ econf ${myconf}
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}