summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:32:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:32:40 +0000
commit44efabd6705153441d35aca8405fb65e3f9ff364 (patch)
tree907614095cb56cc06533d60725a70129f2bcb9ba /app-office
parentUpdate to 1.6.0 final. (diff)
downloadgentoo-2-44efabd6705153441d35aca8405fb65e3f9ff364.tar.gz
gentoo-2-44efabd6705153441d35aca8405fb65e3f9ff364.tar.bz2
gentoo-2-44efabd6705153441d35aca8405fb65e3f9ff364.zip
Update to 1.6.0 final.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.03
-rw-r--r--app-office/koffice/koffice-1.6.0.ebuild94
3 files changed, 104 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 39fb74859c74..5363a595b4c8 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.188 2006/10/17 20:40:32 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.189 2006/10/19 16:32:40 flameeyes Exp $
+
+*koffice-1.6.0 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -koffice-1.6_beta1.ebuild, -koffice-1.6_rc1.ebuild, +koffice-1.6.0.ebuild:
+ Update to 1.6.0 final.
17 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
koffice-1.5.2-r1.ebuild:
diff --git a/app-office/koffice/files/digest-koffice-1.6.0 b/app-office/koffice/files/digest-koffice-1.6.0
new file mode 100644
index 000000000000..22dfd6c9ed05
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.0
@@ -0,0 +1,3 @@
+MD5 2134a0d09a3f98b91a062c7bafb57622 koffice-1.5.92.tar.bz2 54676447
+RMD160 4006772a542c24132ef7b7d16ad087beb6eb76cd koffice-1.5.92.tar.bz2 54676447
+SHA256 a4df08decea688dddfeec7b47e0fb4e96bf75e1c85b72b721d315d718bae11c5 koffice-1.5.92.tar.bz2 54676447
diff --git a/app-office/koffice/koffice-1.6.0.ebuild b/app-office/koffice/koffice-1.6.0.ebuild
new file mode 100644
index 000000000000..8ac24a8d3a7e
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.0.ebuild,v 1.1 2006/10/19 16:32:40 flameeyes Exp $
+
+inherit kde
+
+RV="1.5.92"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+#SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.14-r1
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.4
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}