summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-09 12:15:00 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-09 12:15:00 +0000
commit3a2b9b559776c5127f9b38fe12c577e5c9c75a34 (patch)
tree175783b2eea35ee9e8df1a50665befe56978fbf4 /app-office
parentRemove old. (diff)
downloadgentoo-2-3a2b9b559776c5127f9b38fe12c577e5c9c75a34.tar.gz
gentoo-2-3a2b9b559776c5127f9b38fe12c577e5c9c75a34.tar.bz2
gentoo-2-3a2b9b559776c5127f9b38fe12c577e5c9c75a34.zip
Fix build with libcrypt-1.6 (#495176 by Anton Kochkov) and boost dependency (#493786 by Maxim Kammerer)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog9
-rw-r--r--app-office/abiword/abiword-3.0.0-r1.ebuild9
-rw-r--r--app-office/abiword/files/abiword-3.0.0-libgcrypt_1_6_0-1.patch27
3 files changed, 40 insertions, 5 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 4396d36a374e..c09b3cc4c94b 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.272 2013/12/19 21:10:25 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.273 2014/02/09 12:15:00 pacho Exp $
+
+ 09 Feb 2014; Pacho Ramos <pacho@gentoo.org>
+ +files/abiword-3.0.0-libgcrypt_1_6_0-1.patch, abiword-3.0.0-r1.ebuild:
+ Fix build with libcrypt-1.6 (#495176 by Anton Kochkov) and boost dependency
+ (#493786 by Maxim Kammerer)
19 Dec 2013; Pacho Ramos <pacho@gentoo.org> abiword-3.0.0-r1.ebuild:
eds-3.6 or newer is needed (#494774 by Jeremy Huddleston)
diff --git a/app-office/abiword/abiword-3.0.0-r1.ebuild b/app-office/abiword/abiword-3.0.0-r1.ebuild
index 460ed3557172..20a92e381e14 100644
--- a/app-office/abiword/abiword-3.0.0-r1.ebuild
+++ b/app-office/abiword/abiword-3.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-3.0.0-r1.ebuild,v 1.7 2013/12/19 21:10:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-3.0.0-r1.ebuild,v 1.8 2014/02/09 12:15:00 pacho Exp $
EAPI=5
GCONF_DEBUG="yes"
@@ -22,7 +22,6 @@ REQUIRED_USE="!plugins? ( !collab !grammar !latex !math !ots !readline !thesauru
RDEPEND="
>=app-text/wv-1.2
- >=dev-libs/boost-1.40.0
>=dev-libs/fribidi-0.10.4
>=dev-libs/glib-2.16:2
>=dev-libs/libgcrypt-1.4.5
@@ -62,6 +61,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-lang/perl
+ >=dev-libs/boost-1.40.0
virtual/pkgconfig
collab? ( dev-cpp/asio )
"
@@ -77,6 +77,9 @@ src_prepare() {
# http://bugzilla.abisource.com/show_bug.cgi?id=13564
epatch "${FILESDIR}/${PN}-3.0.0-fix-crash.patch"
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13589
+ epatch "${FILESDIR}/${PN}-3.0.0-libgcrypt_1_6_0-1.patch"
+
gnome2_src_prepare
}
diff --git a/app-office/abiword/files/abiword-3.0.0-libgcrypt_1_6_0-1.patch b/app-office/abiword/files/abiword-3.0.0-libgcrypt_1_6_0-1.patch
new file mode 100644
index 000000000000..7ad3dd476717
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.0-libgcrypt_1_6_0-1.patch
@@ -0,0 +1,27 @@
+Submitted By: Armin K. <krejzi at email dot com>
+Date: 2013-12-21
+Initial Package Version: 3.0.0
+Upstream Status: Not submitted
+Origin: Self
+Description: Fixes building with libgcrypt 1.6.0
+
+diff -Naur a/plugins/collab/backends/service/xp/tls_tunnel.cpp b/plugins/collab/backends/service/xp/tls_tunnel.cpp
+--- a/plugins/collab/backends/service/xp/tls_tunnel.cpp 2009-09-10 12:46:19.000000000 +0200
++++ b/plugins/collab/backends/service/xp/tls_tunnel.cpp 2013-12-20 19:25:38.728798750 +0100
+@@ -123,11 +123,16 @@
+ return 0;
+ }
+
++#if GCRYPT_VERSION_NUMBER >= 0x010600
++ GCRY_THREAD_OPTION_PTHREAD_IMPL;
++ static struct gcry_thread_cbs &gcry_threads_tunnel = gcry_threads_pthread;
++#else
+ static struct gcry_thread_cbs gcry_threads_tunnel =
+ { GCRY_THREAD_OPTION_USER, NULL,
+ gcry_tunnel_mutex_init, gcry_tunnel_mutex_destroy,
+ gcry_tunnel_mutex_lock, gcry_tunnel_mutex_unlock,
+ NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL };
++#endif
+
+ bool Proxy::tls_tunnel_init() {
+ if (gcry_control(GCRYCTL_SET_THREAD_CBS, &tls_tunnel::gcry_threads_tunnel) != 0)