summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 06:20:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 06:20:25 +0000
commit2a7051e6e98d462bf7f9794e81e63f6f5729f43a (patch)
treeb63d2710266eac3e84b60f9923afb5ac2d903570 /app-office
parentvirtual x fix (diff)
downloadgentoo-2-2a7051e6e98d462bf7f9794e81e63f6f5729f43a.tar.gz
gentoo-2-2a7051e6e98d462bf7f9794e81e63f6f5729f43a.tar.bz2
gentoo-2-2a7051e6e98d462bf7f9794e81e63f6f5729f43a.zip
fixed up a typo and cleaned up ebuild
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/gnumeric-1.1.6.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/app-office/gnumeric/gnumeric-1.1.6.ebuild b/app-office/gnumeric/gnumeric-1.1.6.ebuild
index 8fcb004c30de..fcdd0b065642 100644
--- a/app-office/gnumeric/gnumeric-1.1.6.ebuild
+++ b/app-office/gnumeric/gnumeric-1.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.6.ebuild,v 1.1 2002/08/06 01:04:04 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.6.ebuild,v 1.2 2002/08/30 06:20:25 seemant Exp $
#provide Xmake and Xemake
inherit virtualx
@@ -50,16 +50,24 @@ src_unpack() {
src_compile() {
local myconf
use nls || myconf="--disable-nls"
- use gb && myconf="${myconf} --with-gb" || myconf="${myconf} --without-gb"
- use guile && myconf="${myconf} --with-guile" || myconf="${myconf} --without-guile"
- use perl && myconf="${myconf} --with-perl" || myconf="${myconf} --without-perl"
- use python && yconf="${myconf} --with-python" || myconf="${myconf} --without-python"
+ use gb \
+ && myconf="${myconf} --with-gb" \
+ || myconf="${myconf} --without-gb"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- ${myconf} || die
+ use guile \
+ && myconf="${myconf} --with-guile" \
+ || myconf="${myconf} --without-guile"
+
+ use perl \
+ && myconf="${myconf} --with-perl" \
+ || myconf="${myconf} --without-perl"
+
+ use python \
+ && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+
+ econf ${myconf} || die
#'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
#else the build fails.
@@ -71,9 +79,7 @@ src_compile() {
src_install() {
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- install || die
+ einstall || die
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
}