summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-15 19:12:11 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-15 19:12:11 +0000
commit26c77589d98c0a10192cdf9d6fe3071aabcf68fb (patch)
treef4592e2bf68fdfc31a51f4ad2481b6d23c108b55 /app-office
parent Deal with bug 167522 and configure with neon 0.26.3. (diff)
downloadgentoo-2-26c77589d98c0a10192cdf9d6fe3071aabcf68fb.tar.gz
gentoo-2-26c77589d98c0a10192cdf9d6fe3071aabcf68fb.tar.bz2
gentoo-2-26c77589d98c0a10192cdf9d6fe3071aabcf68fb.zip
SQL view query fix.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/ChangeLog8
-rw-r--r--app-office/kexi/files/digest-kexi-1.6.2-r23
-rw-r--r--app-office/kexi/files/kexi-1.6.2-query.diff74
-rw-r--r--app-office/kexi/kexi-1.6.2-r2.ebuild51
4 files changed, 135 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 7c8d397ff84d..9c547fdeec8b 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.75 2007/03/18 22:35:00 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.76 2007/05/15 19:12:11 carlo Exp $
+
+*kexi-1.6.2-r2 (15 May 2007)
+
+ 15 May 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/kexi-1.6.2-query.diff, +kexi-1.6.2-r2.ebuild:
+ SQL view query fix.
*kexi-1.6.2-r1 (18 Mar 2007)
diff --git a/app-office/kexi/files/digest-kexi-1.6.2-r2 b/app-office/kexi/files/digest-kexi-1.6.2-r2
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.6.2-r2
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/kexi/files/kexi-1.6.2-query.diff b/app-office/kexi/files/kexi-1.6.2-query.diff
new file mode 100644
index 000000000000..ffa0812d020f
--- /dev/null
+++ b/app-office/kexi/files/kexi-1.6.2-query.diff
@@ -0,0 +1,74 @@
+Index: kexi/kexidb/field.cpp
+===================================================================
+--- kexi/kexidb/field.cpp (wersja 664945)
++++ kexi/kexidb/field.cpp (kopia robocza)
+@@ -268,11 +268,6 @@
+ return false;
+ }
+
+-bool Field::isQueryAsterisk() const
+-{
+- return dynamic_cast<QueryAsterisk const *>(this);
+-}
+-
+ bool Field::hasEmptyProperty(uint type)
+ {
+ return Field::isTextType(type) || type==BLOB;
+Index: kexi/kexidb/queryschema.cpp
+===================================================================
+--- kexi/kexidb/queryschema.cpp (wersja 664945)
++++ kexi/kexidb/queryschema.cpp (kopia robocza)
+@@ -1837,7 +1837,7 @@
+ m_table=table;
+ }
+
+-QString QueryAsterisk::debugString()
++QString QueryAsterisk::debugString() const
+ {
+ QString dbg;
+ if (isAllTableAsterisk()) {
+Index: kexi/kexidb/queryschema.h
+===================================================================
+--- kexi/kexidb/queryschema.h (wersja 664945)
++++ kexi/kexidb/queryschema.h (kopia robocza)
+@@ -775,7 +775,7 @@
+ There can be many asterisks of 1st type defined for given single query.
+ There can be one asterisk of 2nd type defined for given single query.
+ */
+-class KEXI_DB_EXPORT QueryAsterisk : protected Field
++class KEXI_DB_EXPORT QueryAsterisk : public Field
+ {
+ public:
+ /*! Constructs query asterisk definition object.
+@@ -803,6 +803,9 @@
+ \a table may be NULL - then the asterisk becames "all-tables" type asterisk. */
+ virtual void setTable(TableSchema *table);
+
++ /*! Reimplemented. */
++ virtual bool isQueryAsterisk() const { return true; }
++
+ /*! This is convenience method that returns true
+ if the asterisk has "all-tables" type (2nd type).*/
+ bool isSingleTableAsterisk() const { return m_table!=NULL; }
+@@ -812,7 +815,7 @@
+ bool isAllTableAsterisk() const { return m_table==NULL; }
+
+ /*! \return String for debugging purposes. */
+- virtual QString debugString();
++ virtual QString debugString() const;
+
+ protected:
+ //! \return a deep copy of this object. Used in FieldList(const FieldList& fl).
+Index: kexi/kexidb/field.h
+===================================================================
+--- kexi/kexidb/field.h (wersja 664945)
++++ kexi/kexidb/field.h (kopia robocza)
+@@ -507,7 +507,7 @@
+ Every QueryAsterisk object returns true here,
+ and every Field object returns false.
+ */
+- bool isQueryAsterisk() const;
++ virtual bool isQueryAsterisk() const { return false; }
+
+ /*! \return string for debugging purposes. */
+ virtual QString debugString() const;
diff --git a/app-office/kexi/kexi-1.6.2-r2.ebuild b/app-office/kexi/kexi-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..4a31efb69171
--- /dev/null
+++ b/app-office/kexi/kexi-1.6.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.2-r2.ebuild,v 1.1 2007/05/15 19:12:11 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres kdeenablefinal"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+PATCHES="${FILESDIR}/kexi-1.6.2-build_kexi_file.diff
+ ${FILESDIR}/kexi-1.6.2-query.diff"
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ # Labplot needs the header file
+ sed -i -e "s:utils.h:utils.h parser/parser.h:" kexi/kexidb/Makefile.am || die "sed failed"
+ kde-meta_src_compile
+}