summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-12-18 12:42:18 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-12-18 12:42:18 +0000
commit25a17a8f6991eea2945d57d76f3ebdb6ef15b4f6 (patch)
treec6d73fd908250c3ed1c0d8ab1d1990f9775403e4 /app-office
parentforgot to upgrade deps (diff)
downloadgentoo-2-25a17a8f6991eea2945d57d76f3ebdb6ef15b4f6.tar.gz
gentoo-2-25a17a8f6991eea2945d57d76f3ebdb6ef15b4f6.tar.bz2
gentoo-2-25a17a8f6991eea2945d57d76f3ebdb6ef15b4f6.zip
New version of Koffice... Bugfix release
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/files/digest-koffice-1.1.11
-rw-r--r--app-office/koffice/koffice-1.1.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-office/koffice/files/digest-koffice-1.1.1 b/app-office/koffice/files/digest-koffice-1.1.1
new file mode 100644
index 000000000000..afcb4667ee62
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.1.1
@@ -0,0 +1 @@
+MD5 7692854feb223180e00f47f850fd006a koffice-1.1.1.tar.bz2 8495104
diff --git a/app-office/koffice/koffice-1.1.1.ebuild b/app-office/koffice/koffice-1.1.1.ebuild
new file mode 100644
index 000000000000..aaf51d262b5d
--- /dev/null
+++ b/app-office/koffice/koffice-1.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.1.ebuild,v 1.1 2001/12/18 12:42:18 verwilst Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-base || die
+
+need-kdelibs 2.2
+
+DESCRIPTION="KDE ${PV} - KOffice"
+
+HOMEPAGE="http://www.koffice.org/"
+
+# turns out kde.org.eclass doesn't work here
+SRC_PATH="kde/stable/${P}/src/${P}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.0-r5"
+# >=sys-devel/automake-1.4
+# >=sys-devel/autoconf-1.13"
+ # hm. This was in achim's original. are these versions superior to the ones we have by default in a current-day rc6?
+
+src_unpack() {
+ base_src_unpack all patch
+ kde-objprelink-patch
+}
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ cd ${S}
+ make LIBPYTHON="`python-config --libs`"
+
+}