summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-27 23:39:43 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-27 23:39:43 +0000
commit241664a806cb45244ebd13be3c388a3fa22bdf09 (patch)
treef7c63cb41c0e94a21f6b8f0da1ca6b4f6816bea3 /app-office
parentMove all agents into kdepim-common-libs, bug 494754 (diff)
downloadgentoo-2-241664a806cb45244ebd13be3c388a3fa22bdf09.tar.gz
gentoo-2-241664a806cb45244ebd13be3c388a3fa22bdf09.tar.bz2
gentoo-2-241664a806cb45244ebd13be3c388a3fa22bdf09.zip
Version bump for bug 491150
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-bin/ChangeLog8
-rw-r--r--app-office/libreoffice-bin/libreoffice-bin-4.1.4.2.ebuild224
2 files changed, 231 insertions, 1 deletions
diff --git a/app-office/libreoffice-bin/ChangeLog b/app-office/libreoffice-bin/ChangeLog
index df55b0a25234..7e3169c5f471 100644
--- a/app-office/libreoffice-bin/ChangeLog
+++ b/app-office/libreoffice-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-bin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/ChangeLog,v 1.132 2014/01/16 20:46:24 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/ChangeLog,v 1.133 2014/01/27 23:39:43 dilfridge Exp $
+
+*libreoffice-bin-4.1.4.2 (27 Jan 2014)
+
+ 27 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libreoffice-bin-4.1.4.2.ebuild:
+ Version bump for bug 491150
16 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
-libreoffice-bin-4.1.3.2-r2.ebuild:
diff --git a/app-office/libreoffice-bin/libreoffice-bin-4.1.4.2.ebuild b/app-office/libreoffice-bin/libreoffice-bin-4.1.4.2.ebuild
new file mode 100644
index 000000000000..6475e3ff1813
--- /dev/null
+++ b/app-office/libreoffice-bin/libreoffice-bin-4.1.4.2.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/libreoffice-bin-4.1.4.2.ebuild,v 1.1 2014/01/27 23:39:43 dilfridge Exp $
+
+EAPI=5
+
+KDE_REQUIRED="optional"
+CMAKE_REQUIRED="never"
+
+BASE_PACKAGENAME="bin"
+BASE_AMD64_URI="http://packages.gentooexperimental.org/packages/amd64-libreoffice/amd64-${BASE_PACKAGENAME}-"
+BASE_X86_URI="http://packages.gentooexperimental.org/packages/x86-libreoffice/x86-${BASE_PACKAGENAME}-"
+
+PYTHON_COMPAT=( python2_7 python3_3 )
+PYTHON_REQ_USE="threads,xml"
+
+inherit kde4-base java-pkg-opt-2 python-single-r1 pax-utils prefix versionator
+
+DESCRIPTION="LibreOffice, a full office productivity suite. Binary package."
+HOMEPAGE="http://www.libreoffice.org"
+SRC_URI_AMD64="
+ ${BASE_AMD64_URI}libreoffice-${PVR}.tar.xz
+ kde? (
+ !java? ( ${BASE_AMD64_URI}libreoffice-kde-${PVR}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-kde-java-${PVR}.xd3 )
+ )
+ gnome? (
+ !java? ( ${BASE_AMD64_URI}libreoffice-gnome-${PVR}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ )
+ !kde? ( !gnome? (
+ java? ( ${BASE_AMD64_URI}libreoffice-java-${PVR}.xd3 )
+ ) )
+"
+SRC_URI_X86="
+ ${BASE_X86_URI}libreoffice-${PVR}.tar.xz
+ kde? (
+ !java? ( ${BASE_X86_URI}libreoffice-kde-${PVR}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-kde-java-${PVR}.xd3 )
+ )
+ gnome? (
+ !java? ( ${BASE_X86_URI}libreoffice-gnome-${PVR}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ )
+ !kde? ( !gnome? (
+ java? ( ${BASE_X86_URI}libreoffice-java-${PVR}.xd3 )
+ ) )
+"
+
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
+IUSE="gnome java kde"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BIN_COMMON_DEPEND="
+ =app-text/libexttextcat-3.4*
+ app-text/poppler:0/44
+ dev-libs/boost:0/1.52
+ dev-libs/icu:0/51.2
+ =media-gfx/graphite2-1.2*
+ =media-libs/harfbuzz-0.9.23[icu]
+ media-libs/libpng:0/16
+ >=sys-libs/glibc-2.17
+ virtual/jpeg:62
+ kde? ( >=kde-base/kdelibs-4.11.2-r1:4 >=dev-qt/qtcore-4.8.5-r1:4 )
+"
+
+# PLEASE place any restrictions that are specific to the binary builds
+# into the BIN_COMMON_DEPEND block above.
+# All dependencies below this point should remain identical to those in
+# the source ebuilds.
+
+COMMON_DEPEND="
+ ${BIN_COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ app-arch/unzip
+ >=app-text/hunspell-1.3.2-r3
+ app-text/mythes
+ >=app-text/libexttextcat-3.2
+ app-text/liblangtag
+ app-text/libmspub
+ >=app-text/libmwaw-0.1.7
+ app-text/libodfgen
+ app-text/libwpd:0.9[tools]
+ app-text/libwpg:0.2
+ >=app-text/libwps-0.2.2
+ >=app-text/poppler-0.16:=[xpdf-headers(+),cxx]
+ >=dev-cpp/clucene-2.3.3.4-r2
+ >=dev-cpp/libcmis-0.3.1:0.3
+ dev-db/unixODBC
+ >=dev-libs/boost-1.46:=
+ dev-libs/expat
+ >=dev-libs/hyphen-2.7.1
+ >=dev-libs/icu-4.8.1.1:=
+ >=dev-libs/liborcus-0.5.1:=
+ >=dev-libs/nspr-4.8.8
+ >=dev-libs/nss-3.12.9
+ >=dev-lang/perl-5.0
+ >=dev-libs/openssl-1.0.0d
+ >=dev-libs/redland-1.0.16[ssl]
+ media-gfx/graphite2
+ >=media-libs/fontconfig-2.8.0
+ media-libs/freetype:2
+ >=media-libs/harfbuzz-0.9.10:=[icu(+)]
+ media-libs/lcms:2
+ >=media-libs/libpng-1.4
+ >=media-libs/libcdr-0.0.5
+ media-libs/libvisio
+ >=net-misc/curl-7.21.4
+ net-nds/openldap
+ sci-mathematics/lpsolve
+ virtual/jpeg
+ >=x11-libs/cairo-1.10.0[X]
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ net-print/cups
+ >=dev-libs/dbus-glib-0.92
+ gnome? ( gnome-extra/evolution-data-server )
+ gnome? ( gnome-base/gconf:2 )
+ x11-libs/gdk-pixbuf[X]
+ >=x11-libs/gtk+-2.24:2
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ virtual/glu
+ virtual/opengl
+ net-libs/neon
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-office/libreoffice
+ !<app-office/openoffice-bin-3.4.0-r1
+ !app-office/openoffice
+ media-fonts/libertine-ttf
+ media-fonts/liberation-fonts
+ media-fonts/urw-fonts
+ java? ( >=virtual/jre-1.6 )
+"
+
+PDEPEND="
+ =app-office/libreoffice-l10n-${PV}*
+"
+
+DEPEND="dev-util/xdelta:3"
+
+# only one flavor at a time
+REQUIRED_USE="kde? ( !gnome ) gnome? ( !kde )"
+
+RESTRICT="test strip"
+
+S="${WORKDIR}"
+
+PYTHON_UPDATER_IGNORE="1"
+
+pkg_pretend() {
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 4 ]] ) \
+ && die "Sorry, but gcc-4.4 and earlier won't work for libreoffice-bin package (see bug #387515)."
+}
+
+pkg_setup() {
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ elog "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz"
+ xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+
+ local patchname
+ use kde && patchname="-kde"
+ use gnome && patchname="-gnome"
+ use java && patchname="${patchname}-java"
+
+ if [ -n "${patchname}" ]; then
+ elog "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3"
+ xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3" "${WORKDIR}/tmpdist.tar" || die
+ mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ fi
+
+ elog "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+ unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/50-${PN} "${T}"
+ eprefixify "${T}"/50-${PN}
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr
+ cp -aR "${S}"/usr/* "${ED}"/usr/
+
+ # prevent revdep-rebuild from attempting to rebuild all the time
+ insinto /etc/revdep-rebuild && doins "${T}/50-${PN}"
+}
+
+pkg_preinst() {
+ # Cache updates - all handled by kde eclass for all environments
+ kde4-base_pkg_preinst
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
+ pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
+
+ use java || \
+ ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
+}
+
+pkg_postrm() {
+ kde4-base_pkg_postrm
+}