summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-15 19:14:55 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-15 19:14:55 +0000
commit178a55a50759cfc4194fd1b82e83fb47f27bb271 (patch)
tree55e93ea546e0c43847aaa926de14266eda72872a /app-office
parent SQL view query fix. (diff)
downloadgentoo-2-178a55a50759cfc4194fd1b82e83fb47f27bb271.tar.gz
gentoo-2-178a55a50759cfc4194fd1b82e83fb47f27bb271.tar.bz2
gentoo-2-178a55a50759cfc4194fd1b82e83fb47f27bb271.zip
SQL view query fix.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.2-r23
-rw-r--r--app-office/koffice/files/kexi-1.6.2-query.diff74
-rw-r--r--app-office/koffice/koffice-1.6.2-r2.ebuild107
4 files changed, 191 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 8bb1dccf4a53..8ab18f78d7b2 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.218 2007/04/19 10:38:00 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.219 2007/05/15 19:14:55 carlo Exp $
+
+*koffice-1.6.2-r2 (15 May 2007)
+
+ 15 May 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/kexi-1.6.2-query.diff, +koffice-1.6.2-r2.ebuild:
+ SQL view query fix.
19 Apr 2007; Carsten Lohrke <carlo@gentoo.org> koffice-1.6.2-r1.ebuild:
Care for some tests.
diff --git a/app-office/koffice/files/digest-koffice-1.6.2-r2 b/app-office/koffice/files/digest-koffice-1.6.2-r2
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.2-r2
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/koffice/files/kexi-1.6.2-query.diff b/app-office/koffice/files/kexi-1.6.2-query.diff
new file mode 100644
index 000000000000..ffa0812d020f
--- /dev/null
+++ b/app-office/koffice/files/kexi-1.6.2-query.diff
@@ -0,0 +1,74 @@
+Index: kexi/kexidb/field.cpp
+===================================================================
+--- kexi/kexidb/field.cpp (wersja 664945)
++++ kexi/kexidb/field.cpp (kopia robocza)
+@@ -268,11 +268,6 @@
+ return false;
+ }
+
+-bool Field::isQueryAsterisk() const
+-{
+- return dynamic_cast<QueryAsterisk const *>(this);
+-}
+-
+ bool Field::hasEmptyProperty(uint type)
+ {
+ return Field::isTextType(type) || type==BLOB;
+Index: kexi/kexidb/queryschema.cpp
+===================================================================
+--- kexi/kexidb/queryschema.cpp (wersja 664945)
++++ kexi/kexidb/queryschema.cpp (kopia robocza)
+@@ -1837,7 +1837,7 @@
+ m_table=table;
+ }
+
+-QString QueryAsterisk::debugString()
++QString QueryAsterisk::debugString() const
+ {
+ QString dbg;
+ if (isAllTableAsterisk()) {
+Index: kexi/kexidb/queryschema.h
+===================================================================
+--- kexi/kexidb/queryschema.h (wersja 664945)
++++ kexi/kexidb/queryschema.h (kopia robocza)
+@@ -775,7 +775,7 @@
+ There can be many asterisks of 1st type defined for given single query.
+ There can be one asterisk of 2nd type defined for given single query.
+ */
+-class KEXI_DB_EXPORT QueryAsterisk : protected Field
++class KEXI_DB_EXPORT QueryAsterisk : public Field
+ {
+ public:
+ /*! Constructs query asterisk definition object.
+@@ -803,6 +803,9 @@
+ \a table may be NULL - then the asterisk becames "all-tables" type asterisk. */
+ virtual void setTable(TableSchema *table);
+
++ /*! Reimplemented. */
++ virtual bool isQueryAsterisk() const { return true; }
++
+ /*! This is convenience method that returns true
+ if the asterisk has "all-tables" type (2nd type).*/
+ bool isSingleTableAsterisk() const { return m_table!=NULL; }
+@@ -812,7 +815,7 @@
+ bool isAllTableAsterisk() const { return m_table==NULL; }
+
+ /*! \return String for debugging purposes. */
+- virtual QString debugString();
++ virtual QString debugString() const;
+
+ protected:
+ //! \return a deep copy of this object. Used in FieldList(const FieldList& fl).
+Index: kexi/kexidb/field.h
+===================================================================
+--- kexi/kexidb/field.h (wersja 664945)
++++ kexi/kexidb/field.h (kopia robocza)
+@@ -507,7 +507,7 @@
+ Every QueryAsterisk object returns true here,
+ and every Field object returns false.
+ */
+- bool isQueryAsterisk() const;
++ virtual bool isQueryAsterisk() const { return false; }
+
+ /*! \return string for debugging purposes. */
+ virtual QString debugString() const;
diff --git a/app-office/koffice/koffice-1.6.2-r2.ebuild b/app-office/koffice/koffice-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..3b998e54af02
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.2-r2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.2-r2.ebuild,v 1.1 2007/05/15 19:14:55 carlo Exp $
+
+inherit kde
+
+RV="${PV}"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+#SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.15
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.4
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+PATCHES="${FILESDIR}/kexi-1.6.2-build_kexi_file.diff
+ ${FILESDIR}/kexi-1.6.2-query.diff"
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+ sed -i -e "s:toolbar tests:toolbar:" ${S}/kplato/Makefile.am
+
+ if ! [[ $(xhost >> /dev/null 2>/dev/null) ]] ; then
+ einfo "User ${USER} has no X access, disabling some tests."
+ sed -e "s:SUBDIRS = . tests:SUBDIRS = .:" -i lib/store/Makefile.am || die "sed failed"
+ sed -e "s:SUBDIRS = kohyphen . tests:SUBDIRS = kohyphen .:" -i lib/kotext/Makefile.am || die "sed failed"
+ fi
+
+ # Labplot needs the header file
+ sed -i -e "s:utils.h:utils.h parser/parser.h:" ${S}/kexi/kexidb/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}