summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-05-31 22:13:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-05-31 22:13:22 +0000
commit087aecafa8a5409746bf497efd76a705c0e78189 (patch)
treeae321716e4f8d37292178eec4bd2fb1b762c23c0 /app-office
parentAddress bug 300722, bug 312921 (diff)
downloadgentoo-2-087aecafa8a5409746bf497efd76a705c0e78189.tar.gz
gentoo-2-087aecafa8a5409746bf497efd76a705c0e78189.tar.bz2
gentoo-2-087aecafa8a5409746bf497efd76a705c0e78189.zip
Version bump, bug #322123. Print and sheet order dialog fixes. Add non-linear solved.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog9
-rw-r--r--app-office/gnumeric/gnumeric-1.10.5.ebuild77
2 files changed, 85 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 1104563bedb8..f9ffc659bfeb 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/gnumeric
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.200 2010/05/09 13:14:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.201 2010/05/31 22:13:22 eva Exp $
+
+*gnumeric-1.10.5 (01 Jun 2010)
+
+ 01 Jun 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnumeric-1.10.5.ebuild:
+ Version bump, bug #322123. Print and sheet order dialog fixes. Add
+ non-linear solved.
09 May 2010; Pacho Ramos <pacho@gentoo.org> gnumeric-1.10.3.ebuild:
Bump goffice RDEPEND as reported by Priit Laes in bug #319053
diff --git a/app-office/gnumeric/gnumeric-1.10.5.ebuild b/app-office/gnumeric/gnumeric-1.10.5.ebuild
new file mode 100644
index 000000000000..527f8bbfd233
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.10.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.10.5.ebuild,v 1.1 2010/05/31 22:13:22 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 flag-o-matic python
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="gnome perl python"
+# libgda
+
+# lots of missing files, wait for next release
+# also fails tests due to 80-bit long story
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib
+ app-arch/bzip2
+ >=dev-libs/glib-2.12
+ >=gnome-extra/libgsf-1.14.15[gnome?]
+ >=x11-libs/goffice-0.8.5:0.8
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.12
+
+ >=x11-libs/gtk+-2.18
+ x11-libs/cairo[svg]
+ >=gnome-base/libglade-2.3.6
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ perl? ( dev-lang/perl )
+ python? (
+ >=dev-lang/python-2
+ >=dev-python/pygtk-2 )
+"
+# libgda? (
+# >=gnome-extra/libgda-4.1.1:4.0
+# >=gnome-extra/libgnomedb-3.99.6:4.0 )
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=dev-util/pkgconfig-0.18
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS BEVERAGES BUGS ChangeLog HACKING MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-ssindex
+ --disable-static
+ --without-gda
+ --with-zlib
+ $(use_with perl)
+ $(use_with python)
+ $(use_with gnome)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Remove useless .la files
+ find "${D}" -name "*.la" -delete
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}