summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-14 12:20:30 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-14 12:20:30 +0000
commit931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856 (patch)
treebf581caed040d9cc39d891e9ba7b6a2753a422a3 /app-office/tpp/tpp-1.3.1.ebuild
parentInstall documentation in proper directory (diff)
downloadgentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.tar.gz
gentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.tar.bz2
gentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-office/tpp/tpp-1.3.1.ebuild')
-rw-r--r--app-office/tpp/tpp-1.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-office/tpp/tpp-1.3.1.ebuild b/app-office/tpp/tpp-1.3.1.ebuild
new file mode 100644
index 000000000000..2c1c7bd7f5dc
--- /dev/null
+++ b/app-office/tpp/tpp-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.3.1.ebuild,v 1.1 2008/10/14 12:20:30 graaff Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="An ncurses-based presentation tool."
+HOMEPAGE="http://synflood.at/tpp.html"
+SRC_URI="http://synflood.at/tpp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="figlet"
+
+USE_RUBY="ruby18"
+
+RDEPEND="virtual/ruby
+ dev-ruby/ncurses-ruby
+ figlet? ( app-misc/figlet )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}