summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 19:09:57 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 19:09:57 +0000
commit7f1a407632eba5e78b8d8ea58a6f7342d69fa963 (patch)
tree7b57f4cf10e55dfd3a707532fe3bffd8910512df /app-office/texstudio
parentStable for amd64, wrt bug #422461 (diff)
downloadgentoo-2-7f1a407632eba5e78b8d8ea58a6f7342d69fa963.tar.gz
gentoo-2-7f1a407632eba5e78b8d8ea58a6f7342d69fa963.tar.bz2
gentoo-2-7f1a407632eba5e78b8d8ea58a6f7342d69fa963.zip
app-office/texstudio: Fix for gcc-4.7, #422619
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-office/texstudio')
-rw-r--r--app-office/texstudio/ChangeLog6
-rw-r--r--app-office/texstudio/files/texstudio-2.3-gcc47.patch41
-rw-r--r--app-office/texstudio/texstudio-2.3.ebuild7
3 files changed, 51 insertions, 3 deletions
diff --git a/app-office/texstudio/ChangeLog b/app-office/texstudio/ChangeLog
index 46f9912a7091..8bf5c78b8ef5 100644
--- a/app-office/texstudio/ChangeLog
+++ b/app-office/texstudio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/texstudio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.3 2012/05/03 20:00:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.4 2012/06/20 19:09:57 jlec Exp $
+
+ 20 Jun 2012; Justin Lecher <jlec@gentoo.org> texstudio-2.3.ebuild,
+ +files/texstudio-2.3-gcc47.patch:
+ Fix for gcc-4.7, #422619
03 May 2012; Jeff Horelick <jdhore@gentoo.org> texstudio-2.2.ebuild,
texstudio-2.3.ebuild:
diff --git a/app-office/texstudio/files/texstudio-2.3-gcc47.patch b/app-office/texstudio/files/texstudio-2.3-gcc47.patch
new file mode 100644
index 000000000000..faa5173720b8
--- /dev/null
+++ b/app-office/texstudio/files/texstudio-2.3-gcc47.patch
@@ -0,0 +1,41 @@
+ qcodeedit/lib/document/qdocumentcommand.cpp | 1 +
+ qtsingleapplication/qtlocalpeer.cpp | 6 +++---
+ 2 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/qcodeedit/lib/document/qdocumentcommand.cpp b/qcodeedit/lib/document/qdocumentcommand.cpp
+index 308e4e4..35b7d9f 100644
+--- a/qcodeedit/lib/document/qdocumentcommand.cpp
++++ b/qcodeedit/lib/document/qdocumentcommand.cpp
+@@ -32,6 +32,7 @@
+ \brief The base class for document editing command
+ */
+
++#include <unistd.h>
+
+ /*!
+ \brief ctor
+diff --git a/qtsingleapplication/qtlocalpeer.cpp b/qtsingleapplication/qtlocalpeer.cpp
+index 120a8e8..cab57cd 100644
+--- a/qtsingleapplication/qtlocalpeer.cpp
++++ b/qtsingleapplication/qtlocalpeer.cpp
+@@ -48,9 +48,9 @@
+ #include "qtlocalpeer.h"
+ #include <QtCore/QCoreApplication>
+ #include <QtCore/QTime>
+-#if QT_VERSION >= 0x040600
++#if QT_VERSION >= 0x040600
+ #include <QtCore/QProcessEnvironment>
+-#endif
++#endif
+
+ #if defined(Q_OS_WIN)
+ #include <QtCore/QLibrary>
+@@ -103,7 +103,7 @@ QtLocalPeer::QtLocalPeer(QObject* parent, const QString &appId)
+ socketName += QLatin1Char('-') + QString::number(sessionId, 16);
+ }
+ #else
+- socketName += QLatin1Char('-') + QString::number(::getuid(), 16);
++ socketName += QLatin1Char('-') + QString::number(QtLP_Private::getuid(), 16);
+ #endif
+
+ server = new QLocalServer(this);
diff --git a/app-office/texstudio/texstudio-2.3.ebuild b/app-office/texstudio/texstudio-2.3.ebuild
index 6756f0b5e84d..099eaa8c3517 100644
--- a/app-office/texstudio/texstudio-2.3.ebuild
+++ b/app-office/texstudio/texstudio-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.3.ebuild,v 1.2 2012/05/03 20:00:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.3.ebuild,v 1.3 2012/06/20 19:09:57 jlec Exp $
EAPI=4
@@ -36,7 +36,10 @@ DEPEND="${COMMON_DEPEND}
S="${WORKDIR}"/${P/-/}
-PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-hunspell.patch"
+ "${FILESDIR}/${P}-gcc47.patch"
+ )
src_prepare() {
find hunspell -delete