summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-28 10:58:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-28 10:58:49 +0000
commit8c0bade63eb3800d24431fe76250edc5858585e3 (patch)
treeed1677a86026bc670b4ca5ff9cda3019c9cc644e /app-office/texmaker
parentMoved patch to mirror (diff)
downloadgentoo-2-8c0bade63eb3800d24431fe76250edc5858585e3.tar.gz
gentoo-2-8c0bade63eb3800d24431fe76250edc5858585e3.tar.bz2
gentoo-2-8c0bade63eb3800d24431fe76250edc5858585e3.zip
version bump, bug #248921
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-1.80-hunspell.patch74
-rw-r--r--app-office/texmaker/texmaker-1.80.ebuild75
3 files changed, 156 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 378197e34726..b11e4c8529c1 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.51 2008/11/26 12:58:02 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.52 2008/11/28 10:58:49 aballier Exp $
+
+*texmaker-1.80 (28 Nov 2008)
+
+ 28 Nov 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/texmaker-1.80-hunspell.patch, +texmaker-1.80.ebuild:
+ version bump, bug #248921
26 Nov 2008; Ferris McCormick <fmccor@gentoo.org> texmaker-1.71-r1.ebuild:
Sparc stable, Bug #245518.
diff --git a/app-office/texmaker/files/texmaker-1.80-hunspell.patch b/app-office/texmaker/files/texmaker-1.80-hunspell.patch
new file mode 100644
index 000000000000..410e3beae534
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-1.80-hunspell.patch
@@ -0,0 +1,74 @@
+Index: texmaker-1.8/spellerdialog.h
+===================================================================
+--- texmaker-1.8.orig/spellerdialog.h
++++ texmaker-1.8/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+Index: texmaker-1.8/texmaker.pro
+===================================================================
+--- texmaker-1.8.orig/texmaker.pro
++++ texmaker-1.8/texmaker.pro
+@@ -2,7 +2,8 @@ TEMPLATE = app
+ LANGUAGE = C++
+ TARGET = texmaker
+ QT += network
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ ###############################
+ HEADERS += texmaker.h \
+ dsingleapplication.h \
+@@ -35,25 +36,7 @@ HEADERS += texmaker.h \
+ spellerdialog.h \
+ pstrickslistwidget.h \
+ blockdata.h \
+- parenmatcher.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/w_char.hxx
++ parenmatcher.h
+ SOURCES += main.cpp \
+ dsingleapplication.cpp \
+ texmaker.cpp \
+@@ -85,18 +68,7 @@ SOURCES += main.cpp \
+ webpublishdialog.cpp \
+ spellerdialog.cpp \
+ pstrickslistwidget.cpp \
+- parenmatcher.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/hunzip.cxx
++ parenmatcher.cpp
+ RESOURCES += texmaker.qrc
+ FORMS += findwidget.ui\
+ gotolinedialog.ui \
diff --git a/app-office/texmaker/texmaker-1.80.ebuild b/app-office/texmaker/texmaker-1.80.ebuild
new file mode 100644
index 000000000000..c48cb86aa95a
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.80.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.80.ebuild,v 1.1 2008/11/28 10:58:49 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator qt4
+
+DESCRIPTION="A nice LaTeX-IDE"
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ || ( ( x11-libs/qt-gui x11-libs/qt-core ) =x11-libs/qt-4.3*:4 )
+ >=app-text/hunspell-1.2.4"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-hunspell.patch"
+}
+
+src_compile() {
+ eqmake4 texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+
+ make_desktop_entry texmaker Texmaker "/usr/share/pixmaps/texmaker/texmaker48x48.png" Office
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+ elog
+}