summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-11 19:35:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-11 19:35:15 +0000
commit265089dd4d3e375383c6fa193a18a2abfa76f1c0 (patch)
tree4dad86981254d1ecb2307e7797b633d3b320c400 /app-office/texmaker
parentversion bump (diff)
downloadgentoo-2-265089dd4d3e375383c6fa193a18a2abfa76f1c0.tar.gz
gentoo-2-265089dd4d3e375383c6fa193a18a2abfa76f1c0.tar.bz2
gentoo-2-265089dd4d3e375383c6fa193a18a2abfa76f1c0.zip
version bump, thanks to Dustin Surawicz <gentoobugs.20.dsurawicz@spamgourmet.com> for reporting in bug #220617
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/texmaker-1.71.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 053326a8fd37..3192d79795f8 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.41 2008/01/26 11:43:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.42 2008/05/11 19:35:15 aballier Exp $
+
+*texmaker-1.71 (11 May 2008)
+
+ 11 May 2008; Alexis Ballier <aballier@gentoo.org> +texmaker-1.71.ebuild:
+ version bump, thanks to Dustin Surawicz
+ <gentoobugs.20.dsurawicz@spamgourmet.com> for reporting in bug #220617
26 Jan 2008; Alexis Ballier <aballier@gentoo.org>
-texmaker-1.11-r1.ebuild, -texmaker-1.30.ebuild, -texmaker-1.40.ebuild,
diff --git a/app-office/texmaker/texmaker-1.71.ebuild b/app-office/texmaker/texmaker-1.71.ebuild
new file mode 100644
index 000000000000..be6632aa84f1
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.71.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.71.ebuild,v 1.1 2008/05/11 19:35:15 aballier Exp $
+
+EAPI=1
+
+inherit eutils versionator qt4
+
+DESCRIPTION="A nice LaTeX-IDE"
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ || ( ( x11-libs/qt-gui x11-libs/qt-core ) >=x11-libs/qt-4.3.0:4 )"
+
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm"
+
+src_compile() {
+ eqmake4 texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+
+ make_desktop_entry texmaker Texmaker "/usr/share/pixmaps/texmaker/texmaker48x48.png" Office
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+ elog
+}