summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-02 15:07:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-02 15:07:23 +0000
commit0bea74425b31cdb3b4d2edafac4ed68c67c30b45 (patch)
tree310aadcc1b6bb5ae45483564f6d4610808cf9a97 /app-office/texmaker
parentStable for HPPA (LuckyLuke). (diff)
downloadgentoo-2-0bea74425b31cdb3b4d2edafac4ed68c67c30b45.tar.gz
gentoo-2-0bea74425b31cdb3b4d2edafac4ed68c67c30b45.tar.bz2
gentoo-2-0bea74425b31cdb3b4d2edafac4ed68c67c30b45.zip
fix hunspell detection by using pkgconfig, by René 'Necoro' Neumann <gentoo@necoro.eu>, bug #229729
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog7
-rw-r--r--app-office/texmaker/files/texmaker-1.71-hunspell.patch23
-rw-r--r--app-office/texmaker/texmaker-1.71-r1.ebuild9
3 files changed, 25 insertions, 14 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 1796193db30e..3b34d50af5f1 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.44 2008/05/13 20:34:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.45 2008/07/02 15:07:22 aballier Exp $
+
+ 02 Jul 2008; Alexis Ballier <aballier@gentoo.org>
+ files/texmaker-1.71-hunspell.patch, texmaker-1.71-r1.ebuild:
+ fix hunspell detection by using pkgconfig, by René 'Necoro' Neumann
+ <gentoo@necoro.eu>, bug #229729
*texmaker-1.71-r1 (13 May 2008)
diff --git a/app-office/texmaker/files/texmaker-1.71-hunspell.patch b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
index 39e1712633bc..2845196476bc 100644
--- a/app-office/texmaker/files/texmaker-1.71-hunspell.patch
+++ b/app-office/texmaker/files/texmaker-1.71-hunspell.patch
@@ -1,5 +1,6 @@
---- spellerdialog.h.old 2008-05-13 09:55:46.000000000 +0200
-+++ spellerdialog.h 2008-05-13 09:56:06.000000000 +0200
+diff -r 9450ca28545a spellerdialog.h
+--- a/spellerdialog.h Fri Jun 27 20:29:16 2008 +0200
++++ b/spellerdialog.h Fri Jun 27 20:39:29 2008 +0200
@@ -13,7 +13,7 @@
#include "ui_spellerdialog.h"
@@ -9,18 +10,20 @@
#include <QTextCursor>
---- texmaker.pro.old 2008-05-13 10:09:23.000000000 +0200
-+++ texmaker.pro 2008-05-13 10:11:15.000000000 +0200
-@@ -2,6 +2,8 @@
+diff -r 9450ca28545a texmaker.pro
+--- a/texmaker.pro Fri Jun 27 20:29:16 2008 +0200
++++ b/texmaker.pro Fri Jun 27 20:39:29 2008 +0200
+@@ -1,7 +1,8 @@
+ TEMPLATE = app
LANGUAGE = C++
TARGET = texmaker
- CONFIG += qt warn_off release
-+INCLUDEPATH += "/usr/include/hunspell"
-+LIBS += "-lhunspell"
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
###############################
HEADERS += texmaker.h \
symbollistwidget.h \
-@@ -32,22 +34,7 @@
+@@ -32,22 +33,7 @@
webpublishdialog.h \
spellerdialog.h \
pstrickslistwidget.h \
@@ -44,7 +47,7 @@
SOURCES += main.cpp \
texmaker.cpp \
symbollistwidget.cpp \
-@@ -77,16 +64,7 @@
+@@ -77,16 +63,7 @@
aboutdialog.cpp \
webpublishdialog.cpp \
spellerdialog.cpp \
diff --git a/app-office/texmaker/texmaker-1.71-r1.ebuild b/app-office/texmaker/texmaker-1.71-r1.ebuild
index a9fc618083ee..46bf478bbdd8 100644
--- a/app-office/texmaker/texmaker-1.71-r1.ebuild
+++ b/app-office/texmaker/texmaker-1.71-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.71-r1.ebuild,v 1.1 2008/05/13 20:34:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.71-r1.ebuild,v 1.2 2008/07/02 15:07:22 aballier Exp $
EAPI=1
@@ -31,17 +31,20 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
-DEPEND="x11-libs/libX11
+COMMON_DEPEND="x11-libs/libX11
x11-libs/libXext
|| ( ( x11-libs/qt-gui x11-libs/qt-core ) >=x11-libs/qt-4.3.0:4 )
>=app-text/hunspell-1.2.2"
-RDEPEND="${DEPEND}
+RDEPEND="${COMMON_DEPEND}
virtual/latex-base
app-text/psutils
virtual/ghostscript
media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
src_unpack() {
unpack ${A}
cd "${S}"