summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-11-29 12:12:55 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-11-29 12:12:55 +0000
commitad7043d7a5213bd8e43506a8396aa01660c9728d (patch)
treeca7763a555a59a3bb811e16140575934815f8419 /app-office/texmacs
parentRemove git bash completion script, as it's delivered with git itself (diff)
downloadgentoo-2-ad7043d7a5213bd8e43506a8396aa01660c9728d.tar.gz
gentoo-2-ad7043d7a5213bd8e43506a8396aa01660c9728d.tar.bz2
gentoo-2-ad7043d7a5213bd8e43506a8396aa01660c9728d.zip
Version bump
(Portage version: 2.2_rc54/cvs/Linux i686)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog8
-rw-r--r--app-office/texmacs/files/texmacs-1.0.7.3-strip.patch14
-rw-r--r--app-office/texmacs/texmacs-1.0.7.3.ebuild64
3 files changed, 85 insertions, 1 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index fb2de0abec64..065fdbb16468 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmacs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.76 2009/10/11 06:13:40 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.77 2009/11/29 12:12:55 grozin Exp $
+
+*texmacs-1.0.7.3 (29 Nov 2009)
+
+ 29 Nov 2009; Andrey Grozin <grozin@gentoo.org> +texmacs-1.0.7.3.ebuild,
+ +files/texmacs-1.0.7.3-strip.patch:
+ Version bump
11 Oct 2009; Andrey Grozin <grozin@gentoo.org> -texmacs-1.0.6.14.ebuild,
-files/texmacs-1.0.6.14.patch:
diff --git a/app-office/texmacs/files/texmacs-1.0.7.3-strip.patch b/app-office/texmacs/files/texmacs-1.0.7.3-strip.patch
new file mode 100644
index 000000000000..b6e660eac900
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.0.7.3-strip.patch
@@ -0,0 +1,14 @@
+Index: TeXmacs-1.0.7.1-src/Makefile.in
+===================================================================
+--- TeXmacs-1.0.7.1-src.orig/Makefile.in
++++ TeXmacs-1.0.7.1-src/Makefile.in
+@@ -130,9 +130,7 @@ INSTALL:
+ $(CP) $(tmdir)/bin/tm_gs $(DESTDIR)$(tmbin)/bin
+ $(CP) $(tmdir)/plugins/*/bin/* $(DESTDIR)$(tmbin)/bin
+ $(CP) $(tmdir)/plugins/*/lib/*.$(so) $(DESTDIR)$(tmbin)/lib 2>/dev/null || :
+- $(STRIP) $(DESTDIR)$(tmbin)/bin/texmacs.bin
+ $(CP) $(tmdir)/lib/*.$(so) $(DESTDIR)$(tmbin)/lib 2>/dev/null || :
+- $(STRIP) $(DESTDIR)$(tmbin)/lib/*.$(so) 2>/dev/null || :
+ $(CHMOD) 755 $(DESTDIR)$(tmbin)/bin/*
+ $(CHMOD) 755 $(DESTDIR)$(tmbin)/lib/*.$(so) 2>/dev/null || :
+ $(RM) $(DESTDIR)$(tmbin)/lib/*.a
diff --git a/app-office/texmacs/texmacs-1.0.7.3.ebuild b/app-office/texmacs/texmacs-1.0.7.3.ebuild
new file mode 100644
index 000000000000..5a3e09216240
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.3.ebuild,v 1.1 2009/11/29 12:12:55 grozin Exp $
+EAPI=2
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ virtual/ghostscript
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_prepare() {
+ # don't strip
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}