summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-01-02 18:48:31 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-01-02 18:48:31 +0000
commit34b0301cfef0c9d959b3fa15b9a243d5ef9b0bd9 (patch)
tree9a9bd70078c8f4fd9095dbbf3fb61012bd2c7650 /app-office/texmacs
parentStable for HPPA (bug #250752). (diff)
downloadgentoo-2-34b0301cfef0c9d959b3fa15b9a243d5ef9b0bd9.tar.gz
gentoo-2-34b0301cfef0c9d959b3fa15b9a243d5ef9b0bd9.tar.bz2
gentoo-2-34b0301cfef0c9d959b3fa15b9a243d5ef9b0bd9.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog10
-rw-r--r--app-office/texmacs/files/texmacs-1.0.7.1-strip.patch11
-rw-r--r--app-office/texmacs/texmacs-1.0.7.1.ebuild67
3 files changed, 86 insertions, 2 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 7060d916d931..af91e7416547 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmacs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.67 2008/11/02 07:14:43 grozin Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.68 2009/01/02 18:48:31 grozin Exp $
+
+*texmacs-1.0.7.1 (03 Jan 2009)
+
+ 03 Jan 2009; Andrey Grozin <grozin@gentoo.org>
+ +files/texmacs-1.0.7.1-strip.patch, +texmacs-1.0.7.1.ebuild:
+ Version bump
*texmacs-1.0.7 (02 Nov 2008)
diff --git a/app-office/texmacs/files/texmacs-1.0.7.1-strip.patch b/app-office/texmacs/files/texmacs-1.0.7.1-strip.patch
new file mode 100644
index 000000000000..838d770685ae
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.0.7.1-strip.patch
@@ -0,0 +1,11 @@
+diff -r -U2 TeXmacs-1.0.7-src.orig/Makefile.in TeXmacs-1.0.7-src/Makefile.in
+--- TeXmacs-1.0.7-src.orig/Makefile.in 2008-10-16 13:41:18.000000000 +0700
++++ TeXmacs-1.0.7-src/Makefile.in 2008-11-02 18:20:51.000000000 +0600
+@@ -129,7 +129,5 @@
+ $(CP) $(tmdir)/plugins/*/bin/* $(DESTDIR)$(tmbin)/bin
+ $(CP) $(tmdir)/plugins/*/lib/*.$(so) $(DESTDIR)$(tmbin)/lib 2>/dev/null || :
+- $(STRIP) $(DESTDIR)$(tmbin)/bin/texmacs.bin
+ $(CP) $(tmdir)/lib/*.$(so) $(DESTDIR)$(tmbin)/lib 2>/dev/null || :
+- $(STRIP) $(DESTDIR)$(tmbin)/lib/*.$(so) 2>/dev/null || :
+ $(CHMOD) 755 $(DESTDIR)$(tmbin)/bin/*
+ $(CHMOD) 755 $(DESTDIR)$(tmbin)/lib/*.$(so) 2>/dev/null || :
diff --git a/app-office/texmacs/texmacs-1.0.7.1.ebuild b/app-office/texmacs/texmacs-1.0.7.1.ebuild
new file mode 100644
index 000000000000..6c7ee56bf3ba
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.1.ebuild,v 1.1 2009/01/02 18:48:31 grozin Exp $
+EAPI=1
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/latex-base
+ virtual/ghostscript
+ >=dev-scheme/guile-1.4
+ media-libs/freetype
+ x11-libs/libXext
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't strip
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}