summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-09-07 11:19:08 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-09-07 11:19:08 +0000
commit2a16112e70248c14d23f14cc8bfdd9bf1ee113c3 (patch)
tree0250e5f6ca52afaabf42cdc38bc4e4cdd33e1bf9 /app-office/texmacs
parentEnable indi useflag now when we have libindi up-to-date in main tree. (diff)
downloadgentoo-2-2a16112e70248c14d23f14cc8bfdd9bf1ee113c3.tar.gz
gentoo-2-2a16112e70248c14d23f14cc8bfdd9bf1ee113c3.tar.bz2
gentoo-2-2a16112e70248c14d23f14cc8bfdd9bf1ee113c3.zip
texmacs-1.0.7.2 now does not contain the USE flag qt4, and should be stabilized soon; texmacs-1.0.7.2-r1 does contain this flag, and should remain ~arch
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog12
-rw-r--r--app-office/texmacs/texmacs-1.0.7.2-r1.ebuild64
-rw-r--r--app-office/texmacs/texmacs-1.0.7.2.ebuild15
3 files changed, 77 insertions, 14 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index b34984852215..e0ec4cb55eaf 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/texmacs
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.70 2009/04/19 13:19:20 grozin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.71 2009/09/07 11:19:08 grozin Exp $
+
+*texmacs-1.0.7.2-r1 (07 Sep 2009)
+
+ 07 Sep 2009; Andrey Grozin <grozin@gentoo.org> texmacs-1.0.7.2.ebuild,
+ +texmacs-1.0.7.2-r1.ebuild:
+ texmacs-1.0.7.2 now does not contain the USE flag qt4, and should be
+ stabilized soon; texmacs-1.0.7.2-r1 does contain this flag, and should
+ remain ~arch
*texmacs-1.0.7.2 (19 Apr 2009)
diff --git a/app-office/texmacs/texmacs-1.0.7.2-r1.ebuild b/app-office/texmacs/texmacs-1.0.7.2-r1.ebuild
new file mode 100644
index 000000000000..e8d4bb343229
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.2-r1.ebuild,v 1.1 2009/09/07 11:19:08 grozin Exp $
+EAPI=2
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ virtual/ghostscript
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_prepare() {
+ # don't strip
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}
diff --git a/app-office/texmacs/texmacs-1.0.7.2.ebuild b/app-office/texmacs/texmacs-1.0.7.2.ebuild
index e97f63e4105b..0eaee1a22489 100644
--- a/app-office/texmacs/texmacs-1.0.7.2.ebuild
+++ b/app-office/texmacs/texmacs-1.0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.2.ebuild,v 1.1 2009/04/19 13:19:20 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.2.ebuild,v 1.2 2009/09/07 11:19:08 grozin Exp $
EAPI=2
inherit autotools
MY_P=${P/tex/TeX}-src
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
HOMEPAGE="http://www.texmacs.org/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="imlib jpeg netpbm -qt4 svg spell"
+IUSE="imlib jpeg netpbm svg spell"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
RDEPEND="dev-scheme/guile[deprecated]
@@ -21,7 +21,6 @@ RDEPEND="dev-scheme/guile[deprecated]
media-libs/freetype
x11-libs/libXext
x11-apps/xmodmap
- qt4? ( x11-libs/qt-gui:4 )
imlib? ( media-libs/imlib2 )
jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
@@ -33,13 +32,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use qt4; then
- ewarn "Qt port is highly experimental"
- ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
- fi
-}
-
src_prepare() {
# don't strip
epatch "${FILESDIR}"/${P}-strip.patch
@@ -49,8 +41,7 @@ src_prepare() {
src_configure() {
econf $(use_with imlib imlib2) \
- --enable-optimize="${CXXFLAGS}" \
- $(use_enable qt4 qt)
+ --enable-optimize="${CXXFLAGS}"
}
src_install() {