summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-02-04 18:44:40 +0000
committerHanno Böck <hanno@gentoo.org>2010-02-04 18:44:40 +0000
commit33176ba0f23f58b1e609fceb31d440b807cf4425 (patch)
tree6d908693e2abe83a9d5a4ff5c7a2f112d9387975 /app-office/taxbird
parentlibgeier bump (diff)
downloadgentoo-2-33176ba0f23f58b1e609fceb31d440b807cf4425.tar.gz
gentoo-2-33176ba0f23f58b1e609fceb31d440b807cf4425.tar.bz2
gentoo-2-33176ba0f23f58b1e609fceb31d440b807cf4425.zip
taxbird version bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taxbird')
-rw-r--r--app-office/taxbird/ChangeLog10
-rw-r--r--app-office/taxbird/taxbird-0.15.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/app-office/taxbird/ChangeLog b/app-office/taxbird/ChangeLog
index 8b0b8441394c..b9f2aaac8f7d 100644
--- a/app-office/taxbird/ChangeLog
+++ b/app-office/taxbird/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taxbird
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.21 2009/10/18 14:31:19 hanno Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.22 2010/02/04 18:44:40 hanno Exp $
+
+*taxbird-0.15 (04 Feb 2010)
+
+ 04 Feb 2010; Hanno Boeck <hanno@gentoo.org> +taxbird-0.15.ebuild:
+ Version bump, openssl dependency was wrong and discouraged flag in guile
+ is unneeded as it's implied by deprecated-flag.
*taxbird-0.14 (18 Oct 2009)
diff --git a/app-office/taxbird/taxbird-0.15.ebuild b/app-office/taxbird/taxbird-0.15.ebuild
new file mode 100644
index 000000000000..9268c7ec5623
--- /dev/null
+++ b/app-office/taxbird/taxbird-0.15.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.15.ebuild,v 1.1 2010/02/04 18:44:40 hanno Exp $
+
+EAPI="2"
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Taxbird provides a GUI to submit tax forms to the german digital tax project ELSTER."
+HOMEPAGE="http://www.taxbird.de/"
+SRC_URI="http://www.taxbird.de/download/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libgeier-0.11
+ >=gnome-extra/gtkhtml-3.8
+ gnome-base/libgnomeui
+ sys-devel/gettext
+ >=dev-scheme/guile-1.8.0[regex,deprecated]"
+
+src_install() {
+ dodoc README* || die "dodoc failed"
+
+ einstall || die "Installation failed!"
+
+ # clean out the installed mime files, those get recreated in the pkg_postinst function
+ einfo "Deleting mime files in ${D}/usr/share/mime"
+ find "${D}/usr/share/mime/" -type f -maxdepth 1 -delete
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}